8.х работа пользователя с разрешенными кассами

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем serj37, 17 июн 2011.

  1. TopicStarter Overlay
    serj37
    Offline

    serj37

    Регистрация:
    20 мар 2011
    Сообщения:
    23
    Симпатии:
    0
    Баллы:
    1
    Пользователям разрешено перебрасывать наличку с одной кассы на другую, другие кассы согласно расписаным правам в ролях.
    Написал следующее в ВнутреннееПеремещениеНаличныхДенежныхСредств:
    Код:
      Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
    
    Если Ответственный.Пустая() Тогда
    Ответственный = глТекущийПользователь;
    КонецЕсли;
    Если (СокрЛП(ПолноеИмяПользователя()) = "Петров Андрей Викторович") Тогда
    Если Касса <> "Касса выходного дня" и КассаПолучатель <> "Основная ИП" Тогда
    Сообщить("Документ не может быть проведен",СтатусСообщения.ОченьВажное);
    Отказ = Истина;
    Иначе 
    Отказ = Ложь;
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры
    
    
    Этот Петров выбирает нужные кассы (как и прочие другие) и выскакивает - Документ не может быть проведен
    По логике должно записываться/проводиться, в отладчике выражения правильно вычисляются и соответствуют значениям в вышенаписаном коде.... голову сломал... укажите товарисчи гуру где я не прав!
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Касса это что за реквизит?
    Может СокрЛП(Касса)?
  3. TopicStarter Overlay
    serj37
    Offline

    serj37

    Регистрация:
    20 мар 2011
    Сообщения:
    23
    Симпатии:
    0
    Баллы:
    1
    В документе есть реквизиты ссылочного типа - Касса и КассаПолучатель (СправочникСсылка.Кассы)
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Так вы же сравниваете со строкой ссылку....
  5. TopicStarter Overlay
    serj37
    Offline

    serj37

    Регистрация:
    20 мар 2011
    Сообщения:
    23
    Симпатии:
    0
    Баллы:
    1
    Вы совершенно правы!!!
    только теперь при любом 1 правльном значении проводится... а надо при одновременно 2 значения правильных...
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    А скобочки бы поставить (режет глаз) и логическое ИЛИ вместо И.
    Т.е. если одно из условий не выполнено - ошибка
  7. TopicStarter Overlay
    serj37
    Offline

    serj37

    Регистрация:
    20 мар 2011
    Сообщения:
    23
    Симпатии:
    0
    Баллы:
    1
    Всё получилось! Спасибо! Логика у меня видно хромает... будем лечить.. 8)

Поделиться этой страницей