8.х Путь к файлу

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Dem0lisher, 10 фев 2011.

  1. TopicStarter Overlay
    Dem0lisher
    Offline

    Dem0lisher Профессионал в 1С

    Регистрация:
    4 авг 2009
    Сообщения:
    1.026
    Симпатии:
    51
    Баллы:
    54
    Здравствуйте!
    Как реализовать выбор файла? требуется по нажатию кнопки на форме открыть окно выбора файла и при выборе файла получить полный путь строкой.
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.781
    Симпатии:
    509
    Баллы:
    204
    Вот код:
    Код:
    Режим = РежимДиалогаВыбораФайла.Открытие;
    ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(Режим);
    ДиалогОткрытияФайла.ПолноеИмяФайла = "";
    Фильтр = "dbf|*.dbf";
    ДиалогОткрытияФайла.Фильтр = Фильтр;
    ДиалогОткрытияФайла.МножественныйВыбор = Ложь;
    ДиалогОткрытияФайла.Заголовок = "Выберите файл выгрузки";
    
    Если ДиалогОткрытияФайла.Выбрать() Тогда
    ПутьКФайлу = ДиалогОткрытияФайла.ПолноеИмяФайла;
    КонецЕсли;
    
    
  3. yzek
    Offline

    yzek Опытный в 1С

    Регистрация:
    13 окт 2010
    Сообщения:
    713
    Симпатии:
    0
    Баллы:
    26
    Разместите на форме поле ввода, добавьте кнопку выбора и в событие при начале выбора напишите примерно следующее:
    Код:
    Процедура ИмяФайлаНачалоВыбора(Элемент, СтандартнаяОбработка)
    Режим = РежимДиалогаВыбораФайла.Открытие;   
    Диал = Новый ДиалогВыбораФайла(Режим);
    Если Диал.Выбрать()Тогда
    ЭтаФорма[Элемент.Имя] = Диал.ПолноеИмяФайла;
    КонецЕсли;
    КонецПроцедуры
    
    

Поделиться этой страницей