8.х пустой реквизит

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем алексий, 24 ноя 2009.

  1. TopicStarter Overlay
    алексий
    Offline

    алексий

    Регистрация:
    24 ноя 2009
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Товарищи, здравствуйте! Я не мастер, я только учусь))Помогите кто может советом. Знаю, что вещь простая, но чот не получается(((
    Требуется найти все негазовые договора у которых не заполнено свойство "Участок Учёта" (можно по коду и так далее не выводить, главное чтоб нужные договора выдавал)
    вот что у меня есть.....

    Код:
    ВЫБРАТЬ
    ДоговорыНеГазовые.Код КАК Код,
    ДоговорыНеГазовые.Ссылка
    ИЗ
    Справочник.ДоговорыНеГазовые КАК ДоговорыНеГазовые
    
    СГРУППИРОВАТЬ ПО
    ДоговорыНеГазовые.Код,
    ДоговорыНеГазовые.Ссылка
    
    УПОРЯДОЧИТЬ ПО
    Код
    
    здесь я вытаскиваю код документа и его наименование, как вытащить все свойства тоже знаю...
    Код:
    ВЫБРАТЬ
    ДоговорыНеГазовые.Код КАК Код,
    ДоговорыНеГазовые.Ссылка,
    ЗначенияСвойствОбъектов.Свойство
    ИЗ
    Справочник.ДоговорыНеГазовые КАК ДоговорыНеГазовые
    ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов
    ПО ДоговорыНеГазовые.Ссылка = ЗначенияСвойствОбъектов.Объект
    
    СГРУППИРОВАТЬ ПО
    ДоговорыНеГазовые.Код,
    ЗначенияСвойствОбъектов.Свойство,
    ДоговорыНеГазовые.Ссылка
    
    УПОРЯДОЧИТЬ ПО
    Код
    
    и как условие на нужное свойство тоже...
    Код:
    где 
    ЗначенияСвойствОбъектов.Свойство=&Свойство
    
    но вот как сделать так, чтобы искалось из всего списка негазовых документов только те, у которых незаполнено свойство "Участок учета"
    Перепробовал по разному-но не получается, что на форуме есть-читал, не помогло или не понял(не знаю), и если можно покажите точно как код писать
    Кстати, 1Сv8.1
    Заранее огромное спасибо!!!!!
  2. solnce
    Offline

    solnce Опытный в 1С

    Регистрация:
    16 июл 2009
    Сообщения:
    61
    Симпатии:
    0
    Баллы:
    26
    "Участок Учета" это как я понимаю реквизит? тут можно все сделать легко в запросе.если "Участок учета" ссылается на что-то,скажем документ или справочник,тогда примерно так:
    Код:
    ТабДок = Новый ТабличныйДокумент;
    Запрос=Новый Запрос;
    Запрос.Текст=
    "ВЫБРАТЬ
    |.....
    |.....
    |ГДЕ
    |ДоговорыНеГазовые.УчастокУчета=&УчастокУчета
    |....
    |.....
    |.....";
    Запрос.УстановитьПараметр("УчастокУчета", Справочники.....ПустаяСсылка());//тут указывается 
    //путь к док или справочнику на который ссылается учаток учета
    
    Результат = Запрос.Выполнить();
    
    ВыборкаДетали = Результат.Выбрать();
    Пока ВыборкаДетали.Следующий() Цикл
    ...........
    КонецЦикла;
    ТабДок.Вывести();
    ТабДок.Показать();
    
    Если ссылки на другой объект нет и УчастокУчета заполняется в самой форме тогда поставь условие:

    Код:
    Запрос=Новый Запрос;
    Запрос.Текст=
    "ВЫБРАТЬ
    |ДоговорыНеГазовые.УчастокУчета КАК УчастокУчета
    |.....
    |.....";
    Результат = Запрос.Выполнить().Выбрать();
    Пока Результат.Следующий() Цикл
    Если  Результат.УчастокУчета=0 И  Результат.УчастокУчета="" И  Результат.УчастокУчета=NULL И  Результат.УчастокУчета=НЕОПРЕДЕЛЕНО 
    И  Результат.УчастокУчета=0 И  Результат.УчастокУчета="" И  Результат.УчастокУчета=NULL И  Результат.УчастокУчета=НЕОПРЕДЕЛЕНО Тогда
    .......
    КонецЕсли;
    КонецЦикла;
    
    Примерно так.Удачи;)

Поделиться этой страницей