7.7 ПУБ Нормы затрат для продукции

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем man37, 19 фев 2016.

  1. TopicStarter Overlay
    man37
    Offline

    man37 Опытный в 1С

    Регистрация:
    10 дек 2013
    Сообщения:
    197
    Симпатии:
    5
    Баллы:
    29
    Здравствуйте, помогите решить задачку!
    В первой таблице выбирается продукт.
    Во второй таблице выводятся материалы, но только на один продукт, который выделен; по кнопке "Используемые материалы продукта" то же выводятся материалы только на выделенный продукт, а хотелось бы на все, выбранные продукты из первой таблицы, что бы потом вывести на печать, т.е.

    Для производства Батон горчичный - 10 шт, Булка городская - 20 шт необходимо:
    мука 1 сорт - 6 кг
    дрожжи - 10 гр.
    сахар - 1 кг и т.д..

    По продуктам вывести на печать получилось, а вот собрать одинаковые материалы вместе и сложить вес не получается.

    Вложения:

  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Только дописывать. Тоже использую ПУБ для хлебного комбината
    man37 нравится это.
  3. TopicStarter Overlay
    man37
    Offline

    man37 Опытный в 1С

    Регистрация:
    10 дек 2013
    Сообщения:
    197
    Симпатии:
    5
    Баллы:
    29
    Не подскажите, что и где дописать.
    С ПУБ столкнулся первый раз.
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Что именно нужно? Реальный расход по документам с заменой на аналоги или нормы расхода?
    man37 нравится это.
  5. TopicStarter Overlay
    man37
    Offline

    man37 Опытный в 1С

    Регистрация:
    10 дек 2013
    Сообщения:
    197
    Симпатии:
    5
    Баллы:
    29
    Мне нужно, собрав заявки на продуты, сделать распечатку необходимых материалов по заявкам, чтобы отпустить их со склада.
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    1) Тупой запрос по заказам с группировкой по продукции.
    2) Выборка запроса.. Разбираем нормы расхода продукции с добавлением в ТаблицуЗначений. ВНИМАНИЕ! Если используются полуфабрикаты их нужно тоже "разворачивать" по нормам
    3) Свернуть ТЗ и вывести результат
  7. TopicStarter Overlay
    man37
    Offline

    man37 Опытный в 1С

    Регистрация:
    10 дек 2013
    Сообщения:
    197
    Симпатии:
    5
    Баллы:
    29
    Вот и фиг то в том, что у меня проблемы с этим "Тупой запрос" и "Выборка запроса".
    Не могли бы Вы накидать приблизительный код?
    --- Объединение сообщений, 20 фев 2016 ---
    Если делаю так:
    Код:
       
    Таблица.ВыбратьСтроки();
    Пока Таблица.ПолучитьСтроку() = 1 Цикл
        ПолучитьТекущиеНормыЗатрат();  
        Если ТекущиеНормыЗатрат.Выбран() = 1 Тогда 
            Док = СоздатьОбъект("Документ.НормыЗатрат");
            Док.НайтиДокумент(ТекущиеНормыЗатрат);
            Док.ВыгрузитьТабличнуюЧасть(СписокНормыЗатрат,"ВидЭлемента,Элемент,Кво,Ед");
            СписокНормыЗатрат.ВыбратьСтроки();
                Пока СписокНормыЗатрат.ПолучитьСтроку() = 1 Цикл
            Сообщить (СписокНормыЗатрат.Элемент);
            Сообщить (СписокНормыЗатрат.Кво);
            Сообщить (СписокНормыЗатрат.Ед);
            КонецЦикла;
        КонецЕсли;
    КонецЦикла;
    
    то у меня выбирается почему-то только один элемент из Таблицы, тот, который активен. Что здесь не так.
  8. TopicStarter Overlay
    man37
    Offline

    man37 Опытный в 1С

    Регистрация:
    10 дек 2013
    Сообщения:
    197
    Симпатии:
    5
    Баллы:
    29
    Вот так сообщает:
    Код:
    Процедура ЗаполнитьНормативныйСостав()
       
    Таблица.ВыбратьСтроки();
    Пока Таблица.ПолучитьСтроку() = 1 Цикл 
        Сообщить ("Выбрана строка          " + Таблица.Товар);
           
        Пер = СоздатьОбъект("Периодический");    
        Пер.ИспользоватьОбъект("НормыЗатрат", Таблица.Товар);
        ТекущиеНормыЗатрат = Пер.ЗначениеНаДату(ДатаЗаказа);   
    
        Если ТекущиеНормыЗатрат.Выбран() = 1 Тогда  
            Док = СоздатьОбъект("Документ.НормыЗатрат");
            Док.НайтиДокумент(ТекущиеНормыЗатрат);
            Док.ВыгрузитьТабличнуюЧасть(СписокНормыЗатрат,"ВидЭлемента,Элемент,Кво,Ед");
            СписокНормыЗатрат.ВыбратьСтроки();
                Пока СписокНормыЗатрат.ПолучитьСтроку() = 1 Цикл
                Сообщить (СписокНормыЗатрат.Элемент); Сообщить (СписокНормыЗатрат.Кво); Сообщить (СписокНормыЗатрат.Ед);
            КонецЦикла;
        КонецЕсли;
    КонецЦикла;
    КонецПроцедуры   
    но в таблицу выводит только один Товар.
  9. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Что у вас ТаблицаВыборки?
  10. TopicStarter Overlay
    man37
    Offline

    man37 Опытный в 1С

    Регистрация:
    10 дек 2013
    Сообщения:
    197
    Симпатии:
    5
    Баллы:
    29
    С этим разобрался, только выводит вместе с Материалами и остальные затраты, если подскажите где поставить условие и какое, буду благодарен.
  11. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    В норме расходов есть реквизит ВидЭлемента. Это перечисление..
    Думаю этого достаточно
    Последнее редактирование: 22 фев 2016
    man37 нравится это.
  12. TopicStarter Overlay
    man37
    Offline

    man37 Опытный в 1С

    Регистрация:
    10 дек 2013
    Сообщения:
    197
    Симпатии:
    5
    Баллы:
    29
    Да этого достаточно, Спасибо!
  13. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Не за что. Обращайтесь

Поделиться этой страницей