7.7 ПУБ 355 релиз журнал учета счетов фактур 1137

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем albasv, 25 ноя 2014.

  1. TopicStarter Overlay
    albasv
    Offline

    albasv Опытный в 1С

    Регистрация:
    11 ноя 2011
    Сообщения:
    66
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте, у нас 1с 7.7 ПУБ 355 релиз, сегодня столкнулись с такой проблемой,
    когда начинаем формировать журнал учета счетов фактур 1137, то в поле для счетов фактур с датой с 1.10.2014 и более поле "номер и дата" пустое, а которые имеют дату ранее 01.10.2014 поле заполняетяс правильно, проверила глоб номер , проверила сам журнал, так понимаю что загвоздка в новом формате, смотрю формулу гото столбца "Таблица 735" Часть2 столбец № 4"Дата и номер счетафактуры"
    формула [СокрЛП(глПреобразоватьНомерДок(НомерСчетаФактуры))];[ДатаСчетаФактуры]
    а сообразить не могу, подскажите что надо поправить, заранее очень признательны
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Не корректно обновились. Ошибки выскакивали?
  3. TopicStarter Overlay
    albasv
    Offline

    albasv Опытный в 1С

    Регистрация:
    11 ноя 2011
    Сообщения:
    66
    Симпатии:
    0
    Баллы:
    26
    вобщем нашла в глоб модуле процедуру и поправила ее

    Функция глСформироватьДатуНомерСчетаФактуры(Конт) Экспорт


    ФормироватьПоПостановлению735 = 0;

    Если Конт.ДатаДокВходящий >= '01.10.2014' Тогда
    ФормироватьПоПостановлению735 = 1;
    КонецЕсли;

    Если ФормироватьПоПостановлению735 = 0 Тогда
    Возврат Формат(Конт.ДатаДокВходящий, "Д ДДММГГГГ") + " №" + Конт.НомерДокВходящий;
    Иначе
    Возврат "№" + СокрЛП(Конт.НомерДокВходящий) + "; " +Формат(Конт.ДатаДокВходящий, "Д ДДММГГГГ");
    // а было Возврат Конт.НомерДокВходящий + "; " +Формат(Конт.ДатаДокВходящий, "Д ДДММГГГГ");
    КонецЕсли;

    Возврат Формат(Конт.ДатаДокВходящий, "Д ДДММГГГГ") + " №" + Конт.НомерДокВходящий;
    КонецФункции // глСформироватьДатуНомерСчетаФактуры()

    вобщем без символа "№" не хочет правильно разбираться то поле, првда теперь в столбце 4 печатаются две лишние точки типа "71;11.10.2014 . ."
    получается надо надо смотреть еще и процедуру глПреобразоватьНомерДок, может кто поправит ее?
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    С какого релиза переходили на 355
  5. TopicStarter Overlay
    albasv
    Offline

    albasv Опытный в 1С

    Регистрация:
    11 ноя 2011
    Сообщения:
    66
    Симпатии:
    0
    Баллы:
    26
Похожие темы
  1. American
    Ответов:
    5
    Просмотров:
    1.439
  2. skurser
    Ответов:
    10
    Просмотров:
    3.470
  3. consol
    Ответов:
    8
    Просмотров:
    1.462
  4. sacredlore
    Ответов:
    5
    Просмотров:
    941
  5. BurSer
    Ответов:
    6
    Просмотров:
    1.978
Загрузка...

Поделиться этой страницей