7.7 проводность и непроводность документов

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем anton, 11 авг 2009.

  1. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    вопрос таков я делал внешку для отмены проводности документов
    Она выглядела так
    Код:
    //*******************************************
    Процедура Сформировать()
    Док = СоздатьОбъект("Документ");
    Док.ОбратныйПорядок(1);
    Док.ВыбратьДокументы(Дата1,);
    //Док.ВыбратьДокументы();
    Пока Док.ПолучитьДокумент() = 1 Цикл
    Если Док.Проведен()=1 Тогда
    Док.СделатьНеПроведенным();
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры
    
    

    Теперь не могу допетрить как мне назад документы проведеными сделать


    Код:
    Процедура Сформировать()
    Док = СоздатьОбъект("Документ");
    Док.ОбратныйПорядок(1);
    Док.ВыбратьДокументы(Дата1,);
    //Док.ВыбратьДокументы();
    Пока Док.ПолучитьДокумент() = 0 Цикл
    Если Док.Проведен() = 0 Тогда
    Док.СделатьПроведенным();
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры
    
    
    если вот так то 1с сразу виснит может я вобще че не правельно делую или ошибся в чем подскажите???? :smile: :unsure:
  2. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    Код:
    Пока Док.ПолучитьДокумент() = 1 Цикл  //цикл бесконечный у тебя был и условие не выполнялось после того как до конца выборки дошло
    Если Док.Проведен() = 0 Тогда
    Док.Провести();
    Message(Док.CurrentDocument()); //это чтобы следить за ходом проведения и не думать, что 1С отвис
    КонецЕсли;
    
    
    
    
    
    P.S. проводность это чо-то из физики.. теплопроводность %)
  3. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    Он проводит но совсем не те документы допустим на какоенибудь число выбираеш ну на 13.07.08
    Говорит сначала что "изменения в розничные цены внесены не будут т.к документ проводится задним числом" нажимаеш "ок" и он проводит предворительные калькуляции вообще за 04.08.08!!! и вконце вываливает ошибку
    :unsure: color=#CC0000]ERR[/color] {E:\BASE\DB\EXTFORMS\ДОКУМЕНТ ПРОВЕСТИ.ERT(9)}: Документ не может быть проведен!
  4. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    Код:
    Док = СоздатьОбъект("Документ");
    
    
    с таким объектом, по идее, обработка должна проводить все непроведенные документы.. а в ручную пробовал пару документов провести?) что за конфа?
    ну и еще сомнение вызывает эта запись "Док.ОбратныйПорядок(1);"
  5. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    нет ну видиш проводность документов же снимает по определенное число!!!! а назад провести не хочет толи зацыкливается то ли, мне кажется он их не проводит потому что они подчинены другим но тоже попробовао я вобще за весь год проводки снял а он мне всего лиш потом 4 документа провел и то за 4.08.09 предворительные каклькуляци а остальные оставил выдал ошибку не возможно провести документ и все цикл остановился!!! ну а вручную то они проводятся! беда в том что иногда бывает нужно многое поменять но для этого проводность нужно снять докуме6нтов а потом назад их по одному тыкать очень не удобно!!!

    Код:
    "Док.ОбратныйПорядок(1);
    
    а что сдесь не так!!!

    А конфа эта штрих-м ресторан бэк офис v4 странная кокая то она!!!! у меня сней вообше проблемы вот такого характера!!! http://www.1c-pro.ru/index.php?showtopic=18738
  6. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    ОбратныйПорядок устанавливает тебе порядок выборки с конца.. я понимаю при снятии с проведения его применение.. а если ты проводишь то как раз тебе с начала все проводить надо.. далее зачем тебе вообще с нимать, судя по всему тебе просто нужно перепроводить документы.. тоесть заново провести с самого начала и все если в твоей конфе нет обработки для востановления последовательности документов и нет групповой обработки документов
  7. TopicStarter Overlay
    anton
    Offline

    anton Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    187
    Симпатии:
    0
    Баллы:
    26
    Убрал я обратный порядок и все заработало но не совсем все!!!!

    Вот такя откладка идет
    Код:
    Проведение документа Приходная накл № 1\ПНк-0001822 от 12.02.09
    Документ <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/не')">не может быть перепроведен, так как имеются более поздние проведенные документы!</span>
    Документ <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/не')">не проведен! :Приходная накл 1\ПНк-0001822</span>
    Приходная накл 1\ПНк-0001822
    Документ проведен.
    Предв.Калькуляция 1\Кк-00002171
    Проведение документа Приходная накл № 1\ПНк-0001825 от 12.02.09
    Документ <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/не')">не может быть перепроведен, так как имеются более поздние проведенные документы!</span>
    Документ <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/не')">не проведен! :Приходная накл 1\ПНк-0001825</span>
    Приходная накл 1\ПНк-0001825
    Документ <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/не')">не может быть перепроведен, так как имеются более поздние проведенные документы!</span>
    Документ <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/не')">не проведен! :Акт списанияоведен! :Акт списания 1\Спс-0000545</span>
    Акт списания 1\Спс-0000545 1\Спс-0000545т списанияоведен! :Акт списания 1\Спс-0000545
    Акт списания 1\Спс-0000545 1\Спс-0000545
    Акт списания 1\Спс-0000545
    На складе нет номенклатуры: Вода
    в количестве: 0.2 кг
    На складе нет номенклатуры: Вода
    в количестве: 0.2 кг
    На складе нет номенклатуры: Вода
    в количестве: 0.2 кг
    На товар Кофе натур.со сливк 0,2 Розничная цена по документу: 35.00 Действуюшая цена : 30.00
    
    На товар Чай (СОТР.) Розничная цена по документу: 2.00 Действуюшая цена : 3.00
    
    На товар Чай Листовой Розничная цена по документу: 25.00 Действуюшая цена : 20.00
    
    Изменения в розничные цены внесены не будут так документ проводится задним числом.
    Документ проведен.
    Наряд на приготовление блюд 1\НПб-0001425
    Проведение документа Отчет отдела № 1\ООП-0001430 от 12.02.09
    Документ <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/не')">не может быть перепроведен, так как имеются более поздние проведенные документы!</span>
    Документ <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/не')">не проведен! :Отчет отдела 1\ООП-0001430</span>
    Отчет отдела 1\ООП-0001430
    Док.Провести(); 
    {E:\BASE\DB\EXTFORMS\ДОКУМЕНТ ПРОВЕСТИ.ERT(8)}: Документ не может быть проведен!
    
    я так понимаю он останавливается и дальше их проводить не хочит и как решить проблему С "Документ не может быть перепроведен, так как имеются более поздние проведенные документы!"????
  8. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    см. точку актуальности, границу последовательности
  9. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    да ТА перекинь в самый конец (Операции, управление опер. итогами)...
    а не проводится у тебя

    "Отчет отдела 1\ООП-0001430 " я так понимаю.. попробуй его в ручную провести, что напишет тебе..

Поделиться этой страницей