7.7 Проводка с НИО

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем змейкин, 1 май 2013.

  1. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Народ снова вопрос)Как сделать проводки по субконто дебита и кредита чтобы в субконто было наименование реквизитов "Справочника НалогиОтчисления"
    Например если проводка по "ЕСВ" то в проводке было наименование справочника ЕСВ пробовал так)
    Код:
    Нио=СоздатьОбъект("Справочник.НалогиОтчисления");
    Нио.НайтиПоКоду("ЕСВ",0);
    ТекНио=Нио.Наименование;  
    
    Полный Код
    Код:
    Процедура ПроводкиСотрудник()
    ТекВидДеятельности = Сотрудник.ВидДеятельности.Получить(КонМесяца(ДатаДок));
    ТекВидЗатрат = Сотрудник.ВидЗатрат.Получить(КонМесяца(ДатаДок));
    Нио=СоздатьОбъект("Справочник.НалогиОтчисления");
    Нио.НайтиПоКоду("ЕСВ",0);
    ТекНио=Нио.Наименование;  
    МесяцНачЗП = НачМесяца(ДатаДок);
    глПроводка(Контекст,"92",Подразделение,Начислено,"НачисленоЗП",,ТекВидДеятельности,ТекВидЗатрат,Сотрудник,МесяцНачЗП,"Проводка");
    глПроводка(Контекст,Подразделение,"651",ЕдСоцВзнос,"УдержанЕСВ",,Сотрудник,МесяцНачЗП,ТекНио,,"Проводка");
    глПроводка(Контекст,Подразделение,"6411",НДФЛ,"Удержано По НДФЛ",,Сотрудник,МесяцНачЗП,,,"Проводка");
    глПроводка(Контекст,"92","651",Налог,"Удержано По ЕСВ(СВЕРХУ 36.76%)",,ТекВидДеятельности,ТекВидЗатрат,Сотрудник,,"Проводка");
    Если МатПомощ>0 Тогда
    глПроводка(Контекст,Подразделение,Подразделение,МатПомощ,"МатериальнаяПомощь",,,,Сотрудник,МесяцНачЗП,"Проводка");
    КонецЕсли;
    Если Отпускные>0 Тогда
    глПроводка(Контекст,Подразделение,Подразделение,Отпускные,"Отпускные",,,,Сотрудник,МесяцНачЗП,"Проводка");
    КонецЕсли;
    
    КонецПроцедуры
    //************************************************************************************************************************************************
    Процедура ОбработкаПроведения()
    
    Если ПроверкаШапки() = 0 Тогда
    СтатусВозврата(0);
    КонецЕсли;
    
    ВыбратьСтроки();
    Пока ПолучитьСтроку()>0 Цикл
    ПроверкаСтроки();
    КонецЦикла;
    
    Если ВидВыплат = Перечисление.ВидыВыплат.Аванс Тогда
    Операция.Содержание = "Начисление аванса за "+Формат(ДатаДок,"Д ММММГГГГ")+" "+Примечание;
    Операция.Записать();
    Возврат;
    КонецЕсли;
    
    МесяцНачЗП = НачМесяца(ДатаДок);
    
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
    Если ВидВыплат = Перечисление.ВидыВыплат.ЗП Тогда
    ПроводкиСотрудник();
    КонецЕсли;
    КонецЦикла;
    
    Операция.СуммаОперации = Итог("КВыплате");
    Операция.Записать();
    КонецПроцедуры
    
  2. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Сделано Спс)

Поделиться этой страницей