7.7 Проверка "помечен на удаление"

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем kisol, 27 ноя 2013.

  1. TopicStarter Overlay
    kisol
    Offline

    kisol Профессионал в 1С

    Регистрация:
    25 июл 2012
    Сообщения:
    386
    Симпатии:
    41
    Баллы:
    54
    Справочник - позиция помечена на удаление, если ее выбираешь выдается:

    ---------------------------
    1С:Предприятие
    ---------------------------
    Объект помечен для удаления - продолжить?
    ---------------------------
    Да Нет
    ---------------------------

    Как изменить это предупреждение на свое? Выдавать свое предупреждение после этого!
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Само предупреждение отключить нет возможности. Системное.
    Свое добавить можете. Проверка события после выбора реквизита.
  3. TopicStarter Overlay
    kisol
    Offline

    kisol Профессионал в 1С

    Регистрация:
    25 июл 2012
    Сообщения:
    386
    Симпатии:
    41
    Баллы:
    54
    Подскажите как правильно иницализировать событие выбора и индентифицировать реквизит "Пометка на удаление"

    Код:
    Если ПометкаНаУдаление=Истина Тогда
    
    Предупреждение("Нельзя выбирать удаленных",60);
    
    КонецЕсли;
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    ДО выбора вы ничего не сделаете ибо не знаете какой элемент будет выбран.
    После - в поле формула свойства реквизита формы.
    Код:
    Процедура ПроверкаУдаления()
    Если ИмяВашегоРеквизита.Выбран()=1 Тогда
    Если ИмяВашегоРеквизита.ПометкаУдаления()=1 Тогда
    ИмяВашегоРеквизита="";//просто обнуляем. Ибо 1с уже вякнула что элемент помечен на удаление. Зачем повторяться?
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры
    

Поделиться этой страницей