[РЕШЕНО] Проверка организации на учетную политику УПП 1.3

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем fenlork, 4 июн 2015.

  1. TopicStarter Overlay
    fenlork
    Offline

    fenlork Опытный в 1С

    Регистрация:
    5 сен 2013
    Сообщения:
    71
    Симпатии:
    0
    Баллы:
    26
    Как сделать проверку на учетную политику организации? Может есть процедура в общих подулях. Нужно проверить в доке Организация работает по упрощенке или по общей системе налогообложения. Даже не знаю как обратится.. если только запросом в рег сведений срезом последних и отбором по нашей организации. Или все же есть продедура?
  2. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.647
    Симпатии:
    948
    Баллы:
    204
    Либо посмотрите вот эту
    ОбщегоНазначения.ПолучитьПараметрыУчетнойПолитикиРегл(Период, Организация, Ложь);
    либо забейте в Глобальный поиск строчку "Политик" и посмотрите
  3. TopicStarter Overlay
    fenlork
    Offline

    fenlork Опытный в 1С

    Регистрация:
    5 сен 2013
    Сообщения:
    71
    Симпатии:
    0
    Баллы:
    26
    Оки, спасибо, поразбираюсь
  4. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    Так ради интереса решил поискать:
    Находится в модуле НалоговыйУчетУСН
    Код:
    //Определяет применяется ли упрощенная система налогообложения
    //
    Функция ПрименениеУСНДоходы(Организация, Знач Дата) Экспорт //~
    
        Если НЕ ЗначениеЗаполнено(Организация) Тогда
            Возврат Ложь;
        КонецЕсли;
       
        Если НЕ ЗначениеЗаполнено(Дата) Тогда
            Дата = ТекущаяДата();
        КонецЕсли;
    
        УчетнаяПолитика = ОбщегоНазначения.ПолучитьПараметрыУчетнойПолитикиРегл(Дата, Организация, Ложь);
        ПрименяетсяУСН = ?(НЕ ЗначениеЗаполнено(УчетнаяПолитика), Ложь, (УчетнаяПолитика.СистемаНалогообложения = Перечисления.СистемыНалогообложения.Упрощенная));
       
        Если НЕ (ПрименяетсяУСН) Тогда
            Возврат Ложь;
        КонецЕсли;
       
        Если УчетнаяПолитика.ОбъектНалогообложенияУСН = Перечисления.ОбъектыНалогообложенияПоУСН.Доходы Тогда
            Возврат Истина;
        Иначе
            Возврат Ложь;
        КонецЕсли;
    
    КонецФункции
    

Поделиться этой страницей