7.7 Проверка НДС

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Peroman, 15 июл 2009.

  1. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Нужна обработка для проверки НДС во всех документах,
    чтобы могла бы и сразу проставлять НДС. Может кто знает готовую обработку.
    Конфигурация: Торговля+склад 7.7

    Вот есть обработка для упрощенки:
    Код:
    Процедура Сформировать()
    Док=СоздатьОбъект("Документ.ПакетПродаж");
    Док.ВыбратьДокументы(НачДата,КонДата);
    Пока Док.ПолучитьДокумент()=1 Цикл
    Док.ВыбратьСтроки();
    Пока Док.ПолучитьСтроку()=1 Цикл
    Если ПустоеЗначение(Док.СтавкаНДС)=1 Тогда
    Сообщить("Док № "+Док.НомерДок+", строка - "+Док.НомерСтроки+" без ставки");
    Док.СтавкаНДС=Док.Номенклатура.СтавкаНДС;
    КонецЕсли;
    Если Док.СуммаНДС=0 Тогда
    Сообщить("Док № "+Док.НомерДок+", строка - "+Док.НомерСтроки+" без НДС");
    Док.СуммаНДС=Окр(Док.Сумма*глВыделяемыйНДС(Док.СтавкаНДС),2,1);
    КонецЕсли;
    КонецЦикла;
    Если Записать=1 Тогда
    Док.Записать();
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры
    
    
    Вопрос такой: можно ли на основе данной обработки написать под ТиС?
    Если да то как(чтобы не для каждого документа, адля всех сразу)?
  2. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    Ну, зачем тебе для всех сразу
    Вбей вместо Документ.ПакетПродаж свой идентификатор
    Для Док.Реализация приведенный код вроде рабочий.
    За другие доки не скажу лень отслеживать, ибо любят 1эсчики в одном доке назвать реквизит СуммаНДС, в другом просто НДС и т.п., никакой совместимости.

Поделиться этой страницей