7.7 проверка наличия схожего товар

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем NovInNik, 16 янв 2012.

  1. TopicStarter Overlay
    NovInNik
    Offline

    NovInNik Опытный в 1С

    Регистрация:
    12 ноя 2007
    Сообщения:
    194
    Симпатии:
    1
    Баллы:
    29
    Добрый день!
    1с7.7 ТиС 9.2
    Появилось желание облегчить ввод номенлатуры, тем самым сократить появление дублирующих элементов номенклатуры. Необходимо при вводе нового элемента справочника Номенклатура проверять на наличие уже введеного товара или похожего (проверка по наименованию, коду поставщика, артикулу). Какие будут предложения? С чего начать? Может у кого есть наработки? Спасибо.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    НайтиПоНаименованию, НайтиПоРеквизиту. Этого достаточно?
  3. TopicStarter Overlay
    NovInNik
    Offline

    NovInNik Опытный в 1С

    Регистрация:
    12 ноя 2007
    Сообщения:
    194
    Симпатии:
    1
    Баллы:
    29
    можно как-то организовать чтобы при вводе значения отображался список с похожим товаром? НайтиПоНаименованию, НайтиПоРеквизиту не слишком долгим будет процесс поиска?
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Все зависит от размера БД. В принципе можно... Но думаю все же достаточно проверки при записи элемента
  5. TopicStarter Overlay
    NovInNik
    Offline

    NovInNik Опытный в 1С

    Регистрация:
    12 ноя 2007
    Сообщения:
    194
    Симпатии:
    1
    Баллы:
    29
    Таким образом, при записи элемента проверять нужные значения? И при их нахождении выводить сообщение о имеющемся. Но опять же целесообразно ли будет перебирать три значения подряд (наименование, код поставщика, артикул). Или как-то можно упростить? Сейчас после очистки пустых и неиспользуемых позиций, на данный момент останется наименований порядка 15-20 тысяч.
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    проще отбор по реквизиту при записи со сравнение по наименованию. просто по наименованию вы найдете только первый попавшийся...
  7. TopicStarter Overlay
    NovInNik
    Offline

    NovInNik Опытный в 1С

    Регистрация:
    12 ноя 2007
    Сообщения:
    194
    Симпатии:
    1
    Баллы:
    29
    Поставщик же может изменить немного название, а другие реквизиты оставить тогда придется проверять и по артикулу (хотя артикул можно проверить таким же образом как и ИНН у клиента проверяется). Может есть какие наработки. Ладно буду пробовать.
  8. TopicStarter Overlay
    NovInNik
    Offline

    NovInNik Опытный в 1С

    Регистрация:
    12 ноя 2007
    Сообщения:
    194
    Симпатии:
    1
    Баллы:
    29
    на схожести проверкии ИНН написал проверку по артикулу, прилагаю ниже. Как избавиться от вывода пустого значения, т.е. если Артикула нет. На данный момент выводит весь товар без артикула. Как от этого избавиться. Куда вставить проверку на пустое значение.

    Список = СоздатьОбъект("СписокЗначений");
    Объект = СоздатьОбъект("Справочник.Номенклатура");
    Объект.ВыбратьЭлементыПоРеквизиту("Артикул", Артикул, 0, 0);

    Пока Объект.ПолучитьЭлемент(1) = 1 Цикл
    Если Объект.ТекущийЭлемент() = Артикул Тогда
    Возврат;
    Иначе
    Список.ДобавитьЗначение(Объект.ТекущийЭлемент());
    КонецЕсли;
    КонецЦикла;
    стр="";
    Если Список.РазмерСписка() = 0 Тогда
    Возврат;
    Иначе
    Для Ном=1 по Список.РазмерСписка() Цикл
    значение=Список.ПолучитьЗначение(ном,стр);
    сообщить(""+значение+","+стр);
    КонецЦикла;
    КонецЕсли;
  9. TopicStarter Overlay
    NovInNik
    Offline

    NovInNik Опытный в 1С

    Регистрация:
    12 ноя 2007
    Сообщения:
    194
    Симпатии:
    1
    Баллы:
    29
    "поборол" и эту проблему. Думаю тему можно закрыть. Всем спасибо.

Поделиться этой страницей