8.х Проверка на наличие штрихкода

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Tilda, 19 ноя 2010.

  1. TopicStarter Overlay
    Tilda
    Offline

    Tilda Опытный в 1С

    Регистрация:
    29 июл 2010
    Сообщения:
    70
    Симпатии:
    0
    Баллы:
    26
    Обработка печати ценников со штрихкодами...Нужно проверить, задан ли штрихкод для товара, чтобы при выполнении нижеприведенной функции вылезала не ошибка "Индекс находится за границами массива", а предупреждение, что для товара не задан штрихкод. Я попробовала сделать так:

    Код:
     Функция ПолучитьШК(Товар) Экспорт
    ШК="";
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ ПЕРВЫЕ 1
    |Штрихкоды.Штрихкод КАК Штрихкод
    |ИЗ
    |    РегистрСведений.Штрихкоды КАК Штрихкоды
    |ГДЕ
    |    Штрихкоды.Владелец = &Владелец
    |
    |СГРУППИРОВАТЬ ПО
    |    Штрихкоды.Штрихкод";
    Запрос.УстановитьПараметр("Владелец",Товар);
    Таблица = Запрос.Выполнить().Выгрузить();
    Если Таблица[0].Штрихкод = NULL Тогда
    Предупреждение ("Для товара " + Товар + " не задан штрихкод!");	
    Иначе 
    ШК = Таблица[0].Штрихкод;
    Возврат ШК;
    КонецЕсли;
    КонецФункции
    
    - но у меня не получилось ничего, по-прежнему вылазит эта ошибка.
    Помогите, пожалуйста! Заранее спасибо!
  2. TopicStarter Overlay
    Tilda
    Offline

    Tilda Опытный в 1С

    Регистрация:
    29 июл 2010
    Сообщения:
    70
    Симпатии:
    0
    Баллы:
    26
    Ой, и еще вопрос! Как правильно рассчитать цену за грамм из полной цены изделия? Я имею ввиду, как правильно оформить это, чтобы не было проблем типа деления на ноль или как в паскале несовпадения типов. Или тут такого нет?
  3. Oleg_NSK
    Offline

    Oleg_NSK Опытный в 1С

    Регистрация:
    25 окт 2010
    Сообщения:
    164
    Симпатии:
    0
    Баллы:
    26
    Код:
    Если Таблица.Количество() = 0 Тогда
    Предупреждение ("Для товара " + Товар + " не задан штрихкод!");	
    Иначе 
    Возврат Таблица[0].Штрихкод;
    КонецЕсли;
    
Похожие темы
  1. ЧКДзержинский
    Ответов:
    3
    Просмотров:
    1.049
  2. Serge
    Ответов:
    0
    Просмотров:
    369
  3. dr303
    Ответов:
    2
    Просмотров:
    355
  4. Euronymous
    Ответов:
    9
    Просмотров:
    568
  5. alexiy281
    Ответов:
    15
    Просмотров:
    1.190
Загрузка...

Поделиться этой страницей