8.х проверка на язык ввода

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем bannov, 5 апр 2012.

  1. TopicStarter Overlay
    bannov
    Offline

    bannov Опытный в 1С

    Регистрация:
    17 дек 2008
    Сообщения:
    185
    Симпатии:
    0
    Баллы:
    26
    Есть обработка, которая выгружает номенклатуру в txt файл. На форме обработки есть поле ввода в котором полозователи выбирают путь, куда сохранить файл и пишут имя файла. Подскажите пожалуйста, как сделать проверку, чтобы пользователи не могли написать имя файла на русском языке? Т.е. при нажатии на кнопку выгрузить у них появлялось сообщение о том что на правильное имя файла и выгрузка не производилась
  2. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.990
    Симпатии:
    399
    Баллы:
    104
    Определенного метода не припомню. Но если его все же нет, то можно просто перебором символов. Т.е. Например в таблицу значений заносите алфавит. Затем берете имя файла. Пример: "Тест1". И просто начинаете проверять каждый символ с каждым символом таблицы значений. Если хоть один совпадет, тогда Отказ. Что-то типа того.
  3. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Ну да, можно по коду клавиши еще проверять, если входит в определенный диапазон кодов - отказ :)
  4. Allizar
    Offline

    Allizar Опытный в 1С

    Регистрация:
    24 сен 2006
    Сообщения:
    413
    Симпатии:
    0
    Баллы:
    26
    Функция ПроверитьВводНаАнглийском()
  5. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Это что за функция такая:)?
  6. Allizar
    Offline

    Allizar Опытный в 1С

    Регистрация:
    24 сен 2006
    Сообщения:
    413
    Симпатии:
    0
    Баллы:
    26
    Это я дописать не успел

    Код:
    Функция ПроверитьВводНаАнглийском(СтрокаВвода)
    
    СимволыАнгл = "wertyuiopasdfghjklzxcvbnm";
    Для  НомПоз = 1 Из СтрДлина(СтрокаВвода) Цикл
    СимволТест = Сред(СтрокаВвод, НомПоз,1);
    Если Найти(СимволыАнгл, СимволТест) = 0 Тогда
    Возврат Ложь;
    КонецЕсли;
    КонецЦикла;
    
    Возврат Истина;
    
    КонецФункции
    
    Ну ещё нужно учесть слэши, точки и т. д.
  7. TopicStarter Overlay
    bannov
    Offline

    bannov Опытный в 1С

    Регистрация:
    17 дек 2008
    Сообщения:
    185
    Симпатии:
    0
    Баллы:
    26
    Спасибо все большое! Смысл понятен, буду делать.

Поделиться этой страницей