7.7 Проверка на истинность условия. Непонятная аномалия

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем iirespektii, 17 ноя 2012.

  1. TopicStarter Overlay
    iirespektii
    Offline

    iirespektii

    Регистрация:
    13 ноя 2012
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    Пытаюсь написать условие в результате которого будет выполняться заполнение подчиненного справочника, но почему то не работает условие.

    Код:
    Процедура ПриЗаписи()
    ПриЗаписиПерепроводить(1);
    Счётчик=0;
    СпрПроизв = СоздатьОбъект("Справочник.Произведения");
    СпрКниги = СоздатьОбъект("Справочник.Книги");
    СпрПроизв.ВыбратьЭлементы();
    Пока СпрПроизв.ПолучитьЭлемент()=1 Цикл
    СпрКниги.ИспользоватьВладельца(СпрПроизв);
    Предупреждение(НаименованиеК);
    Предупреждение(СпрПроизв.Наименование);
    Если (СпрПроизв.Жанр=Жанр) и (СпрПроизв.Авторы=Автор) Тогда  //если добавить    и (СпрПроизв.Наименование=НаименованиеК)  то ничего не происходит, 1с игнорирует условие и не видит, что значения одинаковы, хотя в выше написанных предупреждениях выводит одинаковый результат
    СпрКниги.Новый();
    СпрКниги.Статус=Перечисление.СтатусКниги.Свободна;
    СпрКниги.ГодИздания=ГодИздания;
    СпрКниги.ЧислоСтраниц=ЧислоСтраниц;
    СпрКниги.Записать();
    Счётчик=1; 
    КонецЕсли;   
    КонецЦикла;   
    
    Если Счётчик<>1 Тогда
    Предупреждение("Нет такой книги или жанра или автора в справочнике!!!"); 
    СтатусВозврата(0);Возврат;
    КонецЕсли;
    
    КонецПроцедуры
  2. TopicStarter Overlay
    iirespektii
    Offline

    iirespektii

    Регистрация:
    13 ноя 2012
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    Решил проблему при помощи СокрЛП(), может кому пригодится.
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Жанр и автор лучше бы делали не как строку, а как справочник.
    Ни дай бог буковка будет отличатся.... Скажем простая оЧепЯтка.... "фонтастика" и "фантастика"

Поделиться этой страницей