8.х ОБМЕН Проведение документов, обмен м/у БП-БП

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем Yoda, 4 фев 2010.

  1. TopicStarter Overlay
    Yoda
    Offline

    Yoda Опытный в 1С

    Регистрация:
    5 сен 2008
    Сообщения:
    120
    Симпатии:
    0
    Баллы:
    26
    Привет!
    Настроил обмен 3 документов. :unsure:
    Создание переферийной : На основе выгруженного CF из центральной создана "переферийка" в ней заданы узлы с теме же кодами. В центральной в "Настройка обмена данными" была нажата кнопочка "Зарегестрировать для обмена".Зарегестрированные документы - разрегестрированны т.к. они в переферийке не нужны. Первая огромный обмен перенёс справочники и константы.

    Регистрация у бухгалтерских регистров отключена как в типовом "Поорганизации" .
    Документы переносятся с глаочкой проведён, но реальных движений нет.


    Как сделать чтоб они были ? или где прописать : после создания при переносе проводить в загружаемой базе?
  2. TopicStarter Overlay
    Yoda
    Offline

    Yoda Опытный в 1С

    Регистрация:
    5 сен 2008
    Сообщения:
    120
    Симпатии:
    0
    Баллы:
    26
    Документы переносятся с галочкой проведён, но реальных движений нет.
    В подписках на событие при проведении документов или есть нормальный способ сделать попопытку провести?
    UP
  3. TopicStarter Overlay
    Yoda
    Offline

    Yoda Опытный в 1С

    Регистрация:
    5 сен 2008
    Сообщения:
    120
    Симпатии:
    0
    Баллы:
    26
    Код:
    Процедура ПриПолученииДанныхОтПодчиненного(ЭлементДанных, ОтправкаЭлемента)
    ТипОбъекта = ТипЗнч(ЭлементДанных);
    ИмяБазовогоТипа = мИмяСтарогоБазовогоТипа;
    Если ИмяБазовогоТипа = Неопределено Тогда
    
    ИмяБазовогоТипа = ПолучитьИмяБазовогоТипаПоТипуОбъекта(ТипОбъекта);
    
    КонецЕсли;
    Если  ИмяБазовогоТипа = "Документы" тогда
    если ЭлементДанных.Ссылка.проведен <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">тогда	</span>
    Попытка 
    ЭлементДанных.Записать(РежимЗаписиДокумента.Проведение);
    Исключение
    ЭлементДанных.Записать(РежимЗаписиДокумента.Запись);
    
    КонецПопытки;
    КонецЕсли;
    
    КонецЕсли;	
    
    
    КонецПроцедуры
    
    Но проводятся документы только если они уже есть в загружаемой базе.
    Как провести документ если он новый?
Похожие темы
  1. Trol69
    Ответов:
    1
    Просмотров:
    690
Загрузка...

Поделиться этой страницей