8.х Проведение документа

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Voody, 23 июл 2008.

  1. Вселенная
    Offline

    Вселенная Опытный в 1С

    Регистрация:
    4 ноя 2009
    Сообщения:
    176
    Симпатии:
    0
    Баллы:
    26
    Добавила Приход, получилось. Но в отчете по движениям документа отображается Приход по складу, но без количества, номенклатуры.
  2. ASh
    Offline

    ASh Опытный в 1С

    Регистрация:
    10 сен 2008
    Сообщения:
    568
    Симпатии:
    0
    Баллы:
    26
    Код покажите
  3. Вселенная
    Offline

    Вселенная Опытный в 1С

    Регистрация:
    4 ноя 2009
    Сообщения:
    176
    Симпатии:
    0
    Баллы:
    26
    Код:
    Офис=Справочники.Склады.НайтиПоНаименованию("Библиотека");
    Движение = Движения.ТоварыНаСкладах.ДобавитьПриход();
    Движение.Период = Дата;
    Движение.Склад = Офис;
    
    Если Не Отказ Тогда
    Движения.ТоварыНаСкладах.Записать();
    КонецЕсли;
    
    Надо ему чтоли номенклатуру из документа передать или что? Торможу... :unsure:
  4. ASh
    Offline

    ASh Опытный в 1С

    Регистрация:
    10 сен 2008
    Сообщения:
    568
    Симпатии:
    0
    Баллы:
    26
    Конечно надо.
    Проще всего так сделать: В конец процедуры ДвиженияПоРегистрам добавить код
    Код:
    Офис=Справочники.Склады.НайтиПоНаименованию("Библиотека");
    тз = Движения.ТоварыНаСкладах.Выгрузить();
    КоличествоДвижений = тз.Количество();
    Для А = 0 По КоличествоДвижений-1 Цикл
    НоваяСтрока = тз.Добавить();
    Для Б = 0 По тз.Колонки.Количество()-1 Цикл
    НоваяСтрока.Установить(Б,тз[А].Получить(Б));
    КонецЦикла;
    НоваяСтрока.Склад = Офис;
    КонецЦикла;
    Движения.ТоварыНаСкладах.Загрузить(тз);
    
    
    т.е. взять движения из регистра, которые созданы документом, и добавить к ним такие же, только с измененным складом.
  5. Вселенная
    Offline

    Вселенная Опытный в 1С

    Регистрация:
    4 ноя 2009
    Сообщения:
    176
    Симпатии:
    0
    Баллы:
    26
    Получилось, спасибо! Но только надо же Приход, а получается расход...
  6. ASh
    Offline

    ASh Опытный в 1С

    Регистрация:
    10 сен 2008
    Сообщения:
    568
    Симпатии:
    0
    Баллы:
    26
    Зачем надо приход?
  7. Вселенная
    Offline

    Вселенная Опытный в 1С

    Регистрация:
    4 ноя 2009
    Сообщения:
    176
    Симпатии:
    0
    Баллы:
    26
    ну раз пришел товар на склад, значит, приход, или я глупость говорю?
  8. ASh
    Offline

    ASh Опытный в 1С

    Регистрация:
    10 сен 2008
    Сообщения:
    568
    Симпатии:
    0
    Баллы:
    26
    Вообще-то, документ требование-накладная списывать со склада должен. Но если хочется приход, то после строки
    Код:
    НоваяСтрока.Склад = Офис;
    
    добавьте
    Код:
    НоваяСтрока.ВидДвижения = ВидДвиженияНакопления.Приход;
    
    P.S. Может Вам документом ПеремещениеТоваров просто воспользоваться?
  9. Вселенная
    Offline

    Вселенная Опытный в 1С

    Регистрация:
    4 ноя 2009
    Сообщения:
    176
    Симпатии:
    0
    Баллы:
    26
    Нееееет, Перемещением не надо пользоваться. Ага, требНакл для списания, но нужно и списать товар и чтобы он появился на складе Офис (например, книжки всякие, инструменты для офиса), это нужно для внутреннего учета.
  10. ASh
    Offline

    ASh Опытный в 1С

    Регистрация:
    10 сен 2008
    Сообщения:
    568
    Симпатии:
    0
    Баллы:
    26
    Так-то оприходованием товаров надо на другой склад заводить, но Вам, конечно, виднее как свой учет вести:)

Поделиться этой страницей