8.х Простой отчет

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем oks, 26 мар 2008.

  1. TopicStarter Overlay
    oks
    Offline

    oks

    Регистрация:
    18 сен 2006
    Сообщения:
    43
    Симпатии:
    0
    Баллы:
    1
    Помогите написать простой отчет, совсем не знаю 8.0

    Нужно выбрать несколько реквизитов шапки документа и все реквизиты из табличной части документов.
    Сейчас у меня получаеться выбрать только сами документы.. а как выбрать строки из табличной части не знаю???
    выборку документов делаю так:

    Выборка=документы.Инвентаризация.Выбрать();
    Пока Выборка.Следующий() цикл
    Здесь заполняю таблицу значений

    КонецЦикла;
  2. B@girusss
    Offline

    B@girusss Опытный в 1С

    Регистрация:
    13 сен 2006
    Сообщения:
    102
    Симпатии:
    0
    Баллы:
    26
    Код:
    Ф1 = Документы.Заказ.Выбрать();
    Пока Ф1.Следующий() Цикл //Перебираем доки... 
    Ф2 = Ф1.Товары;              //Получаем ссылку на таб часть текущего документа в переборке			
    Для Каждого Ф4 Из Ф2 Цикл //перебираем строки таб части в документе
    // Вставить содержимое обработчика
    КонецЦикла;
    
    КонецЦикла;
    
    
    Все просто! Удачи!
  3. TopicStarter Overlay
    oks
    Offline

    oks

    Регистрация:
    18 сен 2006
    Сообщения:
    43
    Симпатии:
    0
    Баллы:
    1
    Спасибо получилось... выгрузила в таблицузначений а теперь ка из нее вытащить все в отчет....
  4. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Э....

    Платформа 8.0
    Для отчетов используются запросы, а никак не двойные цмклы

    Платформа 8.1
    Схема компоновки - небольшой запросы и огромные возможности по использованию
  5. B@girusss
    Offline

    B@girusss Опытный в 1С

    Регистрация:
    13 сен 2006
    Сообщения:
    102
    Симпатии:
    0
    Баллы:
    26
    BabySG прав! Есть конструктор отчетов в котором можно это сделать не вникая в суть работы запросов! Опиши поподробней какой тебе нужен отчет! Может помочь смогу!
  6. TopicStarter Overlay
    oks
    Offline

    oks

    Регистрация:
    18 сен 2006
    Сообщения:
    43
    Симпатии:
    0
    Баллы:
    1
    Отчет по документам инвентаризации. И в одну строку вывести три реквизита из шапки документа и все реквизиты табличной части документа (номенклатура и все ее реквизиты некоторые реквизиты подтянуть из справочника номенклатура.) Может быть это можно сделать через консоль отчетов только я не знаю как.
  7. B@girusss
    Offline

    B@girusss Опытный в 1С

    Регистрация:
    13 сен 2006
    Сообщения:
    102
    Симпатии:
    0
    Баллы:
    26
    Уверенна что все в одну строку нужно? Строка то очень длинной будет!
    Сделать то можно все!
  8. TopicStarter Overlay
    oks
    Offline

    oks

    Регистрация:
    18 сен 2006
    Сообщения:
    43
    Симпатии:
    0
    Баллы:
    1
    Уверена! она и должна быть длинной.
  9. B@girusss
    Offline

    B@girusss Опытный в 1С

    Регистрация:
    13 сен 2006
    Сообщения:
    102
    Симпатии:
    0
    Баллы:
    26

    Вложения:

    • отчет.rar
      Размер файла:
      442,4 КБ
      Просмотров:
      108

Поделиться этой страницей