7.7 простая задачка

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Ilya, 21 дек 2007.

  1. TopicStarter Overlay
    Ilya
    Offline

    Ilya

    Регистрация:
    21 дек 2007
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    помогите
    как добавить в список кнопок, которые открываются при выборе вида печати, еще кнопку и
    по ее нажатию чтобы выолнялась уже готовая обработка ("печать этикетки").
  2. MaxxaM
    Offline

    MaxxaM Опытный в 1С

    Регистрация:
    16 окт 2007
    Сообщения:
    288
    Симпатии:
    2
    Баллы:
    29
    Да проще не бывает:

    Открываешь конфигуратор
    в модуль документа добавляешь:
    Код:
    Процедура ВыборВариантаПечати()
    Перем ВыбЗначение;
    ВариантыПечати = СоздатьОбъект("СписокЗначений");
    ВариантыПечати.ДобавитьЗначение(1,"Печать чего то там");
    ВариантыПечати.ДобавитьЗначение(2,"Печать этикетки");
    Если ВариантыПечати.ВыбратьЗначение(выбЗначение,"",,,1) <> 1 Тогда
    Возврат;
    КонецЕсли;
    Если ВыбЗначение = 1 Тогда
    "СтараяПроцедураПечати()"       
    ИначеЕсли ВыбЗначение = 2 Тогда
    ПечатьЭтикетки();
    КонецЕсли;
    КонецПроцедуры
    
    
    Находишь на форме кнопочку в свойствах (закалка дополнительно окошко "Формула") имя старой процедуры ("СтараяПроцедураПечати()") меняешь на ВыборВариантаПечати() :unsure:
Похожие темы
  1. xm1
    Ответов:
    9
    Просмотров:
    4.613
Загрузка...

Поделиться этой страницей