7.7 Прошу Помощи Специалистов

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем BAM26101976, 18 июн 2011.

  1. TopicStarter Overlay
    BAM26101976
    Offline

    BAM26101976

    Регистрация:
    18 июн 2011
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Прошу помощи!

    Никак не могу победить модифицирую внешний отчет: нужно что была возможность выбирать в таличной части документы которые в последующем будут распечатываться.
    Но у меня не желает сохраняться выбираемый параметр ВидДок:
    Код:
    //***************************************
    Процедура ПриДвойномЩелчкеНаТаблице()
    Перем ТекКол, ТекСтр;
    
    ТаблицаЛицевыхСчетов.ТекущаяКолонка(,ТекКол);
    ТекСтр = ТаблицаЛицевыхСчетов.ТекущаяСтрока();
    КодТекКол = ТаблицаЛицевыхСчетов.ПолучитьПараметрыКолонки(ТекКол); 
    
    Если ТекСтр > 0 Тогда
    Если КодТекКол = "Пометка" Тогда
    Если ТаблицаЛицевыхСчетов.Пометка = МеткаЕсть Тогда
    ТаблицаЛицевыхСчетов.Пометка = МеткиНет;
    ТаблицаЛицевыхСчетов.ВидДок = "";
    Иначе
    ТаблицаЛицевыхСчетов.Пометка = МеткаЕсть; 
    КонецЕсли;  
    ИначеЕсли КодТекКол ="Пеня" Тогда
    Пеня = ТаблицаЛицевыхСчетов.Пеня;
    ВвестиЧисло(Пеня, "Пеня:", 15, 2);
    ТаблицаЛицевыхСчетов.Пеня = Пеня;
    ТаблицаЛицевыхСчетов.Пометка = МеткаЕсть; 
    ИначеЕсли КодТекКол ="ВидДок" Тогда
    ВидДок = ТаблицаЛицевыхСчетов.ВидДок;
    ВвестиЧисло(ВидДок, "Вид документа:", 3, 0);
    ТаблицаЛицевыхСчетов.ВидДок = ВидДок;
    ТаблицаЛицевыхСчетов.Пометка = МеткаЕсть; 
    КонецЕсли;
    КонецЕсли;
    
    
    КонецПроцедуры // ПриДвойномЩелчкеНаТаблице() 
    //***************************************************
    
    Что в этом фрагмента не так? Заранее большое спасибо !

    Вложения:

  2. kavak
    Offline

    kavak Опытный в 1С

    Регистрация:
    13 май 2010
    Сообщения:
    703
    Симпатии:
    0
    Баллы:
    26
    В отладчике смотрели?Где именно спотыкается?
    И какая конфигурация у Вас?
    И что за внешний отчет модифицыруете?
  3. TopicStarter Overlay
    BAM26101976
    Offline

    BAM26101976

    Регистрация:
    18 июн 2011
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Конфигурация УСНО переделанная для ТСЖ, Обработка полностью рабочая. Исключение составлет только то что вносишь в табличную часть диалога не могу передать в печатную форму. В табличной части все изменения сохраняются, а дальше передать их как или куда зафиксировать чтобы была возможность дальше их обрабатывать умишка не хватает.
  4. kavak
    Offline

    kavak Опытный в 1С

    Регистрация:
    13 май 2010
    Сообщения:
    703
    Симпатии:
    0
    Баллы:
    26
    Скиньте сюда конфигурацию.Посмотрим.Т.к. она у Вас переделанная.
  5. TopicStarter Overlay
    BAM26101976
    Offline

    BAM26101976

    Регистрация:
    18 июн 2011
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Да боюсь что дело не в конфигурации.

    Вложения:

    • 1cv7.rar
      Размер файла:
      2,6 МБ
      Просмотров:
      24
  6. kavak
    Offline

    kavak Опытный в 1С

    Регистрация:
    13 май 2010
    Сообщения:
    703
    Симпатии:
    0
    Баллы:
    26
    Дело как раз в этом как я смогу отследить баг если нет Вашей базы.Скачал смотрю,позже напишу
  7. TopicStarter Overlay
    BAM26101976
    Offline

    BAM26101976

    Регистрация:
    18 июн 2011
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    У меня большое подозрение, что я неправильно вызываю значения из Таблицы. Как показал метод научного тыка. Все значения в Таблице сохраняются корректно. А вот вызвать их корректно в форму пока не получилось. Выкладываю последнюю версию обработки. Заранее благодарю.

    Вложения:

  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Я не вижу особых проблет в коде. Внешне все правильно. В каком месте ошибка?
  9. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Там где вы заполняете таблицу формы - не присваиваете вид документа переменной ВидДок.
  10. TopicStarter Overlay
    BAM26101976
    Offline

    BAM26101976

    Регистрация:
    18 июн 2011
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Да нет все правильно там присваивается.
  11. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Значит выложили не последний вариант обработки.

    В процедуре Заполнить() смотрите. И уберите ВидДок из описания переменных - сразу все увидите.
  12. TopicStarter Overlay
    BAM26101976
    Offline

    BAM26101976

    Регистрация:
    18 июн 2011
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Сделал как Вы посоветовали все работает. И к сожалению я ничего не увидел. Может не там смотрю?
  13. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Думаю да. Постучите в аську - "ткну носом"
  14. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Метод ПолучитьСтрокуПоНомеру творит чудеса........

Поделиться этой страницей