7.7 Пропустить скрытую строку при загрузке из excel в ТЗ?

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем 4ndr3j, 12 мар 2015.

  1. TopicStarter Overlay
    4ndr3j
    Offline

    4ndr3j Новичок в 1С

    Регистрация:
    1 фев 2012
    Сообщения:
    14
    Симпатии:
    1
    Баллы:
    4
    Добрый день, помогите с обработкой.
    Пытаюсь загрузить с листа excel данные в ТЗ.
    Код:
        Для А=1 По ВсегоКолонок Цикл
            ТЗЗагрузки.НоваяКолонка();
        КонецЦикла;
       
        Для Стр=1 По ВсегоСтрок Цикл
            Состояние("Обработано "+Строка(Стр)+" строк из "+Строка(ВсегоСтрок));
            ТЗЗагрузки.НоваяСтрока(Стр);
            Для Столб=1 По ВсегоКолонок Цикл
                ТЗЗагрузки.УстановитьЗначение(Стр,Столб,СокрЛП(Лист.Cells(Стр,Столб).Value));
            КонецЦикла;
        КонецЦикла;
    Беда в том что на листе есть скрытые колонки и строки, как проверить их на видимость и пропустить при загрузке.
  2. Бухгалтерский угодник
    Online

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.159
    Симпатии:
    492
    Баллы:
    104
    могу ошибаться в методе.. По памяти так
    Код:
    Если Лист.Cells(Стр,Столб).Hidden=1 Тогда
    Сообщить("Ячейка невидима");
    КонецЕсли;
    
    4ndr3j нравится это.
  3. TopicStarter Overlay
    4ndr3j
    Offline

    4ndr3j Новичок в 1С

    Регистрация:
    1 фев 2012
    Сообщения:
    14
    Симпатии:
    1
    Баллы:
    4
    А к строке или колонке целиком возможно применить?
  4. Бухгалтерский угодник
    Online

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.159
    Симпатии:
    492
    Баллы:
    104
    вместо cells юзаем Rows и Columns
    З/Ы Сам не пробовал. Экспериментируйте!
    4ndr3j нравится это.
  5. TopicStarter Overlay
    4ndr3j
    Offline

    4ndr3j Новичок в 1С

    Регистрация:
    1 фев 2012
    Сообщения:
    14
    Симпатии:
    1
    Баллы:
    4
    Да я уже попробовал
    Код:
    Если Лист.Rows(Стр).Hidden=-1 Тогда   
                Продолжить;
    КонецЕсли;
    Почему то с -1 сравнивать пришлось, отладчиком посмотрел.
    Спасибо.
  6. Бухгалтерский угодник
    Online

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.159
    Симпатии:
    492
    Баллы:
    104
    Я говорю - значение точно не помню.
    Обращайтесь!
Похожие темы
  1. chernuscaМАРИНА
    Ответов:
    1
    Просмотров:
    1.209
  2. AD1986
    Ответов:
    1
    Просмотров:
    1.639
  3. mass
    Ответов:
    22
    Просмотров:
    1.100
  4. TODD22
    Ответов:
    1
    Просмотров:
    798
  5. SvetaS_Love
    Ответов:
    3
    Просмотров:
    811
Загрузка...

Поделиться этой страницей