7.7 Пропустить открытый документ в цикле

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем nero, 26 июн 2009.

  1. TopicStarter Overlay
    nero
    Offline

    nero

    Регистрация:
    26 июн 2009
    Сообщения:
    14
    Симпатии:
    0
    Баллы:
    1
    Отчёт формирует печатную форму переданных документов с проставлением даты передачи документа в реквизит заявки.
    Работает нормально при условии если нет открытых документов (заявка). Если попадается первый открытый - "объект заблокирован"
    Версия ТиС 7,7 Работают 6 человек в разных комнатах. Приходится всех просить закрыть заявки для формирования отчёта.
    Поиском ответ найти не удалось.
    Код:
    //*******************************************
    Процедура Сформировать()
    Док=СоздатьОбъект("Документ.Заявка");
    Док.ВыбратьДокументы(ВыбНачПериода,ВыбКонПериода);
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("");
    Таб.ВывестиСекцию("Заголовок");
    Пока Док.ПолучитьДокумент()>0 Цикл
    
    Если ПустоеЗначение(Док.ДатаОтправки)=1 Тогда
    Таб.ВывестиСекцию("Док");
    Док.ДатаОтправки=ТекущаяДата();
    Док.Записать();
    КонецЕсли;
    
    КонецЦикла;
    Таб.ТолькоПросмотр(1);
    Таб.Опции(0, 0, 0, 0);
    Таб.Показать("");
    КонецПроцедуры
    
    Может кто сталкивался с такой проблемой? Как пропустить открытый документ?
    Заранее спасибо!
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Самое простое - Попытка/Исключение
  3. TopicStarter Overlay
    nero
    Offline

    nero

    Регистрация:
    26 июн 2009
    Сообщения:
    14
    Симпатии:
    0
    Баллы:
    1

    Спасибо, получилось! :unsure:

Поделиться этой страницей