8.х Прописать счета учета НДС в новом документе "Реализация товаров и услуг"

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем A|_E><Ey, 23 апр 2015.

  1. TopicStarter Overlay
    A|_E><Ey
    Offline

    A|_E><Ey Опытный в 1С

    Регистрация:
    13 дек 2012
    Сообщения:
    356
    Симпатии:
    2
    Баллы:
    29
    Добрый день уважаемые форумчане, возникла такая проблемма, создаю автоматом новые документы реализации, на основании документа "Возврат товаров от поставщика", при проведении автоматом формируется проводка Дт 90.02 Кт 41.01, почему то при создании того же документа реализации вручную автоматически формируются проводки:
    Дт 90.02 Кт 41.01
    Дт 62 Кт 90.01
    Дт 90.3 Кт 68.02

    Никто не сталкивался с подобной ситуацией, никак не могу найти где я ошибся (((

    Код:
    Для Каждого Стр из ТаблицаВозвратов Цикл
            Если Стр.Создать и Стр.Проведен Тогда
                ДокументРеализация = Документы.РеализацияТоваровУслуг.СоздатьДокумент();
                ДокументРеализация.Дата = Стр.ДокументСсылка.Дата;
                ДокументРеализация.ВидОперации = Перечисления.ВидыОперацийРеализацияТоваров.ПродажаКомиссия;
                ДокументРеализация.ВалютаДокумента = Справочники.Валюты.НайтиПоКоду("643");
                ДокументРеализация.Организация = Стр.ДокументСсылка.Организация;
                ДокументРеализация.Сделка = Стр.ДокументСсылка.Сделка;
                ДокументРеализация.КратностьВзаиморасчетов = 1;
                ДокументРеализация.КурсВзаиморасчетов = 1;
                ДокументРеализация.БанковскийСчетОрганизации = Стр.ДокументСсылка.Организация.ОсновнойБанковскийСчет;
                ДокументРеализация.Контрагент = Стр.ДокументСсылка.Контрагент;
                ДокументРеализация.Грузоотправитель = Стр.ДокументСсылка.Грузополучатель;
                ДокументРеализация.Проект = Стр.ДокументСсылка.Проект;
                ДокументРеализация.Склад = Стр.ДокументСсылка.Склад;
                ДокументРеализация.ВидПередачи = Перечисления.ВидыПередачиТоваров.СоСклада;
                ДокументРеализация.ДоговорКонтрагента = Стр.ДокументСсылка.ДоговорКонтрагента;
                ДокументРеализация.УчитыватьНДС = Истина;
               
                Если ЗначениеЗаполнено(Стр.ДокументСсылка.Грузополучатель)
                    И ЗначениеЗаполнено(Стр.ДокументСсылка.Грузополучатель.ОсновнойДоговорКонтрагента)
                    И Стр.ДокументСсылка.Грузополучатель.ОсновнойДоговорКонтрагента.ВидДоговора = Перечисления.ВидыДоговоровКонтрагентов.СПокупателем
                    И ЗначениеЗаполнено(Стр.ДокументСсылка.Грузополучатель.ОсновнойДоговорКонтрагента.ТипЦен) Тогда
                    ДокументРеализация.ТипЦен    = Стр.ДокументСсылкаГрузополучатель.ОсновнойДоговорКонтрагента.ТипЦен;
                Иначе
                    ДокументРеализация.ТипЦен    = Стр.ДокументСсылка.ДоговорКонтрагента.ТипЦен;
                КонецЕсли;
    
                ДокументРеализация.СуммаВключаетНДС                    = Стр.ДокументСсылка.ТипЦен.ЦенаВключаетНДС;
                ДокументРеализация.Ответственный                    = ПараметрыСеанса.ТекущийПользователь;
                ДокументРеализация.Комментарий                        = "Документ создан на основании " + Стр.ДокументСсылка + " через обработку.";
                ДокументРеализация.ОтражатьВУправленческомУчете        = Истина;
                ДокументРеализация.ОтражатьВБухгалтерскомУчете        = Истина;
                ДокументРеализация.ОтражатьВНалоговомУчете            = Истина;
                ДокументРеализация.Подразделение                    = Стр.ДокументСсылка.Подразделение;
               
                Для Каждого СтрочкаТабЧастиВозврат из Стр.ДокументСсылка.Товары Цикл
                    СтрокаТабЧастиРеализации = ДокументРеализация.Товары.Добавить();
                    СтрокаТабЧастиРеализации.Номенклатура = СтрочкаТабЧастиВозврат.Номенклатура;
                    СтрокаТабЧастиРеализации.ЕдиницаИзмерения = СтрочкаТабЧастиВозврат.ЕдиницаИзмерения;
                    СтрокаТабЧастиРеализации.СтавкаНДС = СтрочкаТабЧастиВозврат.СтавкаНДС;
                    СтрокаТабЧастиРеализации.Коэффициент = СтрочкаТабЧастиВозврат.Коэффициент;
                    СтрокаТабЧастиРеализации.Количество = СтрочкаТабЧастиВозврат.Количество;
                    СтрокаТабЧастиРеализации.Цена = СтрочкаТабЧастиВозврат.Цена;
                    СтрокаТабЧастиРеализации.Сумма = СтрочкаТабЧастиВозврат.Сумма;
                    СтрокаТабЧастиРеализации.СуммаНДС = СтрочкаТабЧастиВозврат.СуммаНДС;
                    СтрокаТабЧастиРеализации.Склад = СтрочкаТабЧастиВозврат.Склад;
                КонецЦикла;
               
                ДокументРеализация.СуммаДокумента = ДокументРеализация.Товары.Итог("Сумма");
               
                Попытка
                    ДокументРеализация.Записать(РежимЗаписиДокумента.Проведение);
                    НоваяСтрока = ТабличноеПоле1.Добавить();
                    НоваяСтрока.Документ = ДокументРеализация;
                    Сообщить("Создан новый документ " + ДокументРеализация.Ссылка);
                Исключение
                    Сообщить("Не удалось провести документ на основании документа " + Стр.ДокументСсылка);
                    Попытка
                        ДокументРеализация.Записать(РежимЗаписиДокумента.Запись);
                        НоваяСтрока = ТабличноеПоле1.Добавить();
                        НоваяСтрока.Документ = ДокументРеализация;
                    Исключение
                        Сообщить("Не удалось записать документ на основании документа " + Стр.ДокументСсылка);
                    КонецПопытки;
                КонецПопытки;
           
            КонецЕсли;
        КонецЦикла;
    

Поделиться этой страницей