7.7 Пропись

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем змейкин, 11 май 2013.

  1. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Народ помогите как сделать чтобы формат ЧПДС выводил прописью не на русском а на украинском языке)
    Пробовал так:
    Код:
    Процедура Печать()
    Перем Таб;
    ЕДРПОУ =  Фирма.ЕДРПОУ;
    ДатаВед = ПериодСтр(НачМесяца(ДатаДок), КонМесяца(ДатаДок));
    Таб = СоздатьОбъект ("Таблица");
    Таб.ИсходнаяТаблица ("Таблица");
    Таб.ВывестиСекцию("Шапка");
    Номер = 1;
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
    Таб.ВывестиСекцию("Строка");
    Номер = Номер + 1;
    КонецЦикла;
    Таб.ВывестиСекцию("Дно");
    Пропись("uahukr.spl");
    Таб.Показать("Таблица");
    КонецПроцедуры
    
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Пропись нужно устанавливать ДО вывода данных
    Код:
    Таб = СоздатьОбъект ("Таблица");
    Таб.ИсходнаяТаблица ("Таблица");
    Пропись("uahukr.spl");
    Таб.ВывестиСекцию("Шапка");
    ...........
    
  3. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Сделал вот)но все равно не идет я там понял что пропись управляет форматом у меня на печатной форме
    Код:
    //***************************************************************************************************************
    Процедура Печать()
    Перем Таб;
    ЕДРПОУ =  Фирма.ЕДРПОУ;
    ДатаВед = ПериодСтр(НачМесяца(ДатаДок), КонМесяца(ДатаДок));
    Таб = СоздатьОбъект ("Таблица");
    Таб.ИсходнаяТаблица ("Таблица");
    Пропись("uahukr.spl");
    Таб.ВывестиСекцию("Шапка");
    Номер = 1;
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
    Таб.ВывестиСекцию("Строка");
    Номер = Номер + 1;
    КонецЦикла;
    Таб.ВывестиСекцию("Дно");
    Таб.Показать("Таблица");
    КонецПроцедуры
    //***************************************************************************************************************
    
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Верно. А сам файл-то у вас в каталоге БД есть?
  5. Vlan
    Online

    Vlan Гость Гость

    А что именно не получается? Выводится прописью на русском? Вообще прописью не выводится?
    Используете форматную строку Формат(Сумма, "ЧПДС")?
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Перечитайте первый пост....
  7. Vlan
    Online

    Vlan Гость Гость

    Вопросы адресованы не вам.
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Тек человек написал, что именно не получается
  9. TopicStarter Overlay
    змейкин
    Offline

    змейкин Опытный в 1С

    Регистрация:
    25 мар 2013
    Сообщения:
    118
    Симпатии:
    0
    Баллы:
    26
    Да файл есть
    "uahukr.spl"
    Открыл в блокноте вот Украиский язык :
    {"Speller",
    {"Money",
    {"Гривня","Гривні","Гривень","копійка","копійки","копійок","F"}},
    {"Numbers",
    {"Один","Два","Три","Чотири","П'ять","Шість","Сім","Вісім","Дев'ять","Одна","Дві",
    "Десять","Одинадцять","Дванадцять","Тринадцять","Чотирнадцять","П'ятнадцять","Шістнадцять","Сімнадцять","Вісімнадцять","Дев'ятнадцять",
    "Двадцять","Тридцять","Сорок","П'ятдесят","Шістдесят","Сімдесят","Вісімдесят","Дев'яносто",
    "Сто","Двісті","Триста","Чотириста","П'ятсот","Шістсот","Сімсот","Вісімсот","Дев'ятсот",
    "Тисяча","Тисячі","Тисяч",
    "Мільйон","Мільйона","Мільйонів",
    "Мільярд","Мільярда","Мільярдів",
    "Трильйон","Трильйона","Трильйонів",
    "Нуль"}},
    {"Date",
    {"Січень","Лютий","Березень","Квітень","Травень","Червень","Липень","Серпень","Вересень","Жовтень","Листопад","Грудень",
    "Січня","Лютого","Березня","Квітня","Травня","Червня","Липня","Серпня","Вересня","Жовтня","Листопада","Грудня",
    "р.","Квартал"}},
    {"DateRange",
    {"Півріччя","Місяців"}},
    {"WeekDay",
    {"Понеділок","Вівторок","Середа","Четвер","П'ятниця","Субота","Неділя"}}
    }
    Хочу вывести через формат() На печатной форме чтоб вывелось валюта в гривне а не в рублях)
    На печатной форме вот так :Формат(Итог("КВыплате"),"ЧПДС")

Поделиться этой страницей