8.х Программное создание документа в управляемом приложении

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем alexshm, 12 окт 2011.

  1. TopicStarter Overlay
    alexshm
    Offline

    alexshm

    Регистрация:
    10 сен 2010
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте.

    В конфигурацию добавлен нетиповой документ ЗаявкаНаФинансирование. Нужно на основании его вводить платежное поручение. Пользователи работают в тонком клиенте.
    Использовать ввод на основании не хочется, чтобы не было лишних проблем при обновлении конфигурации.
    Попытался по старой памяти написать такую команду:

    Код:
    Процедура СоздатьПП(Команда)
    // Вставить содержимое обработчика.
    ПП= додкументы.ПлатежноеПоручение.СоздатьДокумент();
    ПП.Организация = Объект.Плательщик;
    ПП.Контрагент = Объект.Получатель;
    ПП.СуммаДокумента = объект.Сумма;
    ПП.Комментарий = "Создана из заявкии " + Объект.Автор.наименование;
    ПП.Записать();
    ПП.ПолучитьФорму().Открыть();
    КонецПроцедуры
    
    Конечно, не работает.
    Подскажите, как это перевести на язык, понятный управляемому приложению. Или как сделать по другому.
  2. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    Код:
    &НаКлиенте
    Процедура СоздатьПП(Команда)
    ФормаПП = ОткрытьФорму("Документ.ПлатежноеПоручение.ФормаОбъекта");
    ФормаПП.Объект.Организация = Объект.Плательщик;
    ФормаПП.Объект.Контрагент = Объект.Получатель;
    ФормаПП.Объект.СуммаДокумента = Объект.Сумма;
    ФормаПП.Объект.Комментарий = "Создана из заявкии " + Объект.Автор.Наименование;
    КонецПроцедуры
    
    
  3. TopicStarter Overlay
    alexshm
    Offline

    alexshm

    Регистрация:
    10 сен 2010
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Премного благодарен. Так работает. Правда, выяснилось, типовая бухгалтерия не имеет управляемой формы платежки =( Но это уже другая история.
  4. TopicStarter Overlay
    alexshm
    Offline

    alexshm

    Регистрация:
    10 сен 2010
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    А можно ли просто создать экземпляр документа, не открывая его форму? А потом из обычного приложения его открыть и доделать все, что нужно?
  5. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    А разве типовая бухгалтерия имеет хоть одну управляемую форму?

    Так попробуйте:
    Код:
    &НаКлиенте
    Процедура СоздатьПП(Команда)
    СоздатьДок();
    КонецПроцедуры
    
    
    &НаСервере
    Процедура СоздатьДок()
    ПП = Документы.ПлатежноеПоручение.СоздатьДокумент();
    ПП.Дата = Объект.Дата;
    ПП.Организация = Объект.Плательщик;
    ПП.Контрагент = Объект.Получатель;
    ПП.СуммаДокумента = Объект.Сумма;
    ПП.Комментарий = "Создана из заявкии " + Объект.Автор.Наименование;
    ПП.Записать();
    КонецПроцедуры
    

Поделиться этой страницей