[РЕШЕНО] Программное объединение ячеек в скд

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем NewLife89, 9 дек 2014.

  1. KrivosheevEV
    Offline

    KrivosheevEV Новичок в 1С

    Регистрация:
    3 мар 2014
    Сообщения:
    35
    Симпатии:
    2
    Баллы:
    4
    Код:
        НомерПервойСтроки             = 2;
        НомерПоследнейСтроки         = Результат.ВысотаТаблицы - 1;
        НомерПервойКолонки            = 1;
        НомерПоследнейКолонки        = 1;
        НачалоВыделения                = Истина;
        ВыделеннаяОбластьНачало        = 0;
        ВыделеннаяОбластьОкончание    = 0;
       
        Для НомерСтрокиТаблицы = НомерПервойСтроки По НомерПоследнейСтроки Цикл
           
            ТекстТекущейЯчеи     = Результат.Область(НомерСтрокиТаблицы, НомерПервойКолонки, НомерСтрокиТаблицы, НомерПоследнейКолонки).Текст;
            ТекстЯчеиСлева        = Результат.Область(НомерСтрокиТаблицы, НомерПервойКолонки - 1, НомерСтрокиТаблицы, НомерПоследнейКолонки - 1).Текст;
           
            Если НачалоВыделения Тогда
               
                ВыделеннаяОбластьНачало = НомерСтрокиТаблицы;
               
            КонецЕсли;
           
            Если ТекстТекущейЯчеи = ТекстЯчеиСлева Тогда
           
                ВыделеннаяОбластьОкончание     = НомерСтрокиТаблицы;
                НачалоВыделения             = Ложь;
               
            ИначеЕсли ВыделеннаяОбластьНачало < ВыделеннаяОбластьОкончание Тогда
               
                ОбластьОбъединения = Результат.Область(ВыделеннаяОбластьНачало, НомерПервойКолонки, ВыделеннаяОбластьОкончание, НомерПоследнейКолонки);
                ОбластьОбъединения.Объединить();
                НачалоВыделения = Истина;
               
            КонецЕсли;
           
        КонецЦикла;
    
    Суть примера - необходимо сначала получить координаты области объединения, и, лишь, потом объединять.
  2. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.639
    Симпатии:
    948
    Баллы:
    204
    Ну в вашем коде да - т.к там стоит Область(к-1,1,к,1);
    при таком написании будет всегда две ячейки объеденяться.
    Вы В моем примере гляньте по коду. там идет счетчик и когда уже условие сработало, тогда подставляются значения для объединения
  3. TopicStarter Overlay
    NewLife89
    Offline

    NewLife89 Опытный в 1С

    Регистрация:
    4 дек 2014
    Сообщения:
    63
    Симпатии:
    1
    Баллы:
    29
    Спасибо все получилось. Тему можно закрывать)

Поделиться этой страницей