8.х Программное добавление кнопки на форме

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Svb, 17 июл 2014.

  1. TopicStarter Overlay
    Svb
    Offline

    Svb Опытный в 1С Команда форума

    Регистрация:
    12 янв 2011
    Сообщения:
    980
    Симпатии:
    19
    Баллы:
    29
    Добрый день.
    Хочу добавить кнопку на форму документа программно.
    Что сделал. В общем серверном модуле добавил две процедуры:
    Код:
    Процедура ДобавитьКнопкуСменыНомераДокумента(Форма) Экспорт
    
    СменитьНомерДокумента = Форма.Команды.Добавить("КомандаСменыНомера");
    СменитьНомерДокумента.Действие = "ДоработкиСервер.СменитьНомерДокумента";
    НоваяКнопка = Форма.Элементы.Добавить("КнопкаСменыНомераДокумента", Тип("КнопкаФормы"), Форма.Элементы.ГруппаНомерДата);
    НоваяКнопка.Вид = ВидКнопкиФормы.ОбычнаяКнопка;
    НоваяКнопка.ИмяКоманды = "КомандаСменыНомера";
    НоваяКнопка.Доступность = Истина;
    НоваяКнопка.Высота = 1;
    НоваяКнопка.Ширина = 2;
    //Элементы.ТоварыОткрытьПодбор.Картинка
    //Элементы.ТоварыОткрытьПодбор.Отображение = ОтображениеКнопки.Картинка;
    
    КонецПроцедуры
    
    Процедура СменитьНомерДокумента() Экспорт
    а = 0;
    КонецПроцедуры
    
    В модуле объекта документа добавляю вызов процедуры добавления кнопки:
    Код:
        // Svb 17.07.2014
        ДоработкиСервер.ДобавитьКнопкуСменыНомераДокумента(ЭтаФорма);
        // --
    
    КонецПроцедуры // ПриСозданииНаСервере()
    
    Кнопка появляется, но процедура общего модуля СменитьНомерДокумента() не вызывается...
  2. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.978
    Симпатии:
    397
    Баллы:
    104
    Потому что Вы не тот метод вызываете. Вы это на форме процедуру создайте. И ее к действию привяжите. А в ней уже вызывайте свою серверную процедуру.
    Svb нравится это.
  3. TopicStarter Overlay
    Svb
    Offline

    Svb Опытный в 1С Команда форума

    Регистрация:
    12 янв 2011
    Сообщения:
    980
    Симпатии:
    19
    Баллы:
    29
    Не хотелось бы добавлять процедуру в модуле формы. Но если по-другому никак, то добавлю.

Поделиться этой страницей