7.7 Программно установить значение общего реквизита документа

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем NASKALAR, 12 май 2016.

  1. TopicStarter Overlay
    NASKALAR
    Offline

    NASKALAR

    Регистрация:
    4 мар 2016
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Как Программно установить значение общего реквизита документа ?\
    Написал код для присвоения общему реквизиту всех документов значения 0:

    nn1=Метаданные.ОбщийРеквизитДокумента();
    Пока (1 = Док.ПолучитьДокумент()) Цикл
    nomerdok = Док.ТекущийДокумент();
    Для nn = 1 По nn1 Цикл
    Рекв = Метаданные.ОбщийРеквизитДокумента(nn).Идентификатор;
    Сообщить(Рекв);
    Если Рекв="Закрыт" Тогда
    nomerdok.УстановитьАтрибут(Рекв,0);
    Сообщить(nomerdok);
    КонецЕсли;
    //открываем новый документ
    КонецЦикла;
    КонецЦикла;

    Искал на сайтах, но на них указывается только как делать просмотр общих реквизитов документа.
    Код этот не записывает ноль в реквизит. Почему ?
  2. MaxxaM
    Offline

    MaxxaM Опытный в 1С

    Регистрация:
    16 окт 2007
    Сообщения:
    288
    Симпатии:
    2
    Баллы:
    29
    Ну если надо поставить в общий реквезит во все документы 1 значение, проще воспользоваться sql функцией update делов то на 1 минуту
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    1) А если база не скульная?
    2) Если реквизит действительно ОБЩИЙ, то и морочиться не стоит
    Док=СоздатьОбъект("Документ");
    Док.ВыбратьДокументы();
    Пока Док.ПолучитьДокумент()=1 Цикл
    Док.ИмяРеквизита=ВашеЗначение;
    Док.Записать();
    КонецЦикла;
  4. MaxxaM
    Offline

    MaxxaM Опытный в 1С

    Регистрация:
    16 окт 2007
    Сообщения:
    288
    Симпатии:
    2
    Баллы:
    29
    wdbfview или dbExplorer тоже позволяют выполнять SQL - запросы, update на 1000000 документов будет выполнятся минуту максимум 2, а вариат ВыбратьДокументы и т.д. - часа 2-3
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    а кто сказал, что база скульная?
  6. MaxxaM
    Offline

    MaxxaM Опытный в 1С

    Регистрация:
    16 окт 2007
    Сообщения:
    288
    Симпатии:
    2
    Баллы:
    29
    Угодник, а причем здесь скульная или нет? dbExplorer и wdbfview прекрасно работают с дбф, последний русифицирован и позволяет видеть удаленные записи, чем очень иногда помогает

Поделиться этой страницей