[РЕШЕНО] Программно удалить одну из проводок по документу

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем usha, 13 мар 2015.

  1. TopicStarter Overlay
    usha
    Offline

    usha

    Регистрация:
    13 мар 2015
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте! У нас с помощью обработки в программу вводятся документы "Поступление товаров и услуг","Поступление доп.расходов","Счета-фактуры полученные", т.к. складской учет ведется в другой программе (не в 1С). Но необходимо откорректировать проводки по документу "Поступление доп.расходов". Как изменить часть проводок я нашла, а как удалить одну из проводок - не знаю. Помогите, пожалуйста.
  2. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.548
    Симпатии:
    716
    Баллы:
    204
    Насколько понял вопрос:
    Код:
    .....
    НаборЗаписей.Прочитать();
    НаборЗаписей.Удалить(ИндексНужнойСтроки);
    НаборЗаписей.Записать();
  3. TopicStarter Overlay
    usha
    Offline

    usha

    Регистрация:
    13 мар 2015
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Спасибо, удаляет, но не ту строку. Делаю так:
    НаборЗаписей.Прочитать();
    Для каждого Запись из НаборЗаписей Цикл
    Если <Условие> Тогда
    номудзап=Запись.НомерСтроки;
    КонецЕсли;
    КонецЦикла;
    Если номудзап>0 Тогда
    НаборЗаписей.Удалить(номудзап);
    КонецЕсли;
    НаборЗаписей.Записать();​
  4. Svb
    Offline

    Svb Опытный в 1С Команда форума

    Регистрация:
    12 янв 2011
    Сообщения:
    980
    Симпатии:
    19
    Баллы:
    29
    Может "номудзап-1" попробовать?
  5. TopicStarter Overlay
    usha
    Offline

    usha

    Регистрация:
    13 мар 2015
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    А почему удаляется предыдущая строка?
  6. Svb
    Offline

    Svb Опытный в 1С Команда форума

    Регистрация:
    12 янв 2011
    Сообщения:
    980
    Симпатии:
    19
    Баллы:
    29
    Видимо, потому что вы ее удаляете програмно :)
    Выложите код полностью, записи до и после удаления.
  7. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.548
    Симпатии:
    716
    Баллы:
    204
    Потому что:
    НомерСтроки = ИндексСтроки + 1, а
    ИндексСтроки = НомерСтроки - 1
    Последнее редактирование: 13 мар 2015
  8. TopicStarter Overlay
    usha
    Offline

    usha

    Регистрация:
    13 мар 2015
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Спасибо за науку.

Поделиться этой страницей