8.х Программирование в 1С ПОМОГИТЕ

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем GAMI1991, 5 фев 2015.

  1. TopicStarter Overlay
    GAMI1991
    Offline

    GAMI1991 Опытный в 1С

    Регистрация:
    5 фев 2015
    Сообщения:
    71
    Симпатии:
    1
    Баллы:
    29
    Прошу Вас помочь мне, нужно в Обработке написать программу извлечения корня из 3 чисел и вывести результат в виде сообщения.
    Вот что дано:
    Процедура ВычислениеКорня(Вычислить)
    A=объект.А;
    B=объект.B;
    C=объект.С;


    КонецПроцедуры
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.760
    Симпатии:
    509
    Баллы:
    204
    В чем сложность ? На лекции не ходили :)))))))) ?
  3. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    предлагаю создать подраздел "Лабы, курсовые, дипломы" по аналогии с типовыми конфигурациями. Поймите правильно - не полное изготовление, а именно вопросы по данной тематике.

    по делу - ну тут чистая математика и ради пятницы вот вам решение
  4. ТехБухПривет
    Offline

    ТехБухПривет Профессионал в 1С Команда форума

    Регистрация:
    25 июн 2013
    Сообщения:
    504
    Симпатии:
    53
    Баллы:
    54
    Вы бы уточнили условия, ат о вдруг на лекции проходили циклы и было сказано реализовать циклом)))
    ну и после цикла не забудьте про:
    Сообщить()
    ;)
  5. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    а как корень в цикле вычислять?
  6. ТехБухПривет
    Offline

    ТехБухПривет Профессионал в 1С Команда форума

    Регистрация:
    25 июн 2013
    Сообщения:
    504
    Симпатии:
    53
    Баллы:
    54
    я говорил про Pow - возведение в степень - не вник в задание)):
    Код:
    ДвоичноеЧисло = 5;
    Степень= 2;
    Результат = 1;
    Для Количество = 1 по Степень Цикл
        Результат = Результат * ДвоичноеЧисло;
        Если
    КонецЦикла;   
    Сообщить(Результат);   
    
    // ИЛИ
    //СтепеньРезультата = Pow(ДвоичноеЧисло,Степень);
    
  7. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    и все равно не вник, тут корень из числа, а на степень как таковая
  8. ТехБухПривет
    Offline

    ТехБухПривет Профессионал в 1С Команда форума

    Регистрация:
    25 июн 2013
    Сообщения:
    504
    Симпатии:
    53
    Баллы:
    54
    вниК - Ты меня пугаешь)))
    Я просто увидел твое Pow(функция, которая возвращает нужную степень числа....) и вспомнил про этот старенький метод с циклом.....
  9. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    ага, а корень - это возведение в степень 1/n
  10. ТехБухПривет
    Offline

    ТехБухПривет Профессионал в 1С Команда форума

    Регистрация:
    25 июн 2013
    Сообщения:
    504
    Симпатии:
    53
    Баллы:
    54
    Понял тебя)) ну логика моей косой мысли в пред обеденном состоянии - это неописуемый и непредсказуемый процесс :D
  11. ТехБухПривет
    Offline

    ТехБухПривет Профессионал в 1С Команда форума

    Регистрация:
    25 июн 2013
    Сообщения:
    504
    Симпатии:
    53
    Баллы:
    54
    Вот корень)
    Код:
    А = 81;
    Для Х = 1 по А Цикл
       Если А = Х*Х тогда
         Сообщить(Х);
         Прервать;
       Иначе
       КонецЕсли;
    КонецЦикла;
  12. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    не поняла если честно
  13. ТехБухПривет
    Offline

    ТехБухПривет Профессионал в 1С Команда форума

    Регистрация:
    25 июн 2013
    Сообщения:
    504
    Симпатии:
    53
    Баллы:
    54
    По моему у кого-то похое настроение или замучили на работе((
    это только для целочисленных(без дроби) и это просто в шутку - упрощение задания так сказать - сам знаю, что не правильно - но надо было же придумать как вытянуть циклом...)))
    --- Объединение сообщений, 6 фев 2015 ---
    Ну а вообще, если всё так серьезно:( можно не замораживаться, а использовать:
    Код:
    Sqrt (Sqrt)
    Синтаксис:
    
    Sqrt(<Число>)
    Параметры:
    
    <Число> (обязательный)
    
    Тип: Число.
    Аргумент функции. Неотрицательное число.
    Возвращаемое значение:
    
    Тип: Число.
    Результат вычисления квадратного корня.
    Описание:
    
    Вычисляет квадратный корень параметра <Число>.
    
    Последнее редактирование: 6 фев 2015
  14. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    да замучали, и sqrt - это только квадратный корень... останусь при своем мнении пожалуй
Похожие темы
  1. sscc
    Ответов:
    0
    Просмотров:
    1.423
  2. Temz
    Ответов:
    2
    Просмотров:
    629
  3. Матвеева Ирина
    Ответов:
    1
    Просмотров:
    390
Загрузка...

Поделиться этой страницей