7.7 Программирование Штрих фр в 1С

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Сергей123, 15 авг 2013.

  1. TopicStarter Overlay
    Сергей123
    Offline

    Сергей123 Опытный в 1С

    Регистрация:
    11 июл 2013
    Сообщения:
    69
    Симпатии:
    0
    Баллы:
    26
    Доброго всем дня. подскажите пожалуйста как можно запрограммировать фискалку чтобы печаталась в чеке сумма скидки а не процент. процент вычисляется методом "Объект.DiscountOnCheck", есть метод Объект.Discount который, по идее, оперирует с суммой скидки. но при его использовании выдается ошибка: поле агрегатного объекта Discount не обнаружено. Как вывести в чеке сумму скидки?
    Код:
    Пока СписокТоваров.ПолучитьСтроку() = 1 Цикл
    Объект.Password		  = Пароль;
    Объект.StringForPrinting = Сред(СокрЛП(СписокТоваров.ТовНаим),1,32);
    Объект.Price			 = СписокТоваров.Цена;
    Объект.Quantity		  = СписокТоваров.Количество;
    Объект.Department	    = НомерСекции;
    
    Если ПризнВозврата = 0 Тогда
    Объект.Sale();
    Иначе
    Объект.ReturnSale();
    КонецЕсли;
    Если СписокТоваров.Количество=0 Тогда
    СуммаЧека=СуммаЧека+СписокТоваров.Цена*1;
    Иначе   
    СуммаЧека=СуммаЧека+СписокТоваров.Цена*СписокТоваров.Количество;
    КонецЕсли;
    Если Объект.ResultCode <> 0 Тогда
    ОписаниеРезультата = ПолучитьОписаниеРезультата(Объект);
    АннулированиеЧека(Объект, Пароль);
    
    Возврат 0;
    КонецЕсли;
    КонецЦикла;
    Если Получено>0 Тогда
    Получено=Получено;
    ИначеЕсли Получено=0 Тогда
    Получено=СуммаЧека;
    КонецЕсли;
    Объект.Password = Пароль;
    Если ОплатаКартой=0 Тогда
    Объект.Summ1    = Получено;
    Объект.Summ2    = 0;
    Объект.Summ3    = 0;
    Объект.Summ4    = 0;
    Иначе
    Объект.Summ1    = 0;
    Объект.Summ2    = 0;
    Объект.Summ3    = 0;
    Объект.Summ4    = Получено;
    
    КонецЕсли;
    Объект.StringForPrinting="Кассир: "+глПользователь;
    Объект.DiscountOnCheck=Скидка;
    Объект.CloseCheck();
  2. TopicStarter Overlay
    Сергей123
    Offline

    Сергей123 Опытный в 1С

    Регистрация:
    11 июл 2013
    Сообщения:
    69
    Симпатии:
    0
    Баллы:
    26
    Добился того что на чеке выводиться сумма скидки, но итоговые поля зависают, чек не проводиться. Добавил вместо
    Объект.DiscountOnChek=Скидка;
    следующее:
    Код:
    Объект.Password =Пароль;
    Объект.Summ1=СуммаСкидки; // ее вычисли в цикле ранее
    Объект.Tax1=0;
    Объект.Tax2=0;
    Объект.Tax3=0;
    Объект.Tax4=0;
    Объект.StringForPrinting = "";
  3. TopicStarter Overlay
    Сергей123
    Offline

    Сергей123 Опытный в 1С

    Регистрация:
    11 июл 2013
    Сообщения:
    69
    Симпатии:
    0
    Баллы:
    26
    Все. разобрался. тема закрыта. нашел свой же косяк.
  4. StAlexei
    Offline

    StAlexei

    Регистрация:
    6 фев 2014
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Сергей, поделитесь успехами, есть необходимость сделать примерно такое же (клиент просил изменить немного печать чека)
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    какие нужны изменения? Какая конфигурация?

Поделиться этой страницей