8.х УТ Продажа сертификата

Тема в разделе ""1С:Управление торговлей УТ"", создана пользователем Titov, 16 фев 2012.

  1. TopicStarter Overlay
    Titov
    Offline

    Titov Опытный в 1С

    Регистрация:
    13 апр 2008
    Сообщения:
    177
    Симпатии:
    1
    Баллы:
    26
    Добрый день!
    Работаю в УТ 10.3.13
    Менеджерам запрещено редактировать цены в документе реализация.

    Подскажите, у кого есть какие идеи как сделать следующее:

    Есть один товар, на который менеджеры должны иметь возможность менять цену в документе (она почти всякий раз разная будет).
    Сейчас запрет стоит галочка в типовых дополнительных правах пользователя - блокируется столбец цена.

    И еще одно условие, необходимо сделать чтобы если в документе есть этот товар то он должен быть там один - нельзя чтобы там еще что то присутствовало.

    Конфу можно редактировать, жду советов, спасибо
  2. vartanet
    Offline

    vartanet Опытный в 1С Команда форума

    Регистрация:
    16 ноя 2010
    Сообщения:
    2.698
    Симпатии:
    15
    Баллы:
    29
    1)


    Код:
    Процедура ТоварыПередНачаломИзменения(Элемент, Отказ)
    
    Если не (Элемент.ТекущаяКолонка.Имя="Цена" И Элемент.ТекущаяСтрока.Номенклатура.ШайтанРеквизит) Тогда
    Отказ = истина;
    возврат;
    КонецЕсли;
    
    КонецПроцедуры
    2)


    Код:
    Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
    
    ИскомаяНоменклатура = Справочники.Номенклатура.НайтиПоКоду("0756");
    Таблица = Товары.Выгрузить();
    Таблица.Свернуть("Номенклатура");
    
    Если Товары.Найти(ИскомаяНоменклатура)<>Неопределено И Таблица.Количество()>1 Тогда
    сообщить("тынц");
    Отказ = истина;
    возврат;
    КонецЕсли;
    
    КонецПроцедуры
  3. TopicStarter Overlay
    Titov
    Offline

    Titov Опытный в 1С

    Регистрация:
    13 апр 2008
    Сообщения:
    177
    Симпатии:
    1
    Баллы:
    26
    Если стоит запрет в дополнительных правах пользователя на редактирование цены - то такой вариант не работает, а если запрет не стоит тогда менеджер может поменять цену либо при подборе - указав галочку "цена" в нем. Либо если добавлять в тч товар нажатием на кнопку добавить, появляется в тч пустая строка в которую можно забить любые данные и они не проверяются до тех пор пока не кликнешь курсором по пустому место в тч - тогда уже строка фикируется и ваш вариант начинает работать...
    Как это можно решить?)
  4. TopicStarter Overlay
    Titov
    Offline

    Titov Опытный в 1С

    Регистрация:
    13 апр 2008
    Сообщения:
    177
    Симпатии:
    1
    Баллы:
    26
    Разобрался, ограничение на редактирование цены оставил, и сделал так:
    Код:
    мКолонкиТовары.Цена.ЭлементУправления.ТолькоПросмотр = Истина;			 
    Если НЕ (Элемент.ТекущаяКолонка.Имя="Цена" И Элемент.ТекущаяСтрока.Номенклатура.ШайтанРеквизит Тогда
    Отказ = истина;
    Возврат; 
    Иначе
    мКолонкиТовары.Цена.ЭлементУправления.ТолькоПросмотр = Ложь;			 
    КонецЕсли;

Поделиться этой страницей