8.х Процедура Сообщить()

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Elych, 23 май 2011.

  1. TopicStarter Overlay
    Elych
    Offline

    Elych

    Регистрация:
    23 май 2011
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте!
    Идея такова - я вхожу в систему и выскакивает окошко с теми делами, которые мне нужно сегодня сделать.
    Код писала в модуле формы задачи. Но не работает, а ошибок не выдает. Помогите, пожалуйста!
    Код:
    Процедура ПриНачалеРаботыСистемы()
    Для Каждого ЗадачиДела из Задачи Цикл
    Если (День(ДатаОкончания)=День(ТекущаяДата())) 
    и
    (Месяц(ДатаОкончания)=Месяц(ТекущаяДата()))
    и   (Год(ДатаОкончания)=Год(ТекущаяДата()))
    тогда
    Сообщить ("Не выполнено задание", имя)
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры
    
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Вы сами написали эту процедуру?
  3. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    И что такое ДатаОкончания?
  4. vartanet
    Offline

    vartanet Опытный в 1С Команда форума

    Регистрация:
    16 ноя 2010
    Сообщения:
    2.698
    Симпатии:
    15
    Баллы:
    29
    а мне непонятно что такое Задачи. и откуда в модуле формы задачи процедура ПриНачалеРаботыСистемы()?
  5. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Думаю лучше писать в модуле приложения, там есть процедура ПриНачалеРаботыСистемы(), вот там и нужно проверять ваши запланированные дела.

    Вот и я про то:)
  6. TopicStarter Overlay
    Elych
    Offline

    Elych

    Регистрация:
    23 май 2011
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Я только учусь, но знания в основном не систематизированы, а все урывками взято из поиска.
    ДатаОкончания - поле на ФормаЗадачи, которое указывает, к какому сроку нужно завершить дело.
    Задачи - Это я где-то подглядела строчку
    Код:
    ДляКаждого ДокументМенеджеры из Документы Цикл
    
    Помогите разобраться, пожалуйста. Куда что лучше писать, как писать :)

    И еще вопрос: может быть реализацию записи задач лучше поручить Документу? И в чем различие Задач и Документов, кроме кнопки "Выполнить"?

    Я понимаю, что в ваших глазах я безбожная тупица, но поверьте, перед тем как идти на форум, измучила поисковик вопросами:)

    Вот здесь нашла эту строчку http://www.cyberforum.ru/1c/thread117741.html
  7. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.549
    Симпатии:
    716
    Баллы:
    204
    может быстрее и лучше будет поглядеть как сей механизм реализован в типовых КА/УПП и иже с ними?
  8. TopicStarter Overlay
    Elych
    Offline

    Elych

    Регистрация:
    23 май 2011
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Простите, подробнее можно, где это точно есть и где его найти?
  9. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.549
    Симпатии:
    716
    Баллы:
    204
    в КА и УПП - точно есть. "Задачи пользователя" называются.

Поделиться этой страницей