8.х Процедура или функция с указанным именем не определена(СформироватьОтчет)

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Katisha, 26 фев 2016.

  1. TopicStarter Overlay
    Katisha
    Offline

    Katisha

    Регистрация:
    26 фев 2016
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Код:
    &НаКлиенте
    Процедура Сформировать(Команда)
        ТабДок=Новый ТабличныйДокумент;
        СформироватьОтчет(ТабДок);
        ТабДок.Показать();
     
                  КонецПроцедуры
    
    &НаСервреБезКонтекста
    
    Процедура СформироватьОтчет(ТабДок)
        //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
        // Данный фрагмент построен конструктором.
        // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    
        Макет = Отчеты.ЗакупкиПродажи_Объединение.ПолучитьМакет("Макет");
        Запрос = Новый Запрос;
        Запрос.Текст =
            "ВЫБРАТЬ
            |    ВложенныйЗапрос.Номенклатура,
            |    СУММА(ВложенныйЗапрос.Закупки) КАК Закупки,
            |    СУММА(ВложенныйЗапрос.Продажи) КАК Продажи
            |ИЗ
            |    (ВЫБРАТЬ
            |        ПриходнаяТовары.Номенклатура КАК Номенклатура,
            |        ПриходнаяТовары.Количество КАК Закупки,
            |        0 КАК Продажи
            |    ИЗ
            |        Документ.Приходная.Товары КАК ПриходнаяТовары
            | 
            |    ОБЪЕДИНИТЬ ВСЕ
            | 
            |    ВЫБРАТЬ
            |        РасходнаяТовары.Номенклатура,
            |        0,
            |        РасходнаяТовары.Количество
            |    ИЗ
            |        Документ.Расходная.Товары КАК РасходнаяТовары) КАК ВложенныйЗапрос
            |
            |СГРУППИРОВАТЬ ПО
            |    ВложенныйЗапрос.Номенклатура";
    
        Результат = Запрос.Выполнить();
    
        ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
        ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
        ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
        ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");
        ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");
    
        ТабДок.Очистить();
        ТабДок.Вывести(ОбластьЗаголовок);
        ТабДок.Вывести(ОбластьШапкаТаблицы);
        ТабДок.НачатьАвтогруппировкуСтрок();
    
        ВыборкаДетальныеЗаписи = Результат.Выбрать();
    
        Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
            ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
            ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетальныеЗаписи.Уровень());
        КонецЦикла;
    
        ТабДок.ЗакончитьАвтогруппировкуСтрок();
        ТабДок.Вывести(ОбластьПодвалТаблицы);
        ТабДок.Вывести(ОбластьПодвал);
    
        //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
               КонецПроцедуры



    Помогите пожалуйста найти ошибку
    Последнее редактирование модератором: 26 фев 2016
  2. Максим
    Offline

    Максим Опытный в 1С

    Регистрация:
    28 фев 2008
    Сообщения:
    684
    Симпатии:
    7
    Баллы:
    29
    Нужно писать не
    &НаСервреБезКонтекста
    , а
    &НаСервереБезКонтекста
  3. TopicStarter Overlay
    Katisha
    Offline

    Katisha

    Регистрация:
    26 фев 2016
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Спасибо,такая глупая ошибка)

Поделиться этой страницей