8.х Проблемы с отчетом "ОТЧЕТ ПО ПРОВОДКАМ"

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Z-bob, 7 авг 2013.

  1. TopicStarter Overlay
    Z-bob
    Offline

    Z-bob Опытный в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте, есть одна проблемка, есть работающий отчет "ОТЧЕТ ПО ПРОВОДКАМ", на формах документов есть реквизит Дата (обычная) и ДатаАудита, эти два реквизита показывают дату и не зависят друг от друга, каждая сама по себе. Даже можно сделать так чтобы Дата показывала сегодняшнюю дату, а ДатаАудита другую дату.
    Вот надо теперь сделать так, чтобы на форме отчета был флажок, и если флажок = истина то выводил те документы в которых разные даты реквизитов Дата и ДатаАудит, и если флажок = ложь то выводил все документы.
    Как это сделать? Подскажите с кодом...
  2. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    У Вас скорее всего в этом отчете есть функция: ПолучитьТекстЗапроса()

    В ней как раз и строится этот запрос. Вы там в зависимости от условия (вашей галочки) добавляйте или не добавляете есловие в текст запроса

    что то типа
    |ГДЕ
    | Проводки.Регистратор.Дата<>Проводки.Регистратор.ДатаАудита
  3. TopicStarter Overlay
    Z-bob
    Offline

    Z-bob Опытный в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    Спасибо, сейчас попробую...
  4. TopicStarter Overlay
    Z-bob
    Offline

    Z-bob Опытный в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    а если создать процедуру с запросом, как бы создать Процедура Флажок1ПриИзменении() и там внутри сделать запрос, так можно?
  5. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    Можно и так ну в любом случае Вам запрос надо писать в а данном отчет он собирается в зависимости от того какие отборы Вы ставите
  6. TopicStarter Overlay
    Z-bob
    Offline

    Z-bob Опытный в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    Код:
    Процедура Флажок1ПриИзменении() Экспорт
    
    Если ЭлементыФормы.Флажок1.Значение = ИСТИНА тогда
    Флажок1Истина();
    Иначе
    ОбновитьОтчет();
    КонецЕсли;
    
    КонецПроцедуры
    

    Код:
    Процедура Флажок1Истина(ВыводитьПолностью = Истина) Экспорт
    
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
    | АвансовыйОтчет.ДатаАудита,
    | АвансовыйОтчет.Дата,
    | АктОбОказанииПроизводственныхУслуг.ДатаАудита КАК ДатаАудита1,
    | АктОбОказанииПроизводственныхУслуг.Дата КАК Дата1,
    | ВозвратТоваровОтПокупателя.ДатаАудита КАК ДатаАудита2,
    | ВозвратТоваровОтПокупателя.Дата КАК Дата2,
    | ВозвратТоваровПоставщику.ДатаАудита КАК ДатаАудита3,
    | ВозвратТоваровПоставщику.Дата КАК Дата3,
    | ДокументРасчетовСКонтрагентом.ДатаАудита КАК ДатаАудита4,
    | ДокументРасчетовСКонтрагентом.Дата КАК Дата4,
    | ЗаявлениеОВвозеТоваровИУплатеКосвенныхНалогов.ДатаАудита КАК ДатаАудита5,
    | ЗаявлениеОВвозеТоваровИУплатеКосвенныхНалогов.Дата КАК Дата5,
    | КомплектацияНоменклатуры.ДатаАудита КАК ДатаАудита6,
    | КомплектацияНоменклатуры.Дата КАК Дата6,
    | КорректировкаДолга.ДатаАудита КАК ДатаАудита7,
    | КорректировкаДолга.Дата КАК Дата7,
    | ОприходованиеТоваров.ДатаАудита КАК ДатаАудита8,
    | ОприходованиеТоваров.Дата КАК Дата8,
    | ОтчетПроизводстваЗаСмену.ДатаАудита КАК ДатаАудита9,
    | ОтчетПроизводстваЗаСмену.Дата КАК Дата9,
    | Партия.ДатаАудита КАК ДатаАудита10,
    | Партия.Дата КАК Дата10,
    | ПередачаНМА.ДатаАудита КАК ДатаАудита11,
    | ПередачаНМА.Дата КАК Дата11,
    | ПередачаТоваров.ДатаАудита КАК ДатаАудита13,
    | ПередачаТоваров.Дата КАК Дата13,
    | ПеремещениеТоваров.ДатаАудита КАК ДатаАудита14,
    | ПеремещениеТоваров.Дата КАК Дата14,
    | ПлатежноеПоручениеВходящее.ДатаАудита КАК ДатаАудита15,
    | ПлатежноеПоручениеВходящее.Дата КАК Дата15,
    | ПлатежноеПоручениеИсходящее.ДатаАудита КАК ДатаАудита16,
    | ПлатежноеПоручениеИсходящее.Дата КАК Дата16,
    | ПлатежныйОрдерПоступлениеДенежныхСредств.ДатаАудита КАК ДатаАудита17,
    | ПлатежныйОрдерПоступлениеДенежныхСредств.Дата КАК Дата17,
    | ПлатежныйОрдерСписаниеДенежныхСредств.ДатаАудита КАК ДатаАудита18,
    | ПлатежныйОрдерСписаниеДенежныхСредств.Дата КАК Дата18,
    | ПоступлениеДопРасходов.ДатаАудита КАК ДатаАудита19,
    | ПоступлениеДопРасходов.Дата КАК Дата19,
    | ПоступлениеИзПереработки.ДатаАудита КАК ДатаАудита20,
    | ПоступлениеИзПереработки.Дата КАК Дата20,
    | ПоступлениеНМА.ДатаАудита КАК ДатаАудита21,
    | ПоступлениеНМА.Дата КАК Дата21,
    | ПоступлениеТоваровУслуг.ДатаАудита КАК ДатаАудита22,
    | ПоступлениеТоваровУслуг.Дата КАК Дата22,
    | ПриходныйКассовыйОрдер.ДатаАудита КАК ДатаАудита23,
    | ПриходныйКассовыйОрдер.Дата КАК Дата23,
    | РасходныйКассовыйОрдер.ДатаАудита КАК ДатаАудита24,
    | РасходныйКассовыйОрдер.Дата КАК Дата24,
    | РеализацияТоваровУслуг.ДатаАудита КАК ДатаАудита25,
    | РеализацияТоваровУслуг.Дата КАК Дата25,
    | РеализацияУслугПоПереработке.ДатаАудита КАК ДатаАудита26,
    | РеализацияУслугПоПереработке.Дата КАК Дата26,
    | РегистрацияПрочихОперацийПоПриобретеннымТоварамВЦеляхНДС.ДатаАудита КАК ДатаАудита27,
    | РегистрацияПрочихОперацийПоПриобретеннымТоварамВЦеляхНДС.Дата КАК Дата27,
    | РегистрацияПрочихОперацийПоРеализованнымТоварамВЦеляхНДС.ДатаАудита КАК ДатаАудита28,
    | РегистрацияПрочихОперацийПоРеализованнымТоварамВЦеляхНДС.Дата КАК Дата28,
    | СписаниеОС.ДатаАудита КАК ДатаАудита29,
    | СписаниеОС.Дата КАК Дата29
    |ИЗ
    | Документ.АктОбОказанииПроизводственныхУслуг КАК АктОбОказанииПроизводственныхУслуг
    |  ЛЕВОЕ СОЕДИНЕНИЕ Документ.АвансовыйОтчет КАК АвансовыйОтчет
    |  ПО АктОбОказанииПроизводственныхУслуг.Сделка = АвансовыйОтчет.Ссылка
    |  ЛЕВОЕ СОЕДИНЕНИЕ Документ.ВозвратТоваровОтПокупателя КАК ВозвратТоваровОтПокупателя
    |  ПО АктОбОказанииПроизводственныхУслуг.Сделка = ВозвратТоваровОтПокупателя.Ссылка
    |  ЛЕВОЕ СОЕДИНЕНИЕ Документ.ВозвратТоваровПоставщику КАК ВозвратТоваровПоставщику
    |  ПО АктОбОказанииПроизводственныхУслуг.Сделка = ВозвратТоваровПоставщику.Ссылка
    |  ЛЕВОЕ СОЕДИНЕНИЕ Документ.ДокументРасчетовСКонтрагентом КАК ДокументРасчетовСКонтрагентом
    |  ПО АктОбОказанииПроизводственныхУслуг.Сделка = ДокументРасчетовСКонтрагентом.Ссылка
    |  ЛЕВОЕ СОЕДИНЕНИЕ Документ.КорректировкаДолга КАК КорректировкаДолга
    |  ПО АктОбОказанииПроизводственныхУслуг.Сделка = КорректировкаДолга.Ссылка
    |  ЛЕВОЕ СОЕДИНЕНИЕ Документ.ПередачаНМА КАК ПередачаНМА
    |  ПО АктОбОказанииПроизводственныхУслуг.Сделка = ПередачаНМА.Ссылка
    |  ЛЕВОЕ СОЕДИНЕНИЕ Документ.ПередачаТоваров КАК ПередачаТоваров
    |  ПО АктОбОказанииПроизводственныхУслуг.Сделка = ПередачаТоваров.Ссылка
    |  ЛЕВОЕ СОЕДИНЕНИЕ Документ.ПлатежноеПоручениеВходящее КАК ПлатежноеПоручениеВходящее
    |  ПО АктОбОказанииПроизводственныхУслуг.Сделка = ПлатежноеПоручениеВходящее.Ссылка
    |  ЛЕВОЕ СОЕДИНЕНИЕ Документ.ПлатежноеПоручениеИсходящее КАК ПлатежноеПоручениеИсходящее
    |   ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗаявлениеОВвозеТоваровИУплатеКосвенныхНалогов КАК ЗаявлениеОВвозеТоваровИУплатеКосвенныхНалогов
    |   ПО ПлатежноеПоручениеИсходящее.ДокументОснование = ЗаявлениеОВвозеТоваровИУплатеКосвенныхНалогов.Ссылка
    |  ПО АктОбОказанииПроизводственныхУслуг.Сделка = ПлатежноеПоручениеИсходящее.Ссылка
    |  ЛЕВОЕ СОЕДИНЕНИЕ Документ.ПлатежныйОрдерПоступлениеДенежныхСредств КАК ПлатежныйОрдерПоступлениеДенежныхСредств
    |  ПО АктОбОказанииПроизводственныхУслуг.Сделка = ПлатежныйОрдерПоступлениеДенежныхСредств.Ссылка
    |  ЛЕВОЕ СОЕДИНЕНИЕ Документ.ПлатежныйОрдерСписаниеДенежныхСредств КАК ПлатежныйОрдерСписаниеДенежныхСредств
    |  ПО АктОбОказанииПроизводственныхУслуг.Сделка = ПлатежныйОрдерСписаниеДенежныхСредств.Ссылка
    |  ЛЕВОЕ СОЕДИНЕНИЕ Документ.ПоступлениеДопРасходов КАК ПоступлениеДопРасходов
    |  ПО АктОбОказанииПроизводственныхУслуг.Сделка = ПоступлениеДопРасходов.Ссылка
    |  ЛЕВОЕ СОЕДИНЕНИЕ Документ.ПоступлениеИзПереработки КАК ПоступлениеИзПереработки
    |  ПО АктОбОказанииПроизводственныхУслуг.Сделка = ПоступлениеИзПереработки.Ссылка
    |  ЛЕВОЕ СОЕДИНЕНИЕ Документ.ПоступлениеНМА КАК ПоступлениеНМА
    |  ПО АктОбОказанииПроизводственныхУслуг.Сделка = ПоступлениеНМА.Ссылка
    |  ЛЕВОЕ СОЕДИНЕНИЕ Документ.ПоступлениеТоваровУслуг КАК ПоступлениеТоваровУслуг
    |  ПО АктОбОказанииПроизводственныхУслуг.Сделка = ПоступлениеТоваровУслуг.Ссылка
    |  ЛЕВОЕ СОЕДИНЕНИЕ Документ.ПриходныйКассовыйОрдер КАК ПриходныйКассовыйОрдер
    |  ПО АктОбОказанииПроизводственныхУслуг.Сделка = ПриходныйКассовыйОрдер.Ссылка
    |  ЛЕВОЕ СОЕДИНЕНИЕ Документ.РасходныйКассовыйОрдер КАК РасходныйКассовыйОрдер
    |  ПО АктОбОказанииПроизводственныхУслуг.Сделка = РасходныйКассовыйОрдер.Ссылка
    |  ЛЕВОЕ СОЕДИНЕНИЕ Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
    |  ПО АктОбОказанииПроизводственныхУслуг.Сделка = РеализацияТоваровУслуг.Ссылка
    |  ЛЕВОЕ СОЕДИНЕНИЕ Документ.РеализацияУслугПоПереработке КАК РеализацияУслугПоПереработке
    |  ПО АктОбОказанииПроизводственныхУслуг.Сделка = РеализацияУслугПоПереработке.Ссылка
    |  ЛЕВОЕ СОЕДИНЕНИЕ Документ.РегистрацияПрочихОперацийПоПриобретеннымТоварамВЦеляхНДС КАК РегистрацияПрочихОперацийПоПриобретеннымТоварамВЦеляхНДС
    |   ЛЕВОЕ СОЕДИНЕНИЕ Документ.СписаниеОС КАК СписаниеОС
    |   ПО РегистрацияПрочихОперацийПоПриобретеннымТоварамВЦеляхНДС.ДокументОснование = СписаниеОС.Ссылка
    |  ПО АктОбОказанииПроизводственныхУслуг.Сделка = РегистрацияПрочихОперацийПоПриобретеннымТоварамВЦеляхНДС.Ссылка
    |  ЛЕВОЕ СОЕДИНЕНИЕ Документ.РегистрацияПрочихОперацийПоРеализованнымТоварамВЦеляхНДС КАК РегистрацияПрочихОперацийПоРеализованнымТоварамВЦеляхНДС
    |  ПО АктОбОказанииПроизводственныхУслуг.Сделка = РегистрацияПрочихОперацийПоРеализованнымТоварамВЦеляхНДС.Ссылка,
    | Документ.КомплектацияНоменклатуры КАК КомплектацияНоменклатуры,
    | Документ.ОприходованиеТоваров КАК ОприходованиеТоваров,
    | Документ.Партия КАК Партия,
    | Документ.ПеремещениеТоваров КАК ПеремещениеТоваров
    |  ЛЕВОЕ СОЕДИНЕНИЕ Документ.ОтчетПроизводстваЗаСмену КАК ОтчетПроизводстваЗаСмену
    |  ПО ПеремещениеТоваров.ДокументОснование = ОтчетПроизводстваЗаСмену.Ссылка";
    
    Результат = Запрос.Выполнить().Выгрузить();
    
    Если  тогда
    
    иначе
    
    КонецЕсли;					
    
    КонецПроцедуры			 



    я вот сделал запрос на документы где есть Дата и ДатаАудита, теперь не знаю как написать условие...подскажите с условием
  7. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    Ну это не верный запрос - отчет сроится по проводкам - данные из регистра беруться. а потом в условии пишите

    |ГДЕ
    | Проводки.Регистратор.Дата<>Проводки.Регистратор.ДатаАудита

    А с тем запрсом как вы написали ванадо для каждого документа такое условие прописать
  8. TopicStarter Overlay
    Z-bob
    Offline

    Z-bob Опытный в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    Код:
    Запрос.Текст = "ВЫБРАТЬ
    | АудиторскийДвиженияССубконто.СубконтоДт1.ДатаАудита,
    | АудиторскийДвиженияССубконто.СубконтоДт1.Дата,
    | АудиторскийДвиженияССубконто.СубконтоДт2.Дата,
    | АудиторскийДвиженияССубконто.СубконтоДт2.ДатаАудита,
    | АудиторскийДвиженияССубконто.СубконтоДт3.Дата,
    | АудиторскийДвиженияССубконто.СубконтоДт3.ДатаАудита,
    | АудиторскийДвиженияССубконто.СубконтоКт1.Дата,
    | АудиторскийДвиженияССубконто.СубконтоКт1.ДатаАудита,
    | АудиторскийДвиженияССубконто.СубконтоКт2.ДатаАудита,
    | АудиторскийДвиженияССубконто.СубконтоКт2.Дата,
    | АудиторскийДвиженияССубконто.СубконтоКт3.Дата,
    | АудиторскийДвиженияССубконто.СубконтоКт3.ДатаАудита
    |ИЗ
    | РегистрБухгалтерии.Аудиторский.ДвиженияССубконто КАК АудиторскийДвиженияССубконто";
    
    
    Результат = Запрос.Выполнить().Выбрать();
    
    Если ... тогда
    ...
    иначе
    ...
    КонецЕсли;          
    
    а как теперь с условием быть?
  9. TopicStarter Overlay
    Z-bob
    Offline

    Z-bob Опытный в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    Код:
    Запрос.Текст = "ВЫБРАТЬ
    | АудиторскийДвиженияССубконто.СубконтоДт1.ДатаАудита,
    | АудиторскийДвиженияССубконто.СубконтоДт1.Дата,
    | АудиторскийДвиженияССубконто.СубконтоДт2.Дата,
    | АудиторскийДвиженияССубконто.СубконтоДт2.ДатаАудита,
    | АудиторскийДвиженияССубконто.СубконтоДт3.Дата,
    | АудиторскийДвиженияССубконто.СубконтоДт3.ДатаАудита,
    | АудиторскийДвиженияССубконто.СубконтоКт1.Дата,
    | АудиторскийДвиженияССубконто.СубконтоКт1.ДатаАудита,
    | АудиторскийДвиженияССубконто.СубконтоКт2.ДатаАудита,
    | АудиторскийДвиженияССубконто.СубконтоКт2.Дата,
    | АудиторскийДвиженияССубконто.СубконтоКт3.Дата,
    | АудиторскийДвиженияССубконто.СубконтоКт3.ДатаАудита
    |ИЗ
    | РегистрБухгалтерии.Аудиторский.ДвиженияССубконто КАК АудиторскийДвиженияССубконто
    |ГДЕ
    | АудиторскийДвиженияССубконто.СубконтоДт1.Дата <> АудиторскийДвиженияССубконто.СубконтоДт1.ДатаАудита
    | И АудиторскийДвиженияССубконто.СубконтоДт2.Дата <> АудиторскийДвиженияССубконто.СубконтоДт2.ДатаАудита
    | И АудиторскийДвиженияССубконто.СубконтоДт3.Дата <> АудиторскийДвиженияССубконто.СубконтоДт3.ДатаАудита
    | И АудиторскийДвиженияССубконто.СубконтоКт1.Дата <> АудиторскийДвиженияССубконто.СубконтоКт1.ДатаАудита
    | И АудиторскийДвиженияССубконто.СубконтоКт2.ДатаАудита <> АудиторскийДвиженияССубконто.СубконтоКт2.Дата
    | И АудиторскийДвиженияССубконто.СубконтоКт3.ДатаАудита <> АудиторскийДвиженияССубконто.СубконтоКт3.Дата";
    а вот теперь запрос правильный?
    теперь после запроса надо что то написать чтобы выводил отчет
  10. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    у вас нигде в выборку регистратор не фигурирует. Регистратор может в выборку добавить
  11. TopicStarter Overlay
    Z-bob
    Offline

    Z-bob Опытный в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    а как это сделать?
  12. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    Ну если в вашей выборке в полях нет такого поля, то берите другую виртуальную таблицу а не ДвиженияССубконто, или у нее надо посмотерть какой вид движения. посмотрте в типовом запросе, какую использует
  13. TopicStarter Overlay
    Z-bob
    Offline

    Z-bob Опытный в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    типовая тоже использует ДвиженияССубконто, вроде в запросе все указал, условие поставил, теперь надо написать такой код чтобы просто выводил результат, вот ломаю голову, подскажите с кодом...
  14. TopicStarter Overlay
    Z-bob
    Offline

    Z-bob Опытный в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    Народ? подскажите
  15. TopicStarter Overlay
    Z-bob
    Offline

    Z-bob Опытный в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    а можно так сделать, типо если Флажок1ИСТИНА то в результате на форме он просто те документы в которых Дата и ДатаАудита одинаковые просто делал не видимыми?
    Ну как бы так:
    Код:
    Если Флажок1 = Истина тогда
    (скрывать)
    иначе
    (не скрывать)
    КонецЕсли;
    Подскажите народ
  16. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    а итоги будете заново подчитывать?
  17. TopicStarter Overlay
    Z-bob
    Offline

    Z-bob Опытный в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    я имею ввиду есть отчет, сформировали его, есть результат, и теперь просто не заморачиваясь и работать с результатом, сделать так чтобы если Флажок Истина то убирал те документы в которых Дата и ДатаАудита одинаковые, если Ложь то показывал все

    а вообще так можно?

    ато у меня получается так что отчет сформирован и если ставишь флажок то он опять формируется
  18. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    ну я же Вам и говорю, что есть отчет - есть его результат - у него есть данные и Итоги
    когда Вы будуте менять данные, вам надо и итоги поменять - не забудьте об этом
  19. TopicStarter Overlay
    Z-bob
    Offline

    Z-bob Опытный в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    ну у меня сейчас так и выходит, когда ставлю флажок отчет автоматически заново формируется.

    Код:
    ЭлементыФормы.Результат.Очистить();
    СтандартныеОтчетыАудит.ПроверитьЗаполнениеОбязательныхРеквизитов(ЭтаФорма);
    СтандартныеОтчетыАудит.СохранитьДанныеОтчета(ЭтаФорма); 
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
    | АудиторскийДвиженияССубконто.СубконтоДт1.ДатаАудита,
    | АудиторскийДвиженияССубконто.СубконтоДт1.Дата,
    | АудиторскийДвиженияССубконто.СубконтоДт2.Дата,
    | АудиторскийДвиженияССубконто.СубконтоДт2.ДатаАудита,
    | АудиторскийДвиженияССубконто.СубконтоДт3.Дата,
    | АудиторскийДвиженияССубконто.СубконтоДт3.ДатаАудита,
    | АудиторскийДвиженияССубконто.СубконтоКт1.Дата,
    | АудиторскийДвиженияССубконто.СубконтоКт1.ДатаАудита,
    | АудиторскийДвиженияССубконто.СубконтоКт2.ДатаАудита,
    | АудиторскийДвиженияССубконто.СубконтоКт2.Дата,
    | АудиторскийДвиженияССубконто.СубконтоКт3.Дата,
    | АудиторскийДвиженияССубконто.СубконтоКт3.ДатаАудита
    |ИЗ
    | РегистрБухгалтерии.Аудиторский.ДвиженияССубконто КАК АудиторскийДвиженияССубконто
    |ГДЕ
    | АудиторскийДвиженияССубконто.СубконтоДт1.Дата <> АудиторскийДвиженияССубконто.СубконтоДт1.ДатаАудита
    | И АудиторскийДвиженияССубконто.СубконтоДт2.Дата <> АудиторскийДвиженияССубконто.СубконтоДт2.ДатаАудита
    | И АудиторскийДвиженияССубконто.СубконтоДт3.Дата <> АудиторскийДвиженияССубконто.СубконтоДт3.ДатаАудита
    | И АудиторскийДвиженияССубконто.СубконтоКт1.Дата <> АудиторскийДвиженияССубконто.СубконтоКт1.ДатаАудита
    | И АудиторскийДвиженияССубконто.СубконтоКт2.ДатаАудита <> АудиторскийДвиженияССубконто.СубконтоКт2.Дата
    | И АудиторскийДвиженияССубконто.СубконтоКт3.ДатаАудита <> АудиторскийДвиженияССубконто.СубконтоКт3.Дата";
    
    РезультатЗапроса = Запрос.Выполнить().Выгрузить();
    
    Если РезультатЗапроса Тогда
    Если Не СтандартныеОтчетыАудит.ПроверитьЗаполнениеОбязательныхРеквизитов(ЭтаФорма) Тогда
    Возврат;
    КонецЕсли;
    КонецЕсли; 
    
    Если РежимРасшифровки Тогда
    РежимРасшифровки = Ложь;
    Иначе
    СтандартныеОтчетыАудит.СохранитьДанныеОтчета(ЭтаФорма);   
    КонецЕсли;
    
    Если НастройкиФормы.ЗакрыватьПанельПриФормированииОтчета И РезультатЗапроса Тогда
    ЭлементыФормы.ДействияФормыДополнительные.Кнопки.ПанельПользователя.Пометка = Ложь;
    СтандартныеОтчетыАудит.УправлениеОтображениемПанелиПользователя(ЭтаФорма);
    КонецЕсли;
    
    СформироватьОтчет(ЭтаФорма.ЭлементыФормы.Результат, ДанныеРасшифровки, Ложь, , РезультатЗапроса);
    
    СтандартныеОтчетыАудит.ОбновитьКоллекциюКнопокИстории(ЭтаФорма);
    
  20. TopicStarter Overlay
    Z-bob
    Offline

    Z-bob Опытный в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    146
    Симпатии:
    0
    Баллы:
    26
    так как мне быть?

Поделиться этой страницей