[РЕШЕНО] Проблемы с нетиповыми ролями. УТ 11.1

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Svb, 15 июн 2016.

  1. TopicStarter Overlay
    Svb
    Online

    Svb Опытный в 1С Команда форума

    Регистрация:
    12 янв 2011
    Сообщения:
    980
    Симпатии:
    19
    Баллы:
    29
    Добрый день.
    Ситуация: создаю в конфигураторе новую роль (например, РольПускатьВезде ), обновляю конфигурацию, запускаю в режиме "Предприятие".
    Создаю новый профиль ПрофильПускатьВезде, добавляю в него РольПускатьВезде... ошибка. Иду обновляю справочник "Идентификаторы объектов метаданных". После этого профиль создается без ошибки.
    Создаю группу доступа ГруппаПускатьВезде, указываю в ней профиль ПрофильПускатьВезде. Подбором указываю пользователя Вася Пупкин в группу доступа, записываю.
    Проверяю, права Васи Пупкина не присвоились, лезу в конфигуратор, открываю Васю Пупкина, перехожу на вкладку "Прочее", галки напртотив роли РольПускатьВезде - нет. А должна быть.

    Что сделано:
    1. Обновлены параметры пользователей - не помогло.
    Код:
    &НаКлиенте
    Процедура ОбновитьПараметрыПользователей(Команда)
       
        ТекстОшибки = "";
        ОбновитьПараметрыПользователейСервер(ТекстОшибки);
    
        Если ТекстОшибки = "" Тогда
            Предупреждение("Выполнено!");
        Иначе
            Предупреждение("Не удалось обновить параметры пользователей!" + Символы.ПС + ТекстОшибки);
        КонецЕсли;
       
    КонецПроцедуры
    
    &НаСервере
    Процедура ОбновитьПараметрыПользователейСервер(ТекстОшибки="")
       
        Попытка
            Константы.ПараметрыРаботыПользователей.СоздатьМенеджерЗначения().ОбновитьОбщиеПараметры();
        Исключение
            ТекстОшибки = ОписаниеОшибки();
        КонецПопытки;
       
    КонецПроцедуры
    2. Обновлено в режиме "Обновлять всё" обработкой из БСП: ИнструментыРазработчикаОбновлениеВспомогательныхДанных. Результата нет.

    Что делать?
  2. TopicStarter Overlay
    Svb
    Online

    Svb Опытный в 1С Команда форума

    Регистрация:
    12 янв 2011
    Сообщения:
    980
    Симпатии:
    19
    Баллы:
    29
    Пункт 2, а именно обработка "ИнструментыРазработчикаОбновлениеВспомогательныхДанных" проблему решает. Оказывается, надо просто уметь ее готовить.

Поделиться этой страницей