[РЕШЕНО] Проблемы с именем файла

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Samouchka, 9 окт 2014.

  1. TopicStarter Overlay
    Samouchka
    Offline

    Samouchka Опытный в 1С

    Регистрация:
    20 мар 2013
    Сообщения:
    214
    Симпатии:
    1
    Баллы:
    29
    Всех приветствую! 1С не умещает имя файла. Пишу код для добавления файла в электронное письмо. Вот ошибка:
    При попытке присоединить файл произошла ошибка : Файл "D:\Базы программ\1С Конфигурация\Нужные мне файлы\Проверить загруз\PFR-700-Y-2014-ORG-036-019-000423-DCK-00031-DPT-000000-DCK-0000" не найден.
    Действительно, в имени файла не хватает "0.XML". Но переименовывать файл нельзя, т.к. это специальное имя для представления отчета в Пенсионный фонд. Вот процедура выбора файла, которая вернула полное имя (ТЗ.ПутьФайла). Может у кого-нибудь есть какие-то мысли, чтоб уместить имя файла (менять каталог на более короткий не предлагать):
    Код:
    Процедура ДобавитьФайл()
        ВыборОтчет=СокрЛП(Константа.КаталогФайловЭлПочты);
        ВыбКаталОтчета=ФС.ВыбратьФайл(0,НазваниеФайла,ВыборОтчет,"Выберите файл",,,);
        Если ВыбКаталОтчета=1 Тогда
            ТЗ.НоваяСтрока();
            ТЗ.ПутьФайла=ВыборОтчет+НазваниеФайла;
            ТЗ.НаимФайла=НазваниеФайла;
        КонецЕсли;
    КонецПроцедуры
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    увеличьте длину строки в ТаблицеЗначений. Или сделайте не типизированной колонку НаимФайла
  3. TopicStarter Overlay
    Samouchka
    Offline

    Samouchka Опытный в 1С

    Регистрация:
    20 мар 2013
    Сообщения:
    214
    Симпатии:
    1
    Баллы:
    29
    Делал - не помогает. Даже с неограниченной длиной не выходит. Специально создал реквизит СмотретьПуть, приравнял его к ВыборОтчет+НазваниеФайла. Тип данного реквизита сначала пробовал Строка неограниченной длины, затем Неопределено. Итог один - не хватает оконцовки "0.XML". Я, кстати не сказал, что в коде сделал переменную НазваниеФайла. Может, в этом дело? Вот какой щас полный код:
    Код:
    Перем НазваниеФайла;
     
    Процедура ДобавитьФайл()
        ВыборОтчет=СокрЛП(Константа.КаталогФайловЭлПочты);
        ВыбКаталОтчета=ФС.ВыбратьФайл(0,НазваниеФайла,ВыборОтчет,"Выберите файл",,,);
        Если ВыбКаталОтчета=1 Тогда
            ТЗ.НоваяСтрока();
            ТЗ.ПутьФайла=ВыборОтчет+НазваниеФайла;
            ТЗ.НаимФайла=НазваниеФайла;
            СмотретьПуть=ВыборОтчет+НазваниеФайла;
        КонецЕсли;
    КонецПроцедуры
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    где определяете таблицу значений?
  5. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    375
    Баллы:
    104
    про не предлагать менять путь я видел, но всё же, если его изменить (урезать на пару уровней средних) то что будет?

    PS
    по мне удобнее не "D:\Базы программ\1С Конфигурация\Нужные мне файлы\Проверить загруз\"
    а "D:\Базы программ\Проверить загруз\" или "D:\Базы программ\Нужные мне файлы\Проверить загруз\"

    IMHO
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Да тут дело ясное, что не хватает длины символов в ТаблицеЗначений
  7. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    не, это не ТЗ, это команда ФС.ВыбратьФайл режет, ничё не сделаешь.
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Не обращал внимания.. Нужно проэкспериментировать предел...
    Тогда - WSH в руки. Думаю там нет ограничений
  9. TopicStarter Overlay
    Samouchka
    Offline

    Samouchka Опытный в 1С

    Регистрация:
    20 мар 2013
    Сообщения:
    214
    Симпатии:
    1
    Баллы:
    29
    Хряк прав! А что значит "WSH в руки" - я не знаю, подскажите
  10. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    можно и штатно
    прочитай каталог методами ФС.НайтиПервыйФайл, найтиследующийфайл, запихни в список, оттуда и выбирай
  11. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    375
    Баллы:
    104
    угу, порылся тут,
    оказывается режет, но весьма хитро
    режет только имя файла до 63 символов, так что длинный путь из папок тут не при делах

    как вариант "префикс" "PFR-" подставлять позднее выбора
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Это Windows Script. Из 1с можно применять...
    Но вам я думаю лучше сделать как предложил Хряк.
  13. TopicStarter Overlay
    Samouchka
    Offline

    Samouchka Опытный в 1С

    Регистрация:
    20 мар 2013
    Сообщения:
    214
    Симпатии:
    1
    Баллы:
    29
    Всем спасибо за внимание, дорогие форумчане! Буду делать как предложили.

Поделиться этой страницей