7.7 проблемка

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Archivar, 26 дек 2013.

  1. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    я просто не знаю куда(
    но оно там работает

    я наименование 80 и длину кода 20 поставил...Вы вроде сказали добавить их....а убирали то мы так
  2. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    если я чисто создаю обработку новую то пишет
    Спр.Наименование=Спр.ОрганизацияД.Наименование;
    {Обработка.новый1.Форма.Модуль(7)}: Изменено Наименование! Может быть нарушена последовательность выборки!
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    1) Код УБРАТЬ. Он вам вообще не нужен
    2) Обработку из конфигурации УБРАТЬ
    3) Обработку переписать так и 1 раз запустить:
    Код:
    Сз=СоздатьОбъект("СписокЗначений");
    Спр=СоздатьОбъект("Справочник.КакТамУВасЗадано");
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()=1 Цикл
    Если Спр.ЭтоГруппа()=1 Тогда
    Продолжить;
    КонецЕсли;
    СЗ.ДобавитьЗначение(Спр.ТекущийЭлемент());
    КонецЦикла;
    
    Для к=1 По СЗ.РазмерСписка() Цикл
    Спр.НайтиЭлемент(СЗ.ПолучитьЗначение(к))
    Спр.Наименование=Спр.РеквизитОрганизация.Наименование;
    Спр.Записать();
    КонецЦикла;
    
    4) Не забыть добавить ПриЗаписи (см. выше)
  4. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26

    Вопрос в том что я не знаю куда эту обработку переписывать.
    Я думал что Вы имеете ввиду обработку в конфиге
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Сделайте ВНЕШНЮЮ обработку.
    Все же вы не внимательно читаете что вам пишут.
  6. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    ОО все работает. СПАСИБО БОЛЬШОЕ.


    Если не сложно объясните мне каким образом данная обработка все исправила?

    Что она поменяла что нельзя было без нее ручками переписать?

    Я прост принцип еще внешних не знаю...в интернете пишут что вот они есть и радуйся
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
  8. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    равен нулю поставил, наименование только оставил
  9. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Ну вот. Вы убрали код. По умолчанию основное представление стало наименование. Сортировка тоже по наименование (поэтому элементы по фирме у вас упорядочились). Осталось только проверить: заполняется ли наименование при записи/изменении элемента
  10. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    В справочнике все ок сортирует и добавляет и сохраняет.
    В документе в реквизит добавляет и отображает
    все работает ок
  11. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Ну хорошо. Тему считаю завершенной.
  12. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    Спасибо большое еще раз
  13. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Не за что. Обращайтесь

Поделиться этой страницей