7.7 проблемка

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Archivar, 26 дек 2013.

  1. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    Создал справочник Доверенности - там колонки: Организация,Номер,Кому,Датанач,датаокончания.

    Решил их в Накладную добавить. в качестве шапки.

    так вот в чем проблема:
    КонтрПлат - это контрагент - оплативший
    контр - контрагент получивший
    Контр - заполняется выбором из справочника, т.е. типа Справочник.Контрагенты
    И как видно из кода он при заполнении копируется в КонтрПлат.
    Вопросы:
    1) При попытке также сделать с ОрганизацияД(это реквизит справочника Доверенности) при выборе, организация не выбирается, а пишет <> эти знаки, перепробовал все комбинации....не получается...

    2) И еще я не знаю как именно написать так чтобы она КонтрПлат=Контр и еще =ОрганизацияД..


    Код:
    Процедура ПриВводеКонтр()
    
    Спр=СоздатьОбъект("Справочник.Доверенности"); 
    
    Если Контр.выбран()=1 тогда
    КонтрПлат=Контр;
    
    номерД=спр.номер;   //это неработает, т.к. что-то не хватает(
    
    //УпЛицоД=
    //ОрганизацияД=
    //ДатавыдачиД=
    //ДатаОкончанияД=
    
    КонецЕсли;
    КонецПроцедуры

    Помогите плз
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Вы не верно подошли к вопросу как мне кажется. Доверенность д.б ДОКУМЕНТ, а не справочник. Вы что будите в следующем году делать с нумерацией? Она же каждый год идет с начала...
    + Организацию, контрагент, сумму можно заполнять при вводе на основании накладной.
  3. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    Не, это как бы по задумке должен быть справочник. Т.к. Нам приносят доверенности на бумажном носителе, при выписке документов вносим данные вручную, + продавцы вынуждены каждый раз звонить в бухгалтерию и спрашивать есть ли доверенность на "такое-то лицо". Потому я и создал справочник. В начале каждого года просто будут менять номера доверенностей и их дату, т.к. полномочные почти всегда теже.
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Код:
    номерД=спр.номер;   //это неработает, т.к. что-то не хватает(
    
    Как вариант - у вас дубль переменная
    Т.е. на форме есть реквизит номерД и в модуле объявлена одноименная. В этом случае на форме не отобразится
  5. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    Фишка в том что я на форме реквизит создал - ОрганизацияД- у него тип Справочник.Доверенности - так вот если выбирать организацию ставится <> . Название не пишет.


    А реквизит то НомерД у меня не связан ни с чем у него тип - Число, я просто думал как то через модуль их связать...чтобы при выборе
    Код:
    Если Контр.выбран()=1 тогда
    КонтрПлат=Контр;
    Выбиралась и ОрганизацияД и НомерД и ДатаД и тд..
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Наименование справочника у вас заполнено? В конфигураторе какое его основное представление?
  7. Катюфка
    Offline

    Катюфка Профессионал в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    412
    Симпатии:
    72
    Баллы:
    54
    Здравствуйте.
    Я согласна с Б.Угодником, что Вы изначально неправильно продумали структуру данных. Я бы сделала справочник Доверенности подчиненным справочнику Контрагенты и тогда можно было бы через метод ИспользоватьВладельца() найти нужный элемент.
    На мой взгляд, Вы совсем не заполняете Наименование справочника Доверенности.
    В вашем случае должно помочь простое приравнивание реквизита Наименование реквизиту Организация в форме справочника Доверенности в процедуре ПриСохранении().
    Только не забудьте, что Наименование - это текст, поэтому присваивание должно быть соответствующим:
    Код:
    Наименование = Организация.Наименование;
    Это годится лишь в том случае, если каждому контрагенту соответствует один элемент в Доверенности. Если Вы планируете их неограниченное количество, то логику нужно продумывать совсем по-другому. Тогда перебором справочника Доверенности отбирать все элементы с нужной Организацией в список значений и показывать весь список на форме, а пользователю уже выбирать нужный. Ведь мы не знаем, какую именно доверенность в данный момент нужно использовать.
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Это в том случае если наименование есть в справочнике. А собственно зачем там лишняя информация?
    Нужно УБРАТЬ наименование и код. Тогда будет отображаться первый реквизит (организация)

    Ну... Там же есть период действия.
  9. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26

    Я сделал так чтобы удобно было продавцам смотреть - чисто список, Боюсь просто у Нас сложилась такая практика, что удобней было бы так и бух и прод.



    В справочниках: Доверенности - идентификатор. В нем 5ть реквизитов: ОрганизацияД(у которого тип: Справочники.Контрагенты - т.к. от туда он забирает название организации), НомерД, УпЛицо, ДатаВыдачи, Датаокончания.

    В Документе Накладная: НомерД, ОрганизацияД(тип Справочники.Доверенности), ДатавыдачиД, ДатаокончанияД, УпЛицоД.
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Уберите наименование/код из справочника... Все равно оно вам не нужно. В выбранном реквизите отобразится организация......
  11. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    Так их там нет, я их изначально не задействовал,а чисто реквизиты новые создал
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Не задействовать и убрать - разные вещи!
    См. в свойствах справочника в конфигураторе. Д.быть
    длина кода 0
    длина наименования 0
  13. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    действительно! заработало.

    А каким действием правильно описать:

    КонтрПлат=Контр=ОрганизацияД;

    сейчас у меня КонтрПлат=Контр, хотелось чтобы он при Выборе Контр(Контрагент) еще и ОрганизацияД выбирал авто.
  14. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Мне НЕ ПОНЯТНО ваше "не задействовал". Вы их убрали из конфигурации или нет?

    Т.е. ОрганизацияД имеет реквизит "авто" и оно д.б. заполнено в документе?
  15. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    Не задействовал т.е. просто в форме не использовал, но теперь я 0 поставил как вы и сказали и значение из справочника передается. За что Вам отдельное спасибо.


    Код:
    Процедура ПриВводеКонтр()
    
    Спр=СоздатьОбъект("Справочник.Доверенности");
    
    Если Контр.выбран()=1 тогда
    КонтрПлат=Контр;
    Если спр.ОрганизацияД.выбран()=1 тогда
    
    номерД=спр.номерД;
    УпЛицоД=спр.УпЛицо;
    ДатавыдачиД=спр.Датавыдачи;
    ДатаОкончанияД=спр.ДатаОкончания;
    КонецЕсли;
    
    КонецЕсли;
    КонецПроцедуры
    Сейчас вопросики: это как сделать так чтобы помимо КонтрПлат=Контр; еще и = ОрганизацияД было. Т.е. КонтрПлат(это платильщик) а Контр(это чисто контрагент по заявки), при заполнении. Т.к. зачастую Контр и КнотрПлат одно лицо то КонтрПлат копирует значение Контр. И хотелось бы чтобы оно копировало автоматически в ОрганизацияД
    и почему то не копирует значения:
    НомерД=спр.номерД;
    УпЛицоД=спр.УпЛицо;
    ДатавыдачиД=спр.Датавыдачи;
    ДатаОкончанияД=спр.ДатаОкончания;
  16. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Код:
    Спр=СоздатьОбъект("Справочник.Доверенности");
    
    Если Контр.выбран()=1 тогда
    КонтрПлат=Контр;
    Если спр.ОрганизацияД.выбран()=1 тогда //вот тут ошибка! Вы создали объект. Выборки нет. Он ПУСТОЙ.
    //м.б. вот так:  Если ОрганизацияД.выбран()=1 тогда
    
    номерД=спр.номерД;
    УпЛицоД=спр.УпЛицо;
    ДатавыдачиД=спр.Датавыдачи;
    ДатаОкончанияД=спр.ДатаОкончания;
    КонецЕсли;
    
    КонецЕсли;
    КонецПроцедуры
  17. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    Не выходит...я так в начале пробовал..
  18. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    В документе реквизит типа Справочник.Доверенности как у вас называется?
  19. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    ОрганизацияД
  20. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Код:
    Спр=СоздатьОбъект("Справочник.Доверенности");
    
    Если Контр.выбран()=1 тогда
    КонтрПлат=Контр;
    Если ОрганизацияД.выбран()=1 тогда
    
    номерД=ОрганизацияД.номерД;
    УпЛицоД=ОрганизацияД.УпЛицо;
    ДатавыдачиД=ОрганизацияД.Датавыдачи;
    ДатаОкончанияД=ОрганизацияД.ДатаОкончания;
    КонецЕсли;
    
    КонецЕсли;
    КонецПроцедуры

Поделиться этой страницей