7.7 Проблема вывода на печать

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем fantas, 6 июл 2007.

  1. TopicStarter Overlay
    fantas
    Offline

    fantas Опытный в 1С

    Регистрация:
    12 июл 2006
    Сообщения:
    104
    Симпатии:
    0
    Баллы:
    26
    //Договір
    Таб.ВывестиСекцию("Шапка");
    змСума=0;
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    Если ТМЦ.ВидТМЦ=Перечисление.ВидыТМЦ.Товар Тогда
    Таб.ВывестиСекцию("Товар");
    змСума=змСума+(ЦенаБезНДС*Кво);
    КонецЕсли;
    КонецЦикла;
    Таб.ВывестиСекцию("Низ");

    //Накладна
    Таб.НоваяСтраница(64);
    Таб.ВывестиСекцию("ШапкаН");
    зСумаВ=0;
    Ном=0;
    зНДС=0;
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    Если ТМЦ.ВидТМЦ=Перечисление.ВидыТМЦ.Товар Тогда
    Ном=Ном+1;
    Таб.ВывестиСекцию("ТоварН");
    зСумаВ=зСумаВ+(ЦенаБезНДС*Кво);
    зНДС=зНДС+НДС;
    КонецЕсли;
    КонецЦикла;
    Таб.ВывестиСекцию("НизН");

    //Рахунок і Відомість
    Таб.ВывестиСекцию("ШапкаР");
    зСумаВ=0;
    Ном=0;
    зНДС=0;
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    Если ТМЦ.ВидТМЦ=Перечисление.ВидыТМЦ.Товар Тогда
    Ном=Ном+1;
    Таб.ВывестиСекцию("ТоварР");
    зСумаВ=зСумаВ+(ЦенаБезНДС*Кво);
    зНДС=зНДС+НДС;
    КонецЕсли;
    КонецЦикла;
    Таб.ВывестиСекцию("НизРВ");

    //Бланк
    Таб.НоваяСтраница(110);
    Таб.ВывестиСекцию("Бланк");

    //Мал
    Таб.НоваяСтраница(180);
    Таб.ВывестиСекцию("Мал");

    ******************
    почему-то при выводе на печать (при предварительном просмотре) выводит за каждой заполненой страницой - пустую страницу (после 1-ой пустая, после 3-ей пустая и т. д.). Почему? Что надо исправить?
  2. Steel Rain
    Offline

    Steel Rain Опытный в 1С

    Регистрация:
    29 сен 2006
    Сообщения:
    408
    Симпатии:
    2
    Баллы:
    29
    Могу предположить, что это связано с методом НоваяСтраница(), попробуй поменять количество строк в параметре или вообще убрать оттуда число.
  3. TopicStarter Overlay
    fantas
    Offline

    fantas Опытный в 1С

    Регистрация:
    12 июл 2006
    Сообщения:
    104
    Симпатии:
    0
    Баллы:
    26
    Забрал числа - результат тот же.
  4. TopicStarter Overlay
    fantas
    Offline

    fantas Опытный в 1С

    Регистрация:
    12 июл 2006
    Сообщения:
    104
    Симпатии:
    0
    Баллы:
    26

Поделиться этой страницей