7.7 Проблема в бух итогах

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем alp, 12 апр 2010.

  1. TopicStarter Overlay
    alp
    Offline

    alp Опытный в 1С

    Регистрация:
    8 янв 2009
    Сообщения:
    432
    Симпатии:
    0
    Баллы:
    26
    Добрый день! есть такая проблема, бух итоги У МЕНЯ выдают не то сальдо на конец периода.
    Код:
    Функция ИдКолонки(Счет)
    Если Счет=СчетПоКоду(62.1) Тогда
    Возврат "_62_1";
    ИначеЕсли Счет=СчетПоКоду(62.6) Тогда
    Возврат "_62_6";
    ИначеЕсли Счет=СчетПоКоду(62.2) Тогда
    Возврат "_62_2";
    ИначеЕсли Счет=СчетПоКоду(62.7) Тогда
    Возврат "_62_7";
    Иначе
    Возврат 0;
    КонецЕсли;
    КонецФункции
    //-----------------------
    Процедура ЗаполнитьСальдо(НомерСтроки,Счет,БухИт)
    ИмяКолонки=ИдКолонки(Счет);
    Если ИмяКолонки=0 Тогда
    Возврат;
    КонецЕсли; 
    //Нач Сальдо
    Если БухИт.СКК()<>0 Тогда
    Сумма=БухИт.СНК();
    Иначе
    Сумма=БухИт.СНД();
    КонецЕсли;
    ТаблицаДанных.УстановитьЗначение(НомерСтроки,ИмяКолонки+"Начало",Сумма);
    //Кон Сальдо
    
    Если БухИт.СКК()<>0 Тогда
    Сумма=БухИт.СКК();
    Иначе
    Сумма=БухИт.СКД();
    КонецЕсли;
    ТаблицаДанных.УстановитьЗначение(НомерСтроки,ИмяКолонки+"Конец",Сумма);
    КонецПроцедуры
    
    СписокКорСчетов=СоздатьОбъект("СписокЗначений");
    СписокКорСчетов.ДобавитьЗначение(СчетПоКоду(51));
    СписокКорСчетов.ДобавитьЗначение(СчетПоКоду(90));
    СписокКорСчетов.ДобавитьЗначение(СчетПоКоду(91));
    
    БухИт=СоздатьОбъект("БухгалтерскиеИтоги");
    Если ВыбКонтрагент.Выбран()=1 Тогда
    БухИт.ИспользоватьСубконто(ВидыСубконто.Контрагенты,ВыбКонтрагент);
    Иначе
    БухИт.ИспользоватьСубконто(ВидыСубконто.Контрагенты);
    КонецЕсли;
    БухИт.ИспользоватьСубконто(ВидыСубконто.Договоры);
    БухИт.ВключатьСубсчета(-1,0);
    Если БухИт.ВыполнитьЗапрос(НачДата,КонДата,"62.1,62.6,62.2,62.7",СписокКорСчетов,,3,,)=0 Тогда
    Возврат;
    КонецЕсли;
    КолСтрок=0;
    БухИт.ВыбратьСубконто(1);
    Пока БухИт.ПолучитьСубконто(1)=1 Цикл
    КолСтрок=КолСтрок+1;
    Таблица.НоваяСтрока();
    Таблица.Контрагент=БухИт.Субконто(1);
    //заполнит сальдо.
    БухИт.ВыбратьСчета();
    Пока БухИт.ПолучитьСчет()=1 Цикл
    ЗаполнитьСальдо(КолСтрок,БухИт.Счет,БухИт);		
    КонецЦикла;
    ...................................
    
    
    Проблема в том если я формирую за 1 квартал 2010г свой отчет по контрагенту "А" например, то конечное сальдо у меня не сходиться с ОСВ "по счету", но если я сформирую за март 2010г то конечное сальдо правильное!
    в чем проблема и с чем связано не могу понять.


    Платформа 25.
    РЕЛИЗ 512 БУХ.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Такое по всем контрагентам или только по"А"? Может создали ручную операцию по "А" без указания договра - тогда такая картина реальна
  3. TopicStarter Overlay
    alp
    Offline

    alp Опытный в 1С

    Регистрация:
    8 янв 2009
    Сообщения:
    432
    Симпатии:
    0
    Баллы:
    26
    нет не по всем , а по некоторым.

    спасибо, проверю.
  4. TopicStarter Overlay
    alp
    Offline

    alp Опытный в 1С

    Регистрация:
    8 янв 2009
    Сообщения:
    432
    Симпатии:
    0
    Баллы:
    26
    Проблема заключается в том что , если в параметре ВыполнитьЗапрос указать тип итогов "3"(и то и другое вместе), СКК() и СКД() Работают не правильно на мой вгляд. Данные все коректны.

    Если указать тип итогов "1"(остатки и обороты по счетам), сальдо показывает верно, но у меня не считает обороты по корсчетам.
    Можно все конечно сделать через 2 запроса, но хотелось бы следовать правельности(быстроте) работы обработки.

    У кого какие мнения на этот счет ?

Поделиться этой страницей