8.х Проблема со вставкой данных в поле автозаполняемого шаблона Документооборот 1.4.5.1

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем starter_ptz, 9 ноя 2014.

  1. TopicStarter Overlay
    starter_ptz
    Offline

    starter_ptz

    Регистрация:
    9 ноя 2014
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Очень прошу помощи.
    Создан автозаполняемый шаблон письма, в котором есть поля с адресатом и его адресом (т.е. кому отсылается). Этот шаблон должен отрабатываться через исходящие документы.
    При попытке сформировать в правилах автозаполнения заполнение этих полей данными обнаружилось, что в форме выбора реквизитов отсутствуют данные об адресате, хотя в карточке исходящего документа поле выбора наименования адресата присутствует.
    Попытался написать в правиле вот это для адреса корреспондента:
    Код:
    РезультатОбработки = УправлениеКонтактнойИнформацией.ПолучитьКонтактнуюИнформацияОбъекта(Файл.ВладелецФайла.Корреспондент , Справочники.ВидыКонтактнойИнформации.ЮридическийАдресКорреспондента);
    однако при проверке правила выскакивает "Поле объекта не обнаружено (Корреспондент)".
    В принципе, понятно, что не обнаружено, поскольку такого реквизита нет и в списке выбора при оформлении правила.
    Подскажите, пожалуйста, как правильно прописать эти реквизиты (наименование и адрес корреспондента), чтобы все нормально отрабатывалось при формировании исходящего документа (файла по шаблону).
    Заранее очень благодарен за советы и помощь!

Поделиться этой страницей