8.х ЗУП Проблема с выводом наименования организации в отчете ФСС

Тема в разделе ""1С:Зарплата и управление персоналом ЗУП"", создана пользователем Golemchik, 8 окт 2014.

  1. TopicStarter Overlay
    Golemchik
    Offline

    Golemchik Опытный в 1С

    Регистрация:
    15 апр 2013
    Сообщения:
    254
    Симпатии:
    1
    Баллы:
    29
    Здравствуйте. ЗУП последнего обновления. Проблема следующая, при формировании отчетов вместо полного наименования ИП, в отчет вставляется "простой" сотрудник (директор магазина).

    Вложения:

  2. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    В справочнике Организации как в полном наименовании указано?
    Golemchik нравится это.
  3. TopicStarter Overlay
    Golemchik
    Offline

    Golemchik Опытный в 1С

    Регистрация:
    15 апр 2013
    Сообщения:
    254
    Симпатии:
    1
    Баллы:
    29
    Везде то что нужно.

    Вложения:

  4. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.649
    Симпатии:
    948
    Баллы:
    204
    Ну там смотрите как они сделали
    Код:
    ПБОЮЛ = РегламентированнаяОтчетность.ЭтоПБОЮЛ(Организация);
    
    Код:
    Функция ЭтоПБОЮЛ(Организация) Экспорт
       
        ИдКонф = ИДКонфигурации();
       
        Если ИдКонф = "ББУ" ИЛИ ИдКонф = "БГУ" ИЛИ ИдКонф = "ЗБУ" ИЛИ ЭтоИностраннаяОрганизация(Организация) Тогда
            Возврат Ложь;
        Иначе
            Возврат (Организация.ЮрФизЛицо = Перечисления.ЮрФизЛицо.ФизЛицо);
        КонецЕсли;
       
    КонецФункции
    Код:
    ОргСведения = РегламентированнаяОтчетность.ПолучитьСведенияОбОрганизации(Организация, ДатаПодписи, Сведения);
    Код:
    ОргСведения.Свойство("ФИОРук", ФИОРук);
        ОргСведения.Свойство("ФИО", ФИО);
        ОргСведения.Свойство("ТелОрганизации", ТелОрганизации);
        ОргСведения.Свойство("ТелСлуж", ТелСлуж);
       
        Если ПБОЮЛ Тогда
            НаимЮлПол = ФИО;
            Адрес =  АдрПрописки;
            ТелОрганизации = ТелСлуж;
            ФИОРук = ФИО;
        КонецЕсли;
    Код:
    Если (мВПрограммеИзмененаОрганизация) Или (НЕ ЗначениеЗаполнено(ПТД_Титульный.Области.ОргНазв.Значение)) Тогда
            ПТД_Титульный.Области.ОргНазв.Значение = НаимЮЛПол;
        КонецЕсли;
    Т.е если ИП то тогда в НаимЮЛПол пишется ФИО
    Golemchik нравится это.
  5. TopicStarter Overlay
    Golemchik
    Offline

    Golemchik Опытный в 1С

    Регистрация:
    15 апр 2013
    Сообщения:
    254
    Симпатии:
    1
    Баллы:
    29
    Мда спасибо. в физ лице организации стояла эта Ольга Николаевна, хотя все данные были забиты под Елену Юрьевну. Видно диверсант у нас завелся. Спасибо за ответ.

Поделиться этой страницей