7.7 Проблема с Возвратной накладной

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем art_m, 10 дек 2008.

  1. TopicStarter Overlay
    art_m
    Offline

    art_m

    Регистрация:
    10 дек 2008
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Товарищи помогите, не могу понять почему не проводится документ, уходит в цикл и начинает отчет назад по годам, смотрел отладчиком, так и не смог выловить... :unsure:
    Конфигурация Бухгалтерия для Украины 7.70.209
    Код:
    глКомментарий("Корректировка себестоимости",2,Контекст);
    ВыбратьСтроки(); //корректировка себестоимости
    
    Пока ПолучитьСтроку()=1 Цикл
    //глПроводка(Контекст,,"УТ",СуммаСНДС,"Возврат товара",кво, 
    
    //            ,,, Контрагент,Заказ,ТМЦ, ,,"УТ");
    
    //
    
    
    Если Число(Тмц.НомерГазеты)<>0 Тогда
    Продолжить;
    КонецЕсли;
    ИтС=СоздатьОбъект("БухгалтерскиеИтоги");
    ИтС.ИспользоватьСубконто(ВидыСубконто.ТМЦ,ТМЦ); 
    ИтС.ВыполнитьЗапрос(НачМесяца(ДатаДок),ДатаДок,"281");
    ИтС.ВыбратьСубконто();
    ЦенаУчБезНДС=0;
    СуммаУчБезНДС=0; 
    
    Пока ИтС.ПолучитьСубконто()=1 Цикл
    
    Если  (ИтС.ДО(3)+ИтС.СНД(3))<>0 Тогда
    
    ЦенаУчБезНДС=(ИтС.СНД(1)+ИтС.ДО(1))/(ИтС.СНД(3)+ИтС.ДО(3));
    СуммаУчБезНДС = ЦенаУчБезНДС*Кво*Коэффициент;
    КонецЕсли;    
    
    КонецЦикла;
    
    
    м=1;
    
    Пока ЦенаУчБезНДС=0 Цикл                                                             
    ИтС=СоздатьОбъект("БухгалтерскиеИтоги");
    ИтС.ИспользоватьСубконто(ВидыСубконто.ТМЦ,ТМЦ); 
    ИтС.ВыполнитьЗапрос(НачМесяца(ДобавитьМесяц(ДатаДок,-м)),ДобавитьМесяц(ДатаДок,-м),"281");
    ИтС.ВыбратьСубконто(); 
    
    Пока ИтС.ПолучитьСубконто()=1 Цикл
    Если  (ИтС.ДО(3)+ИтС.СНД(3))<>0 Тогда
    ЦенаУчБезНДС=(ИтС.СНД(1)+ИтС.ДО(1))/(ИтС.СНД(3)+ИтС.ДО(3));
    СуммаУчБезНДС = ЦенаУчБезНДС*Кво*Коэффициент;
    КонецЕсли;    
    КонецЦикла;
    
    м=м+1;
    КонецЦикла;
    
    
    КонецЦикла;
    
    
  2. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    Используем тэги, указываем конфигурацию и читаем правила.
  3. TopicStarter Overlay
    art_m
    Offline

    art_m

    Регистрация:
    10 дек 2008
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Извините :unsure:
  4. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Не совсем понятен вопрос.
    А что хотите получить? К тому же здесь 3 цикла.
    Проблема может быть с третьим? Так надо предусмотреть условие выхода, и возможность формирования этого условия.
    В твоем случае обрати внимание на
    Код:
    ИтС.ДО(3)+ИтС.СНД(3))
    
    кажется здесь всегда будет ноль, если не делать перебор по валютам.
  5. TopicStarter Overlay
    art_m
    Offline

    art_m

    Регистрация:
    10 дек 2008
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Лично мне кажется, что скорее всего нет оборотов по выбранному ТМЦ за предыдущие периоды, Как сделать так, чтоб оно не искало до бесконечности, ну в крайнем случае пропускало это ТМЦ
    Документ работает только с одной валютой.
  6. Stado_adama
    Offline

    Stado_adama Модераторы Модератор

    Регистрация:
    27 ноя 2007
    Сообщения:
    1.086
    Симпатии:
    0
    Баллы:
    26
    ниче не понял... ни зачем все так сложно, ни вообще что это... но могу сказать одно: слишком много циклов полюбому... а еще и запрос в цикле...

Поделиться этой страницей