7.7 Проблема с регистром Остатков

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Evrey, 3 авг 2010.

  1. TopicStarter Overlay
    Evrey
    Offline

    Evrey

    Регистрация:
    3 авг 2010
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    Проблема в следующем:
    Есть Регистр.Остатки(Измерение-Наименование; Ресурс-Количество);

    Есть Отчет код отчета:
    Код:
    Процедура Сформировать()
    Рег=создатьОбъект("Регистр.Остатки");
    Спр=СоздатьОбъект("Справочник.Номенклатура");
    Спр.ВыбратьЭлементы();
    
    Пока Спр.ПолучитьЭлемент()=1 цикл
    Ном=Спр.Наименование;
    Кол=Рег.Остаток(Ном,"Количество");
    Сообщить(ном);
    Сообщить(Кол);
    КонецЦикла;
    
    Рег.ВыгрузитьИтоги(Таблица,,); 
    
    КонецПроцедуры
    
    
    Так вот, не работают методы регистров остатотков кроме метода СводныеОстатки без указания измерений, тогда выдает общее кол-во единиц товара.

    Т.е Приведенный Выше цикл выдает наименования товаров, а кол-во=0(нулевых остатков ни по одному товару нет). Хотя при этом в таблицу значений процедура выгружает нормальные остатки.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Для метода Остаток в отличии от СводныйОстаток заполнение ВСЕХ измерений ОБЯЗАТЕЛЬНО
  3. TopicStarter Overlay
    Evrey
    Offline

    Evrey

    Регистрация:
    3 авг 2010
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    Прости конечно, но какие реквизиты я еще не заполнил. Регистр Остатки у меня имеет одно измерение "Наименование- т.е это наименования товаров и один ресурс-"Количество".Подскажи пожалуйста, что нужно еще заполнить?
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Просто вы не озвучили конфигурацию - поэтому такой ответ.
    Проверьте итоги на актуальность и если необходимо - сделайте временный расчет. Думаю проблема в этом
  5. TopicStarter Overlay
    Evrey
    Offline

    Evrey

    Регистрация:
    3 авг 2010
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1

    Написал сначала вот так :

    Код:
    Процедура Сформировать()
    Спр=СоздатьОбъект("Справочник.Номенклатура");
    Рег=СоздатьОбъект("Регистр.ОстаткиТоваров");
    Рег.ВременныйРасчет();
    РассчитатьРегистрыПо(ТекущаяДата());
    Рег.ВыбратьИтоги(); 
    Пока Рег.ПолучитьИтог()=1 цикл
    Ном=Рег.товар;
    Кол=Рег.Остаток(Ном,"Количество");
    Сообщить(Ном);
    Сообщить(кол);
    
    КонецЦикла;
    
    КонецПроцедуры
    
    После нажатия кнопки вывел наименование и количество первого товара(Всего их три, остатки у всех не нулевые) на этом обработка цикла закончилась.
    в чем причина?
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    В данном случае нужно так:
    Код:
    Рег=СоздатьОбъект("Регистр.ОстаткиТоваров");
    Рег.ВременныйРасчет();	
    РассчитатьРегистрыПо(ТекущаяДата());	
    Рег.ВыбратьИтоги(); 	
    Пока Рег.ПолучитьИтог()=1 <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">цикл		</span>
    Сообщить(Рег.товар);		
    Сообщить(Рег.Количество);			
    КонецЦикла;
    
    
  7. TopicStarter Overlay
    Evrey
    Offline

    Evrey

    Регистрация:
    3 авг 2010
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    Спасибо. попробую обязательно. в каких случаях необходимо применять методы регистров остатков? приведи пожалуйста пример кода, когда их лучше использовать
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Не совсем понятен вопрос. Что значит "в каких случаях"? Там где вам нужен реальный остаток

Поделиться этой страницей