7.7 Проблема с регистрами

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем id3337668, 22 фев 2017.

  1. TopicStarter Overlay
    id3337668
    Offline

    id3337668

    Регистрация:
    25 фев 2016
    Сообщения:
    36
    Симпатии:
    0
    Баллы:
    1
    Привет Всем

    Возникла необходимость переделать один документ под свои нужды , я все переделал но при проведении документа вываливается такая ошибка:
    СуммаНаСкладе = Рег.Сырьё.Остаток(МестоХранения,Материал,,,,"Сумма");
    {Документ.РасходСырья.Модуль Документа(27)}: Слишком много параметров передано при вызове функции/процедуры объекта

    вот код модуля документа:

    Код:
    Процедура ОбработкаПроведения()
        Рег = СоздатьОбъект("Регистры");
        Рег.Сырьё.УстановитьЗначениеФильтра("МестоХранения",МестоХранения,1);
        Если Итогиактуальны() = 0 Тогда
            Рег.Сырьё.ВременныйРасчет(1);
            Рег.РассчитатьРегистрыНа(ТекущийДокумент());
        КонецЕсли;
        Би = СоздатьОбъект("БухгалтерскиеИтоги");
        Би.ИспользоватьСубконто(ВидыСубконто.МестаХранения,МестоХранения,2);
        Би.ИспользоватьСубконто(ВидыСубконто.Материалы);
    //    Би.ИспользоватьСубконто(ВидыСубконто.Заводы);
        Би.ВыполнитьЗапрос(,ТекущийДокумент(),"10.10",,,,,"СК");
        ВыбратьСтроки();
        Пока ПолучитьСтроку() = 1 Цикл
            //Если ДатаДок <= '28.02.2007' Тогда
            //    СуммаНаСкладе = 0;
            //    КоличествоНаСкладе = 0;
            //    Если Би.ПолучитьСубконто(2,,Материал) = 1 Тогда
            //        Если Би.ПолучитьСубконто(3,,Завод) = 1 Тогда
            //            СуммаНаскладе = Би.СКД(1);
            //            КоличествоНаСкладе = Би.СКД(3);
            //            КоличествоНаСкладеКип = КоличествоКип;
            //        КонецЕсли;
            //    КонецЕсли;
            //Иначе
                СуммаНаСкладе = Рег.Сырьё.Остаток(МестоХранения,Материал,,,,"Сумма");
                КоличествоНаСкладе = Рег.Сырьё.Остаток(МестоХранения,,,,,"Количество");
                КоличествоНаСкладеСыр = Рег.Сырьё.Остаток(МестоХранения,Материал,,,,"КоличествоСыр");
        //    КонецЕсли;
        //    Если (КоличествоНаСкладе < КоличествоВес) или (КоличествоНаСкладеКип < КоличествоКип) Тогда
        //       глОшибкаПроведения(Контекст,"На складе "+КоличествоНаСкладе+" "+Материал.ЕдиницаИзмерения+" ("+КоличествоНаСкладеКип+" кип) хлопковолокна из необходимых "+КоличествоВес+" "+Материал.ЕдиницаИзмерения+" ("+КоличествоКип+" кип).",НомерСтроки);
        //        СтатусВозврата(0); Возврат;
           Если КоличествоНаСкладе = КоличествоСыр Тогда
                Сумма = СуммаНаСкладе;
            Иначе
                Сумма = СуммаНаСкладе/КоличествоНаСкладе*КоличествоСыр;
            КонецЕсли;
            Операция.НоваяПроводка();
            Операция.СодержаниеПроводки = "Передано в производство";
            Операция.НомерЖурнала = "МТ";
            Операция.Дебет.Счет = Подразделение.СчетПодразделения;
            Операция.Дебет.Субконто(1,глМатериальныеЗатраты);
            Операция.Дебет.Субконто(2,Подразделение);
            Операция.Кредит.Счет = Материал.Субсчет10;
            Операция.Кредит.Субконто(1,Материал);
            Операция.Кредит.Субконто(2,МестоХранения);
            Операция.Кредит.Субконто(3,Завод);
            Операция.Количество = КоличествоВес;
            Операция.Сумма = Сумма;
        //    Если ДатаДок > '28.02.2007' Тогда
                Регистр.Сырьё.МестоХранения = МестоХранения;
                Регистр.Сырьё.Материал = Материал;
        //        Регистр.Сырьё.Завод = Завод;
        //        Регистр.Сырьё.Сорт = Сорт;
        //        Регистр.Сырьё.Класс = Класс;
        //        Регистр.Сырьё.Тип = Тип;
                Регистр.Сырьё.Количество = КоличествоСыр;
    //            Регистр.Сырьё.КоличествоКип = КоличествоКип;
                Регистр.Сырьё.Сумма = Сумма;
                Регистр.Сырьё.ДвижениеРасходВыполнить();
             
                Регистр.НезавершенноеПроизводство.Подразделение = Подразделение;
                Регистр.НезавершенноеПроизводство.Материал = глМиксинг;
        //        Регистр.НезавершенноеПроизводство.Сорт = 0;
        //        Регистр.НезавершенноеПроизводство.Класс = "";
        //        Регистр.НезавершенноеПроизводство.Тип = 0;
                Регистр.НезавершенноеПроизводство.Продукт = ПолучитьПустоеЗначение("Справочник.Номенклатура");
        //        Регистр.НезавершенноеПроизводство.Количество = КоличествоВес;
                Регистр.НезавершенноеПроизводство.КоличествоСыр = КоличествоСыр;
                Регистр.НезавершенноеПроизводство.Сумма = Сумма;
                Регистр.НезавершенноеПроизводство.ДвижениеПриходВыполнить();
        //    Иначе
        //        Регистр.НезавершенноеПроизводство.Подразделение = Подразделение;
        //        Регистр.НезавершенноеПроизводство.Материал = глМиксинг;
        //        Регистр.НезавершенноеПроизводство.Сорт = 0;
        //        Регистр.НезавершенноеПроизводство.Класс = "";
        //        Регистр.НезавершенноеПроизводство.Тип = 0;
        //        Регистр.НезавершенноеПроизводство.Продукт = ПолучитьПустоеЗначение("Справочник.Номенклатура");
        //        Регистр.НезавершенноеПроизводство.Количество = КоличествоВес;
        //        Регистр.НезавершенноеПроизводство.КоличествоКип = КоличествоКип;
        //        Регистр.НезавершенноеПроизводство.Сумма = Сумма;
        //        Регистр.НезавершенноеПроизводство.ДвижениеПриходВыполнить();
        //    КонецЕсли;
        КонецЦикла;
        Операция.Записать();
        ЧекЛист(Операция);
    
    КонецПроцедуры
    опыта в программировании 1 с 7 у меня пока очень мало, подскажите пожалуйста где мне копать?
    понимаю что что-то с регистрами я напортачил но не пойму где именно

    С Уважением Дамир
    Последнее редактирование модератором: 22 фев 2017
  2. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.253
    Симпатии:
    144
    Баллы:
    104
    скрин регистра СЫРЬЕ в студию с измерениями (каждая запятая - измерение регистра)
  3. TopicStarter Overlay
    id3337668
    Offline

    id3337668

    Регистрация:
    25 фев 2016
    Сообщения:
    36
    Симпатии:
    0
    Баллы:
    1
    все нашел, запятая была лишней, спасибо всем

Поделиться этой страницей