7.7 Проблема с рашифровкой ячейки в отчете

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем phcode, 25 янв 2011.

  1. TopicStarter Overlay
    phcode
    Offline

    phcode Опытный в 1С

    Регистрация:
    13 апр 2009
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    Подскажите пожалуйста как можно сделать, чтобы в отчете который формирует список документов, при нажатие на строку документа открывался для просмотра этот документ. Учитывая то, что один раз расшифровкой я уже пользовался для вывода этого самого списка документов...

    Часть кода отвечающая за "первый уровень" расшифровки:
    Код:
    ....
    Процедура ДокПокуп(ТочПокуп)
    
    
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса=
    "//{{Запрос(ПродТовар)
    |Период с ВыбНачПериода по ВыбКонПериода;
    //|Клиент = Документ.РасходнаяНакладная.Контрагент;
    |ТекущДок = Документ.РасходнаяНакладная.ТекущийДокумент, Документ.ПриходныйОрдер.ТекущийДокумент;
    |ТочкаП = Документ.РасходнаяНакладная.ТочкаПокупателя, Документ.ПриходныйОрдер.ТочкаПокупателя;
    |Всего222 = Документ.РасходнаяНакладная.Всего, Документ.ПриходныйОрдер.Сумма;
    |Номер = Документ.РасходнаяНакладная.НомерДок, Документ.ПриходныйОрдер.НомерДок;
    |ДатаД = Документ.РасходнаяНакладная.ДатаДок, Документ.ПриходныйОрдер.ДатаДок;
    |Функция ВсегоСумма222 = Сумма(Всего222);
    |Группировка ТекущДок;
    |Условие(ТочкаП = ТочПокуп);
    |"//}}Запрос;
    
    Если Запрос.Выполнить(ТекстЗапроса)=0 Тогда
    Возврат;
    КонецЕсли;
    
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
    Таб.ВывестиСекцию("Заголовок");
    Пока Запрос.Группировка(1) = 1 Цикл
    Таб.ВывестиСекцию("Документ");
    КонецЦикла;
    
    Таб.ТолькоПросмотр(1);
    Таб.Опции(0,4,0,0);
    Таб.Показать("Список документов.. ","");
    КонецПроцедуры
    
    
    
    
    Процедура ОбработкаЯчейкиТаблицы(ЗначЯч, ФлагСтандартнойОбработки)
    Если ТипЗначения(ЗначЯч) = 2 Тогда
    ФлагСтандартнойОбработки=1;
    Возврат;
    КонецЕсли;
    ДокПокуп(ЗначЯч);
    КонецПроцедуры
    
    Результат:
    [​IMG]
  2. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    что у тебя в поле расшифровка написано
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    В свойствах ячеки в расшифровке добавьте Запрос.ТекущДок
    таблица д.б. в режиме просмотра
  4. TopicStarter Overlay
    phcode
    Offline

    phcode Опытный в 1С

    Регистрация:
    13 апр 2009
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    в первой расшифровки: Запрос.ТочкаПокупателя

    Не выходит, вызывается отчет, но тока с пустым списком документов. (который скрин в первом посту)
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Выложите сам отчет
  6. TopicStarter Overlay
    phcode
    Offline

    phcode Опытный в 1С

    Регистрация:
    13 апр 2009
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    В прикрепленном файле - отчет.

    Вложения:

    • Отчет.zip
      Размер файла:
      12,4 КБ
      Просмотров:
      34
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    В расшифровке ячейки прописать Запрос.ТочкаПокупателя
  8. TopicStarter Overlay
    phcode
    Offline

    phcode Опытный в 1С

    Регистрация:
    13 апр 2009
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    Ваш совет, не помог.Сначала формируется таблица "Сформировать", затем таблица "Таблица" где список доков. Если и второй таблице поставить Запрос.ТочкаПокупателя, то происходит зацикливание (

Поделиться этой страницей