7.7 Проблема с привязкой кнопки к процедуре

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем frolov88, 7 фев 2013.

  1. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    Почему ПолучитьЭлементы? У меня в коде написано ПолучитьЭлемент, да и синтакс-помощник у вас есть.
  2. TopicStarter Overlay
    frolov88
    Offline

    frolov88

    Регистрация:
    7 фев 2013
    Сообщения:
    30
    Симпатии:
    0
    Баллы:
    1
    Код:
    Процедура Печать()
    
    Спр=СоздатьОбъект("Справочник.Номенклатура"); //создана переменная для ссылки на объект справочник номенклантура
    Таб=СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Каталог");
    Таб.ВывестиСекцию("Шапка");
    Если Спр.ВыбратьЭлемент()=1 Тогда // Справочник позиционирован
    Пока Спр.ПолучитьЭлемент()=1 Цикл
    Таб.ВывестиСекцию("Строка");
    КонецЦикла;
    КонецЕсли;
    Таб.ТолькоПросмотр(1);
    Таб.Опции(0,0,0,0);
    Таб.Показать("КаталогТоваров");
    КонецПроцедуры
    И вот такая ошибка=(

    Если Спр.ВыбратьЭлемент()=1 Тогда // Справочник позиционирован
    {Справочник.Номенклатура.ФормаСписка.ФормаСписка.Модуль(7)}: Поле агрегатного объекта не обнаружено (ВыбратьЭлемент)
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    вы ОЧЕНЬ не внимательны.
    Попробуйте хоть через буфер обмена скопировать.......
    [CODE1C]
    Спр.ВыбратьЭлементы() ;
    Пока Спр.ПолучитьЭлемент() = 1 Цикл
    // ...
    КонецЦикла;

    [/CODE1C]

    Выбираем элементЫ, а получаем элеменТ
  4. TopicStarter Overlay
    frolov88
    Offline

    frolov88

    Регистрация:
    7 фев 2013
    Сообщения:
    30
    Симпатии:
    0
    Баллы:
    1
    ВСЕМ СПАСИБО=) Заработало=) УРРРААААА! :yahoo:
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    не за что. немного внимательности вам и дело пойдет

Поделиться этой страницей