7.7 Проблема с печатной формой документа.

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем Lusenok1985@mail.ru, 24 июл 2009.

  1. TopicStarter Overlay
    Lusenok1985@mail.ru
    Offline

    Lusenok1985@mail.ru

    Регистрация:
    6 июл 2009
    Сообщения:
    34
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте!
    У меня такая проблема: Есть форма документа в которой есть кнопка печать. Открывается печатная форма , подскажите где я могу ее изменить
    Например: там написано Зам.гер.дир., а мне нужно Полностью: Заместитель генерального директора.
    Не могу нигде в конфигураторе ее найти! Может быть кто нибудь сталкивался с этой проблемой.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Правильно сформулированный вопрос - это половина ответа.

    В последнее время на форму отмечается резкое снижение телепатических способносей участников (лето же)

    Какая конфигурация, Какой документ ?????
  3. TopicStarter Overlay
    Lusenok1985@mail.ru
    Offline

    Lusenok1985@mail.ru

    Регистрация:
    6 июл 2009
    Сообщения:
    34
    Симпатии:
    0
    Баллы:
    1
    Конфигурация: Бухгалтерский учет редакции 4.5, Документ: Учет материалов, отгрузка материалов на сторону.
    Процедура по кнопке пучать такая:
    Код:
    // ПоКнопкеПечать()
    // 
    // Вызывается из формул элементов диалога:
    //  Кнопка "кнПечать".
    //
    // Описание:
    //  Определяется соответствующая печатная форма.
    // 	
    Процедура ПоКнопкеПечать(СразуНаПринтер = 0,КолЭкз = 1)
    
    Если  ПустоеЗначение(НомерТекущейФормы) = 1  Тогда
    НомерТекущейФормы = 1;
    Форма.кнПечать.Заголовок(ТаблицаПечФорм.ПолучитьЗначение(НомерТекущейФормы, "Кнопка"));
    КонецЕсли;
    
    Если НомерТекущейФормы = 1  Тогда
    Печать();
    
    Иначе
    Параметры = СоздатьОбъект("СписокЗначений");
    Параметры.ДобавитьЗначение(Контекст, "Контекст");
    Параметры.ДобавитьЗначение(СразуНаПринтер, "Устройство");
    Параметры.ДобавитьЗначение(КолЭкз, "КоличествоКопий");
    
    ОткрытьФорму("Отчет", Параметры, глКаталогПечФорм+ТаблицаПечФорм.ПолучитьЗначение(НомерТекущейФормы,"Файл"));
    КонецЕсли;
    
    КонецПроцедуры // ПоКнопкеПечать()
    
  4. Balabass
    Offline

    Balabass

    Регистрация:
    22 июл 2009
    Сообщения:
    32
    Симпатии:
    0
    Баллы:
    1
    Так это не печатная форма...а скорее всего должность такая заведена в справочнике должностей - через точки..проверте
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Если вы используете внешнюю форму (ч/з регистрация внешних печатных форм) - ищите в КаталогИБ\ExtForms\PrnForms.

    Штатный шаблон формы М-15 хранится в общих таблицах самой конфигурации
  6. TopicStarter Overlay
    Lusenok1985@mail.ru
    Offline

    Lusenok1985@mail.ru

    Регистрация:
    6 июл 2009
    Сообщения:
    34
    Симпатии:
    0
    Баллы:
    1
    Расскажите пожалуйста по подробнее про штатный шаблон М-15, где конкретно он храниться? В этой папке есть какието файлы, с помощью чего их открыть?
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Здесь хранятся штатные шаблоны

    А здесь внешние (имя файла смотри в таблице)

    Вложения:

  8. TopicStarter Overlay
    Lusenok1985@mail.ru
    Offline

    Lusenok1985@mail.ru

    Регистрация:
    6 июл 2009
    Сообщения:
    34
    Симпатии:
    0
    Баллы:
    1
    Спасибо вам большое я нашла! Вы очень мне помогли! Я просто в 1С еще плохо знаю! Еще раз огромное спасибо.

Поделиться этой страницей