7.7 Проблема с отчетом

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем algrib, 16 авг 2006.

  1. TopicStarter Overlay
    algrib
    Offline

    algrib

    Регистрация:
    16 авг 2006
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    В отчете нужно в справочнике товаров добавить выбор единиц измерения. Помогите, пожалуйста!
  2. рамиль
    Offline

    рамиль Опытный в 1С

    Регистрация:
    12 мар 2006
    Сообщения:
    595
    Симпатии:
    0
    Баллы:
    26
    Вопрос разверните и будет вам щастье!

    P.S:Лелик , скажи человеку зачем усы збрил? :unsure:
  3. TopicStarter Overlay
    algrib
    Offline

    algrib

    Регистрация:
    16 авг 2006
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Усы ни когда не носил. :unsure:
    Здесь надочто он выбирал товар с единицей измерения кг. или добавить форму выбора.

    Код:
    <pre><FONT COLOR="blue"><FONT FACE="Courier">
    [color="green"]//*******************************************[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ОбработкаПодбора[color="red"]([/color]ЗначПод[color="red"])[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> ЗначПод[color="red"].[/color]Вид[color="red"]([/color][color="red"])[/color][color="red"]=[/color][color="black"]"Товары"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ВыбТовары[color="red"].[/color]ДобавитьЗначение[color="red"]([/color]ЗначПод[color="red"])[/color][color="red"];[/color]
    ВыбТовары[color="red"].[/color]ТекущаяСтрока[color="red"]([/color]ВыбТовары[color="red"].[/color]РазмерСписка[color="red"]([/color][color="red"])[/color][color="red"])[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> ВыбТовары[color="red"].[/color]РазмерСписка[color="red"]([/color][color="red"])[/color][color="red"]=[/color][color="black"]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Форма[color="red"].[/color]Удалить[color="red"].[/color]Доступность[color="red"]([/color][color="black"]0[/color][color="red"])[/color][color="red"];[/color]
    Форма[color="red"].[/color]УдалитьВсе[color="red"].[/color]Доступность[color="red"]([/color][color="black"]0[/color][color="red"])[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>
    Форма[color="red"].[/color]Удалить[color="red"].[/color]Доступность[color="red"]([/color][color="black"]1[/color][color="red"])[/color][color="red"];[/color]
    Форма[color="red"].[/color]УдалитьВсе[color="red"].[/color]Доступность[color="red"]([/color][color="black"]1[/color][color="red"])[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">ИначеЕсли</span> ЗначПод[color="red"].[/color]Вид[color="red"]([/color][color="red"])[/color][color="red"]=[/color][color="black"]"Клиенты"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СписокКлиентов[color="red"].[/color]ДобавитьЗначение[color="red"]([/color]ЗначПод[color="red"])[/color][color="red"];[/color]
    СписокКлиентов[color="red"].[/color]ТекущаяСтрока[color="red"]([/color]СписокКлиентов[color="red"].[/color]РазмерСписка[color="red"]([/color][color="red"])[/color][color="red"])[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> СписокКлиентов[color="red"].[/color]РазмерСписка[color="red"]([/color][color="red"])[/color][color="red"]=[/color][color="black"]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Форма[color="red"].[/color]УдалитьКл[color="red"].[/color]Доступность[color="red"]([/color][color="black"]0[/color][color="red"])[/color][color="red"];[/color]
    Форма[color="red"].[/color]УдалитьВсеКл[color="red"].[/color]Доступность[color="red"]([/color][color="black"]0[/color][color="red"])[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>
    Форма[color="red"].[/color]УдалитьКл[color="red"].[/color]Доступность[color="red"]([/color][color="black"]1[/color][color="red"])[/color][color="red"];[/color]
    Форма[color="red"].[/color]УдалитьВсеКл[color="red"].[/color]Доступность[color="red"]([/color][color="black"]1[/color][color="red"])[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">ИначеЕсли</span> ЗначПод[color="red"].[/color]Вид[color="red"]([/color][color="red"])[/color][color="red"]=[/color][color="black"]"ЗначенияСвойств"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СписокСвойств[color="red"].[/color]ДобавитьЗначение[color="red"]([/color]ЗначПод[color="red"],[/color]СокрЛП[color="red"]([/color]ЗначПод[color="red"].[/color]Наименование[color="red"])[/color][color="red"]+[/color][color="black"]" ("[/color][color="red"]+[/color]СокрЛП[color="red"]([/color]ЗначПод[color="red"].[/color]Владелец[color="red"].[/color]Наименование[color="red"])[/color][color="red"]+[/color][color="black"]")"[/color][color="red"])[/color][color="red"];[/color]
    СписокСвойств[color="red"].[/color]ТекущаяСтрока[color="red"]([/color]СписокСвойств[color="red"].[/color]РазмерСписка[color="red"]([/color][color="red"])[/color][color="red"])[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> СписокСвойств[color="red"].[/color]РазмерСписка[color="red"]([/color][color="red"])[/color][color="red"]>[/color][color="black"]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Форма[color="red"].[/color]УдалитьСв[color="red"].[/color]Доступность[color="red"]([/color][color="black"]1[/color][color="red"])[/color][color="red"];[/color]
    Форма[color="red"].[/color]УдалитьВсеСв[color="red"].[/color]Доступность[color="red"]([/color][color="black"]1[/color][color="red"])[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>    
    Форма[color="red"].[/color]УдалитьСв[color="red"].[/color]Доступность[color="red"]([/color][color="black"]0[/color][color="red"])[/color][color="red"];[/color]
    Форма[color="red"].[/color]УдалитьВсеСв[color="red"].[/color]Доступность[color="red"]([/color][color="black"]0[/color][color="red"])[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПриВыбореЗакладки[color="red"]([/color] НомерЗакладки[color="red"],[/color] ЗначениеЗакладки [color="red"])[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> ЗначениеЗакладки [color="red"]=[/color] [color="black"]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ТекЗакладка[color="red"]=[/color][color="black"]1[/color][color="red"];[/color]
    Форма[color="red"].[/color]ИспользоватьСлой[color="red"]([/color][color="black"]"Основной"[/color][color="red"],[/color] [color="black"]2[/color][color="red"])[/color][color="red"];[/color]
    Форма[color="red"].[/color]ИспользоватьСлой[color="red"]([/color][color="black"]"Управление"[/color][color="red"],[/color] [color="black"]1[/color][color="red"])[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">ИначеЕсли</span> ЗначениеЗакладки[color="red"]=[/color][color="black"]2[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Форма[color="red"].[/color]ИспользоватьСлой[color="red"]([/color][color="black"]"Свойства"[/color][color="red"],[/color][color="black"]2[/color][color="red"])[/color][color="red"];[/color]
    Форма[color="red"].[/color]ИспользоватьСлой[color="red"]([/color][color="black"]"Управление"[/color][color="red"],[/color] [color="black"]1[/color][color="red"])[/color][color="red"];[/color]   
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПриОткрытии[color="red"]([/color][color="red"])[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> ВыбТовары[color="red"].[/color]РазмерСписка[color="red"]([/color][color="red"])[/color][color="red"]=[/color][color="black"]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Форма[color="red"].[/color]Удалить[color="red"].[/color]Доступность[color="red"]([/color][color="black"]0[/color][color="red"])[/color][color="red"];[/color]
    Форма[color="red"].[/color]УдалитьВсе[color="red"].[/color]Доступность[color="red"]([/color][color="black"]0[/color][color="red"])[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>
    Форма[color="red"].[/color]Удалить[color="red"].[/color]Доступность[color="red"]([/color][color="black"]1[/color][color="red"])[/color][color="red"];[/color]
    Форма[color="red"].[/color]УдалитьВсе[color="red"].[/color]Доступность[color="red"]([/color][color="black"]1[/color][color="red"])[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> СписокКлиентов[color="red"].[/color]РазмерСписка[color="red"]([/color][color="red"])[/color][color="red"]=[/color][color="black"]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Форма[color="red"].[/color]УдалитьКл[color="red"].[/color]Доступность[color="red"]([/color][color="black"]0[/color][color="red"])[/color][color="red"];[/color]
    Форма[color="red"].[/color]УдалитьВсеКл[color="red"].[/color]Доступность[color="red"]([/color][color="black"]0[/color][color="red"])[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>
    Форма[color="red"].[/color]УдалитьКл[color="red"].[/color]Доступность[color="red"]([/color][color="black"]1[/color][color="red"])[/color][color="red"];[/color]
    Форма[color="red"].[/color]УдалитьВсеКл[color="red"].[/color]Доступность[color="red"]([/color][color="black"]1[/color][color="red"])[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> СписокСвойств[color="red"].[/color]РазмерСписка[color="red"]([/color][color="red"])[/color][color="red"]=[/color][color="black"]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Форма[color="red"].[/color]УдалитьСв[color="red"].[/color]Доступность[color="red"]([/color][color="black"]0[/color][color="red"])[/color][color="red"];[/color]
    Форма[color="red"].[/color]УдалитьВсеСв[color="red"].[/color]Доступность[color="red"]([/color][color="black"]0[/color][color="red"])[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>
    Форма[color="red"].[/color]УдалитьСв[color="red"].[/color]Доступность[color="red"]([/color][color="black"]1[/color][color="red"])[/color][color="red"];[/color]
    Форма[color="red"].[/color]УдалитьВсеСв[color="red"].[/color]Доступность[color="red"]([/color][color="black"]1[/color][color="red"])[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color="red"];[/color]
    Форма[color="red"].[/color]Закладки[color="red"].[/color]ДобавитьЗначение[color="red"]([/color][color="black"]1[/color][color="red"],[/color][color="black"]"Основной"[/color][color="red"])[/color][color="red"];[/color]
    Форма[color="red"].[/color]Закладки[color="red"].[/color]ДобавитьЗначение[color="red"]([/color][color="black"]2[/color][color="red"],[/color][color="black"]"Свойства товаров"[/color][color="red"])[/color][color="red"];[/color]  
    Форма[color="red"].[/color]ИспользоватьСлой[color="red"]([/color][color="black"]"Основной"[/color][color="red"],[/color] [color="black"]2[/color][color="red"])[/color][color="red"];[/color]
    Форма[color="red"].[/color]ИспользоватьСлой[color="red"]([/color][color="black"]"Управление"[/color][color="red"],[/color] [color="black"]1[/color][color="red"])[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ОбработкаВнешнегоСобытия[color="red"]([/color]Источник[color="red"],[/color]Событие[color="red"],[/color]Данные[color="red"])[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> [color="red"]([/color] Источник [color="red"]=[/color] [color="black"]"BarCodeScaner"[/color] [color="red"])[/color]    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и</span> [color="red"]([/color] Событие [color="red"]=[/color] [color="black"]"BarCodeValue"[/color] [color="red"])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ОбработкаСканераОтчет[color="red"]([/color]Данные[color="red"],[/color] Контекст[color="red"])[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> Сформировать[color="red"]([/color]Вид[color="red"])[/color]
    ПоправкаИнтервала[color="red"]([/color]ДатаНач[color="red"],[/color]ДатаКон[color="red"])[/color][color="red"];[/color]
    ПроверкаАктуальностиОтчета[color="red"]([/color]ДатаНач[color="red"],[/color]ДатаКон[color="red"])[/color][color="red"];[/color]
    ОптимизироватьСписок[color="red"]([/color]ВыбТовары[color="red"])[/color][color="red"];[/color]
    ОптимизироватьСписок[color="red"]([/color]СписокКлиентов[color="red"])[/color][color="red"];[/color]
    Запр[color="red"]=[/color]СоздатьОбъект[color="red"]([/color][color="black"]"Запрос"[/color][color="red"])[/color][color="red"];[/color]
    ЧислоСтрок[color="red"]=[/color][color="black"]0[/color][color="red"];[/color]
    ТекстЗапр[color="red"]=[/color][color="black"]"[/color]
    [color="black"]    |Период с ДатаНач по ДатаКон;[/color]
    [color="black"]    |Фирма=Регистр.ОстаткиТоваров.Фирма;[/color]
    [color="black"]    |КЛИЕНТ=Регистр.ОстаткиТоваров.Партия.Клиент;[/color]
    [color="black"]    |ТОВАР=Регистр.ОстаткиТоваров.Товар;[/color]
    [color="black"]    |ДОКУМ=Регистр.ОстаткиТоваров.Партия.ПрихДокумент;[/color]
    [color="black"]    |ДОК=Регистр.ОстаткиТоваров.ТекущийДокумент;[/color]
    [color="black"]    |КодОперации=Регистр.ОстаткиТоваров.КодОперации;[/color]
    [color="black"]    |КОЛИЧЕСТВО=Регистр.ОстаткиТоваров.Количество;[/color]
    [color="black"]    |СТОИМОСТЬ=Регистр.ОстаткиТоваров.СуммаПрих;[/color]
    [color="black"]    |Функция НАЧКОЛ=НачОст(КОЛИЧЕСТВО);[/color]
    [color="black"]    |Функция НАЧСТОИМ=НачОст(СТОИМОСТЬ);[/color]
    [color="black"]    |Функция КОЛ=КонОст(КОЛИЧЕСТВО);[/color]
    [color="black"]    |Функция СТОИМ=КонОст(СТОИМОСТЬ);[/color]
    [color="black"]    |Функция ПРИХКОЛ=Приход(КОЛИЧЕСТВО);[/color]
    [color="black"]    |Функция ПРИХСТОИМ=Приход(СТОИМОСТЬ);[/color]
    [color="black"]    |Функция РАСХКОЛ=Расход(КОЛИЧЕСТВО);[/color]
    [color="black"]    |Функция РАСХСТОИМ=Расход(СТОИМОСТЬ);[/color]
    [color="black"]    |Функция ПРОДКОЛ=Расход(КОЛИЧЕСТВО) Когда ((КодОперации="[/color][color="black"]"О"[/color][color="black"]") ИЛИ (КодОперации="[/color][color="black"]"Р"[/color][color="black"]") ИЛИ (КодОперации="[/color][color="black"]"З"[/color][color="black"]"));[/color]
    [color="black"]    |Функция ПРОДСТОИМ=Расход(СТОИМОСТЬ) Когда ((КодОперации="[/color][color="black"]"О"[/color][color="black"]") ИЛИ (КодОперации="[/color][color="black"]"Р"[/color][color="black"]") ИЛИ (КодОперации="[/color][color="black"]"З"[/color][color="black"]"));[/color]
    [color="black"]    |Функция ВОЗВРКОЛ=Расход(КОЛИЧЕСТВО) Когда ((КодОперации="[/color][color="black"]"Ю"[/color][color="black"]") ИЛИ (КодОперации="[/color][color="black"]"Э"[/color][color="black"]"));[/color]
    [color="black"]    |Функция ВОЗВРСТОИМ=Расход(СТОИМОСТЬ) Когда ((КодОперации="[/color][color="black"]"Ю"[/color][color="black"]") ИЛИ (КодОперации="[/color][color="black"]"Э"[/color][color="black"]"));[/color]
    [color="black"]    |Условие ((КодОперации<>"[/color][color="black"]"А"[/color][color="black"]") И (КодОперации<>"[/color][color="black"]"П"[/color][color="black"]"));[/color]
    [color="black"]    |Условие (Товар в ВыбТовары);[/color]
    [color="black"]    |Группировка Фирма;"[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> ВидОтчета[color="red"]=[/color]Перечисление[color="red"].[/color]ВидыОтчета[color="red"].[/color]ПоКлиентам <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ТекстЗапр[color="red"]=[/color]ТекстЗапр[color="red"]+[/color][color="black"]"[/color]
    [color="black"]        |Группировка КЛИЕНТ без групп;[/color]
    [color="black"]        |Группировка ТОВАР без групп;[/color]
    [color="black"]        |Группировка ДОКУМ;[/color]
    [color="black"]        |Группировка ДОК;"[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>
    ТекстЗапр[color="red"]=[/color]ТекстЗапр[color="red"]+[/color][color="black"]"[/color]
    [color="black"]        |Группировка ТОВАР без групп;[/color]
    [color="black"]        |Группировка КЛИЕНТ без групп;[/color]
    [color="black"]        |Группировка ДОКУМ;[/color]
    [color="black"]        |Группировка ДОК;"[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color="red"];[/color]
    [color="green"]//Сформируем условия на товары[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> СписокСвойств[color="red"].[/color]РазмерСписка[color="red"]([/color][color="red"])[/color][color="red"]>[/color][color="black"]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ИтогСписокТоваров[color="red"]=[/color]СоздатьОбъект[color="red"]([/color][color="black"]"СписокЗначений"[/color][color="red"])[/color][color="red"];[/color]
    ИтогСписокТоваров[color="red"].[/color]УдалитьВсе[color="red"]([/color][color="red"])[/color][color="red"];[/color]
    ФильтрПоСвойствамТоваров[color="red"]([/color]Контекст[color="red"],[/color]ИтогСписокТоваров[color="red"])[/color][color="red"];[/color] 
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> УсловиеСвойств[color="red"].[/color]ТекущаяСтрока[color="red"]([/color][color="red"])[/color][color="red"]=[/color][color="black"]2[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ТекстЗапр[color="red"]=[/color]ТекстЗапр[color="red"]+[/color][color="black"]"[/color]
    [color="black"]                |Условие (НЕ(Товар в ИтогСписокТоваров));"[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> ИтогСписокТоваров[color="red"].[/color]РазмерСписка[color="red"]([/color][color="red"])[/color][color="red"]=[/color][color="black"]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/предупреждение')">Предупреждение</span>[color="red"]([/color][color="black"]"Нет товаров, удовлетворяющих заданным свойствам!!!"[/color][color="red"])[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">Возврат</span>[color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color="red"];[/color]
    ТекстЗапр[color="red"]=[/color]ТекстЗапр[color="red"]+[/color][color="black"]"[/color]
    [color="black"]                |Условие (Товар в ИтогСписокТоваров);"[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color="red"];[/color]                                     
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> СписокКлиентов[color="red"].[/color]РазмерСписка[color="red"]([/color][color="red"])[/color][color="red"]>[/color][color="black"]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ТекстЗапр[color="red"]=[/color]ТекстЗапр[color="red"]+[/color][color="black"]"Условие (Клиент в СписокКлиентов);"[/color][color="red"];[/color]
    Заг[color="red"]=[/color]Заг[color="red"]+[/color][color="black"]"По клиенту(ам): "[/color][color="red"]+[/color]СписокКлиентов[color="red"].[/color]ВСтрокуСРазделителями[color="red"]([/color][color="red"])[/color][color="red"]+[/color][color="black"]"."[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>
    Заг[color="red"]=[/color][color="black"]"По всем клиентам."[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> ВыбТовары[color="red"].[/color]РазмерСписка[color="red"]([/color][color="red"])[/color][color="red"]=[/color][color="black"]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Заг[color="red"]=[/color]Заг[color="red"]+[/color][color="black"]" По всем товарам. "[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>
    Заг[color="red"]=[/color]Заг[color="red"]+[/color][color="black"]" По товарам из списка: "[/color][color="red"]+[/color]ВыбТовары[color="red"].[/color]ВСтрокуСРазделителями[color="red"]([/color][color="red"])[/color][color="red"]+[/color][color="black"]". "[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> ВыбДок[color="red"].[/color]Выбран[color="red"]([/color][color="red"])[/color][color="red"]>[/color][color="black"]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ТекстЗапр [color="red"]=[/color] ТекстЗапр [color="red"]+[/color] [color="black"]"Условие (ДОКУМ=ВыбДок);"[/color][color="red"];[/color]
    Заг[color="red"]=[/color]Заг[color="red"]+[/color][color="black"]" По документу "[/color][color="red"]+[/color]ВыбДок[color="red"]+[/color][color="black"]"."[/color][color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color="red"];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> ВыбФирма[color="red"].[/color]Выбран[color="red"]([/color][color="red"])[/color][color="red"]>[/color][color="black"]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ТекстЗапр [color="red"]=[/color] ТекстЗапр [color="red"]+[/color] [color="black"]"Условие (Фирма=ВыбФирма);"<!--colorc--></span><!

Поделиться этой страницей