7.7 Проблема с отчетом

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем serdel, 7 апр 2010.

  1. TopicStarter Overlay
    serdel
    Offline

    serdel

    Регистрация:
    29 янв 2010
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Помогите пожалуйста! Ошибка: Если ((Тов.Виды.Код="3") или (Тов.Виды.Код="4")) и (Тов.ЗаимствованИз<>"") Тогда //4 или (Тов.Виды.Код="4")
    {E:\1C\БАЗА ТЕХОТДЕЛА\МАТВЕДОМОСТЬ\EXTFORMS1\СОРТИРОВКАДЛЯСНАБЖЕНИЯЗА.ERT(201)}: Значение не представляет агрегатный объект (Виды)


    Код:
    Процедура МатСорт1(Знач Мат,Знач Коэф=1) 
    Вх=СоздатьОбъект("Справочник.Вхождения");
    Спр=СоздатьОбъект("Справочник.МатВедомость");
    Если (Мат.Виды.Код="3")   или (Мат.Виды.Код="4") Тогда 
    Если Мат.ЗаимствованИз.Наименование<>"" Тогда
    Гр=Мат.ЗаимствованИз;
    КонецЕсли;
    Иначе
    Гр=Мат;
    КонецЕсли;
    Пока Гр.Уровень()>1 Цикл
    Гр=Гр.Родитель;
    КонецЦикла;
    Спр.ИспользоватьРодителя(Гр);
    Спр.ПорядокРеквизита("Материал");
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()=1 Цикл
    Тов=Спр.ТекущийЭлемент();
    Если СписокЭлементовМФ.РазмерСписка()>0 тогда //1
    // Сообщить("1");
    Если СписокЭлементовМФ.НайтиЗначение(Тов.материал)<>0 тогда//2  
    //Сообщить("2");
    
    Колво1=Коэф*ПоискПоДереву(Тов,Мат);
    Колво2=Колво1+МатВедКол.Получить(Тов.ПолныйКод());
    Если (Колво1>0) и (Тов.Материал.Наименование<>"") Тогда//3
    Если ((Тов.Виды.Код="3") или (Тов.Виды.Код="4")) и (Тов.ЗаимствованИз.Наименование<>"") Тогда //4 или (Тов.Виды.Код="4") 
    МатВед.Установить(Тов.ЗаимствованИз.ПолныйКод(),Тов.ЗаимствованИз);
    СпМат.Установить(Тов.ЗаимствованИз.ПолныйКод(),Тов.ЗаимствованИз.Материал);
    МатВедКол.Установить(Тов.ЗаимствованИз.ПолныйКод(),Колво2);
    Иначе//4
    МатВед.Установить(Тов.ПолныйКод(),Тов);
    СпМат.Установить(Тов.ПолныйКод(),Тов.Материал);
    МатВедКол.Установить(Тов.ПолныйКод(),Колво2);
    КонецЕсли;//4
    КонецЕсли;//3
    Сч=Сч+1;
    Состояние("Обработано "+Сч+" элементов");
    Если ((Тов.Виды.Код="3") или (Тов.Виды.Код="4")) и (Тов.ЗаимствованИз.Наименование<>"") и (Колво1>0) Тогда
    МатСорт1(Тов.ЗаимствованИз,Колво1);
    КонецЕсли; 
    КонецЕсли;//2 
    Иначе//1
    Если (Тов.Виды.Код="7") или (Тов.Виды.Код="8") или (Тов.Виды.Код="9")  тогда//2
    Продолжить;
    КонецЕсли;//2	  
    Колво1=Коэф*ПоискПоДереву(Тов,Мат);
    Колво2=Колво1+МатВедКол.Получить(Тов.ПолныйКод());
    Если (Колво1>0) и (Тов.Материал.Наименование<>"") Тогда//3
    Если ((Тов.Виды.Код="3") или (Тов.Виды.Код="4"))и (Тов.ЗаимствованИз.Наименование<>"") Тогда //4 или (Тов.Виды.Код="4") 
    МатВед.Установить(Тов.ЗаимствованИз.ПолныйКод(),Тов.ЗаимствованИз);
    СпМат.Установить(Тов.ЗаимствованИз.ПолныйКод(),Тов.ЗаимствованИз.Материал);
    МатВедКол.Установить(Тов.ЗаимствованИз.ПолныйКод(),Колво2);
    Иначе//4
    МатВед.Установить(Тов.ПолныйКод(),Тов);
    СпМат.Установить(Тов.ПолныйКод(),Тов.Материал);
    МатВедКол.Установить(Тов.ПолныйКод(),Колво2);
    КонецЕсли;//4
    КонецЕсли;//3
    Сч=Сч+1;
    Состояние("Обработано "+Сч+" элементов");
    Если (Тов.Виды.Код="3") и (Тов.ЗаимствованИз.Наименование<>"") и (Колво1>0) Тогда
    МатСорт1(Тов.ЗаимствованИз,Колво1);
    КонецЕсли; 
    КонецЕсли;//1
    КонецЦикла;
    КонецПроцедуры
    
    [warn="!!! Внимание !!!"]Пользуйтесь тегами[/warn]
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Выложите всю обработку - не понятно что такое Мат. Если это справочник - могу предположить что передаете группу или пустую ссылку
  3. TopicStarter Overlay
    serdel
    Offline

    serdel

    Регистрация:
    29 янв 2010
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Это Справочник!

    Код:
    <pre><FONT COLOR="blue"><FONT FACE="Courier">
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> ВхСч[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> Лим[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> ЛимК[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> АтрН[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> ВрСпр[color=red];[/color]                                           
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> ВрСп[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> Сч[color=red],[/color]Сч1[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> Аттр[color=red];[/color] 
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> ВремМатВед[color=red];[/color]   
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> Карта[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> СпМат[color=red];[/color]                               
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span>  Лист1[color=red];[/color]      
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> Ном[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> Общая_Модель[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> Общая_Группа[color=red];[/color]
    [color=green]//Перем Значение;[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> Дет[color=red],[/color]СбЕд[color=red],[/color]ВзДет[color=red],[/color]ВзСб[color=red],[/color]Узл[color=red],[/color]Станд[color=red],[/color]Покуп[color=red],[/color]Неопозн[color=red],[/color]Матер[color=red],[/color]Крепеж[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> ДетСв[color=red],[/color]СбЕдСв[color=red],[/color]ВзДетСв[color=red],[/color]ВзСбСв[color=red],[/color]УзлСв[color=red],[/color]СтандСв[color=red],[/color]ПокупСв[color=red],[/color]НеопознСв[color=red],[/color]МатерСв[color=red],[/color]КрепежСв[color=red];[/color] 
    [color=green]//перем ДетЦ,СбЕдЦ,ВЗДетЦ,ВзСбЦ,УзлЦ,СтандЦ,НеопознЦ,матерЦ,ПокупЦ,КрепежЦ,Спц;[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> МатВед[color=red],[/color]МатВедКол[color=red];[/color] 
    [color=green]//**************************************************************************************************************[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/функция')">Функция</span> ПоискПоДереву[color=red]([/color]<span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/знач')">Знач</span> Мат[color=red],[/color]<span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/знач')">Знач</span> Узел[color=red])[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span>  Кол[color=red];[/color]
    Кол[color=red]=[/color][color=black]0[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> Мат[color=red].[/color]Код[color=red]=[/color][color=black]""[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">		Возврат</span> Кол[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> Мат[color=red].[/color]ЭтоГруппа[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Мат[color=red].[/color]Родитель[color=red]=[/color]Узел <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Кол[color=red]=[/color][color=black]1[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">		Иначе</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">			Если</span> Мат[color=red].[/color]Уровень[color=red]([/color][color=red])[/color][color=red]>[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Кол[color=red]=[/color]ПоискПоДереву[color=red]([/color]Мат[color=red].[/color]Родитель[color=red],[/color]Узел[color=red])[/color][color=red];[/color]                                    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">			КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">		Возврат</span> Кол[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    Вх[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"Справочник.Вхождения"[/color][color=red])[/color][color=red];[/color]
    [color=green]//	Сообщить(Мат.ПолныйКод()+" "+Мат.Наименование);[/color]
    Вх[color=red].[/color]ИспользоватьВладельца[color=red]([/color]Мат[color=red])[/color][color=red];[/color]
    Вх[color=red].[/color]ВыбратьЭлементы[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">	Пока</span> Вх[color=red].[/color]ПолучитьЭлемент[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Вх[color=red].[/color]Узел[color=red]=[/color]Мат <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/сообщить')">			Сообщить</span>[color=red]([/color][color=black]"Ошибка структуры данных запись с  кодом "[/color][color=red]+[/color]Строка[color=red]([/color]Мат[color=red].[/color]ПолныйКод[color=red]([/color][color=red])[/color][color=red])[/color][color=red]+[/color][color=black]" входит сама в себя"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">	Возврат</span> [color=black]0[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> Вх[color=red].[/color]Узел[color=red]=[/color]Узел <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Кол[color=red]=[/color]Кол[color=red]+[/color]Вх[color=red].[/color]Колво[color=red];[/color] 
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/продолжить')">			Продолжить</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    Кол[color=red]=[/color]Кол[color=red]+[/color]Вх[color=red].[/color]Колво[color=red]*[/color]ПоискПоДереву[color=red]([/color]Вх[color=red].[/color]Узел[color=red],[/color]Узел[color=red])[/color][color=red];[/color]
    [color=green]//Сообщить("1 "+Мат.Материал+"="+Кол+"");[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">	КонецЦикла</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">	возврат</span>  Кол[color=red];[/color] 
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецфункции')">КонецФункции</span>   
    [color=green]//**********************************************************************************************************************[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> МатСорт1[color=red]([/color]<span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/знач')">Знач</span> Мат[color=red],[/color]<span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/знач')">Знач</span> Коэф[color=red]=[/color][color=black]1[/color][color=red])[/color] 
    Вх[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"Справочник.Вхождения"[/color][color=red])[/color][color=red];[/color]
    Спр[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"Справочник.МатВедомость"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> [color=red]([/color]Мат[color=red].[/color]Виды[color=red].[/color]Код[color=red]=[/color][color=black]"3"[/color][color=red])[/color]   <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/или')">или</span> [color=red]([/color]Мат[color=red].[/color]Виды[color=red].[/color]Код[color=red]=[/color][color=black]"4"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span> 
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Мат[color=red].[/color]ЗаимствованИз[color=red].[/color]Наименование[color=red]<[/color][color=red]>[/color][color=black]""[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Гр[color=red]=[/color]Мат[color=red].[/color]ЗаимствованИз[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>
    Гр[color=red]=[/color]Мат[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">	Пока</span> Гр[color=red].[/color]Уровень[color=red]([/color][color=red])[/color][color=red]>[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    Гр[color=red]=[/color]Гр[color=red].[/color]Родитель[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">	КонецЦикла</span>[color=red];[/color]
    Спр[color=red].[/color]ИспользоватьРодителя[color=red]([/color]Гр[color=red])[/color][color=red];[/color]
    Спр[color=red].[/color]ПорядокРеквизита[color=red]([/color][color=black]"Материал"[/color][color=red])[/color][color=red];[/color]
    Спр[color=red].[/color]ВыбратьЭлементы[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">	Пока</span> Спр[color=red].[/color]ПолучитьЭлемент[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    Тов[color=red]=[/color]Спр[color=red].[/color]ТекущийЭлемент[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> СписокЭлементовМФ[color=red].[/color]РазмерСписка[color=red]([/color][color=red])[/color][color=red]>[/color][color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">тогда</span> [color=green]//1[/color]
    [color=green]// Сообщить("1");[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> СписокЭлементовМФ[color=red].[/color]НайтиЗначение[color=red]([/color]Тов[color=red].[/color]материал[color=red])[/color][color=red]<[/color][color=red]>[/color][color=black]0[/color] тогда[color=green]//2  [/color]
    [color=green]//Сообщить("2");[/color]
    
    Колво1[color=red]=[/color]Коэф[color=red]*[/color]ПоискПоДереву[color=red]([/color]Тов[color=red],[/color]Мат[color=red])[/color][color=red];[/color]
    Колво2[color=red]=[/color]Колво1[color=red]+[/color]МатВедКол[color=red].[/color]Получить[color=red]([/color]Тов[color=red].[/color]ПолныйКод[color=red]([/color][color=red])[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> [color=red]([/color]Колво1[color=red]>[/color][color=black]0[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и</span> [color=red]([/color]Тов[color=red].[/color]Материал[color=red].[/color]Наименование[color=red]<[/color][color=red]>[/color][color=black]""[/color][color=red])[/color] Тогда[color=green]//3[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> [color=red]([/color][color=red]([/color]Тов[color=red].[/color]Виды[color=red].[/color]Код[color=red]=[/color][color=black]"3"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/или')">или</span> [color=red]([/color]Тов[color=red].[/color]Виды[color=red].[/color]Код[color=red]=[/color][color=black]"4"[/color][color=red])[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и</span> [color=red]([/color]Тов[color=red].[/color]ЗаимствованИз[color=red].[/color]Наименование[color=red]<[/color][color=red]>[/color][color=black]""[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span> [color=green]//4 или (Тов.Виды.Код="4") [/color]
    МатВед[color=red].[/color]Установить[color=red]([/color]Тов[color=red].[/color]ЗаимствованИз[color=red].[/color]ПолныйКод[color=red]([/color][color=red])[/color][color=red],[/color]Тов[color=red].[/color]ЗаимствованИз[color=red])[/color][color=red];[/color]
    СпМат[color=red].[/color]Установить[color=red]([/color]Тов[color=red].[/color]ЗаимствованИз[color=red].[/color]ПолныйКод[color=red]([/color][color=red])[/color][color=red],[/color]Тов[color=red].[/color]ЗаимствованИз[color=red].[/color]Материал[color=red])[/color][color=red];[/color]
    МатВедКол[color=red].[/color]Установить[color=red]([/color]Тов[color=red].[/color]ЗаимствованИз[color=red].[/color]ПолныйКод[color=red]([/color][color=red])[/color][color=red],[/color]Колво2[color=red])[/color][color=red];[/color]
    Иначе[color=green]//4[/color]
    МатВед[color=red].[/color]Установить[color=red]([/color]Тов[color=red].[/color]ПолныйКод[color=red]([/color][color=red])[/color][color=red],[/color]Тов[color=red])[/color][color=red];[/color]
    СпМат[color=red].[/color]Установить[color=red]([/color]Тов[color=red].[/color]ПолныйКод[color=red]([/color][color=red])[/color][color=red],[/color]Тов[color=red].[/color]Материал[color=red])[/color][color=red];[/color]
    МатВедКол[color=red].[/color]Установить[color=red]([/color]Тов[color=red].[/color]ПолныйКод[color=red]([/color][color=red])[/color][color=red],[/color]Колво2[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color][color=green]//4[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color][color=green]//3[/color]
    Сч[color=red]=[/color]Сч[color=red]+[/color][color=black]1[/color][color=red];[/color]
    Состояние[color=red]([/color][color=black]"Обработано "[/color][color=red]+[/color]Сч[color=red]+[/color][color=black]" элементов"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> [color=red]([/color][color=red]([/color]Тов[color=red].[/color]Виды[color=red].[/color]Код[color=red]=[/color][color=black]"3"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/или')">или</span> [color=red]([/color]Тов[color=red].[/color]Виды[color=red].[/color]Код[color=red]=[/color][color=black]"4"[/color][color=red])[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и</span> [color=red]([/color]Тов[color=red].[/color]ЗаимствованИз[color=red].[/color]Наименование[color=red]<[/color][color=red]>[/color][color=black]""[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и</span> [color=red]([/color]Колво1[color=red]>[/color][color=black]0[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    МатСорт1[color=red]([/color]Тов[color=red].[/color]ЗаимствованИз[color=red],[/color]Колво1[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color] 
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color][color=green]//2 [/color]
    Иначе[color=green]//1[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> [color=red]([/color]Тов[color=red].[/color]Виды[color=red].[/color]Код[color=red]=[/color][color=black]"7"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/или')">или</span> [color=red]([/color]Тов[color=red].[/color]Виды[color=red].[/color]Код[color=red]=[/color][color=black]"8"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/или')">или</span> [color=red]([/color]Тов[color=red].[/color]Виды[color=red].[/color]Код[color=red]=[/color][color=black]"9"[/color][color=red])[/color]  тогда[color=green]//2[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/продолжить')">Продолжить</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color][color=green]//2	  [/color]
    Колво1[color=red]=[/color]Коэф[color=red]*[/color]ПоискПоДереву[color=red]([/color]Тов[color=red],[/color]Мат[color=red])[/color][color=red];[/color]
    Колво2[color=red]=[/color]Колво1[color=red]+[/color]МатВедКол[color=red].[/color]Получить[color=red]([/color]Тов[color=red].[/color]ПолныйКод[color=red]([/color][color=red])[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> [color=red]([/color]Колво1[color=red]>[/color][color=black]0[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и</span> [color=red]([/color]Тов[color=red].[/color]Материал[color=red].[/color]Наименование[color=red]<[/color][color=red]>[/color][color=black]""[/color][color=red])[/color] Тогда[color=green]//3[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> [color=red]([/color][color=red]([/color]Тов[color=red].[/color]Виды[color=red].[/color]Код[color=red]=[/color][color=black]"3"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/или')">или</span> [color=red]([/color]Тов[color=red].[/color]Виды[color=red].[/color]Код[color=red]=[/color][color=black]"4"[/color][color=red])[/color][color=red])[/color]<span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и</span> [color=red]([/color]Тов[color=red].[/color]ЗаимствованИз[color=red].[/color]Наименование[color=red]<[/color][color=red]>[/color][color=black]""[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span> [color=green]//4 или (Тов.Виды.Код="4") [/color]
    МатВед[color=red].[/color]Установить[color=red]([/color]Тов[color=red].[/color]ЗаимствованИз[color=red].[/color]ПолныйКод[color=red]([/color][color=red])[/color][color=red],[/color]Тов[color=red].[/color]ЗаимствованИз[color=red])[/color][color=red];[/color]
    СпМат[color=red].[/color]Установить[color=red]([/color]Тов[color=red].[/color]ЗаимствованИз[color=red].[/color]ПолныйКод[color=red]([/color][color=red])[/color][color=red],[/color]Тов[color=red].[/color]ЗаимствованИз[color=red].[/color]Материал[color=red])[/color][color=red];[/color]
    МатВедКол[color=red].[/color]Установить[color=red]([/color]Тов[color=red].[/color]ЗаимствованИз[color=red].[/color]ПолныйКод[color=red]([/color][color=red])[/color][color=red],[/color]Колво2[color=red])[/color][color=red];[/color]
    Иначе[color=green]//4[/color]
    МатВед[color=red].[/color]Установить[color=red]([/color]Тов[color=red].[/color]ПолныйКод[color=red]([/color][color=red])[/color][color=red],[/color]Тов[color=red])[/color][color=red];[/color]
    СпМат[color=red].[/color]Установить[color=red]([/color]Тов[color=red].[/color]ПолныйКод[color=red]([/color][color=red])[/color][color=red],[/color]Тов[color=red].[/color]Материал[color=red])[/color][color=red];[/color]
    МатВедКол[color=red].[/color]Установить[color=red]([/color]Тов[color=red].[/color]ПолныйКод[color=red]([/color][color=red])[/color][color=red],[/color]Колво2[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color][color=green]//4[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color][color=green]//3[/color]
    Сч[color=red]=[/color]Сч[color=red]+[/color][color=black]1[/color][color=red];[/color]
    Состояние[color=red]([/color][color=black]"Обработано "[/color][color=red]+[/color]Сч[color=red]+[/color][color=black]" элементов"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> [color=red]([/color]Тов[color=red].[/color]Виды[color=red].[/color]Код[color=red]=[/color][color=black]"3"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и</span> [color=red]([/color]Тов[color=red].[/color]ЗаимствованИз[color=red].[/color]Наименование[color=red]<[/color][color=red]>[/color][color=black]""[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и</span> [color=red]([/color]Колво1[color=red]>[/color][color=black]0[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    МатСорт1[color=red]([/color]Тов[color=red].[/color]ЗаимствованИз[color=red],[/color]Колво1[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color] 
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color][color=green]//1[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">	КонецЦикла</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span>
    [color=green]///**********************************************************************************************************************[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> МатСорт[color=red]([/color][color=red])[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> Итог[color=red];[/color] 
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> Итог2[color=red];[/color] 
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> Ед1[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> Ед2[color=red];[/color] 
    
    Итог[color=red]=[/color][color=black]0[/color][color=red];[/color] 
    Итог2[color=red]=[/color][color=black]0[/color][color=red];[/color]
    Сч[color=red]=[/color][color=black]0[/color][color=red];[/color]
    СпМат[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"СписокЗначений"[/color][color=red])[/color][color=red];[/color]
    МатВед[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"СписокЗначений"[/color][color=red])[/color][color=red];[/color]
    МатВедКол[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"СписокЗначений"[/color][color=red])[/color][color=red];[/color] 
    Вход[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"СписокЗначений"[/color][color=red])[/color][color=red];[/color]
    Спр[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"Справочник.Матведомость"[/color][color=red])[/color][color=red];[/color]
    Изд[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"Справочник.Изделия"[/color][color=red])[/color][color=red];[/color]
    Таб[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"Таблица"[/color][color=red])[/color][color=red];[/color]
    Вх[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"Справочник.Вхождения"[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ИсходнаяТаблица[color=red]([/color][color=black]"МатСорт"[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ПараметрыСтраницы[color=red]([/color][color=black]1[/color][color=red],[/color][color=black]100[/color][color=red],[/color][color=black]1[/color][color=red],[/color][color=black]10[/color][color=red],[/color][color=black]5[/color][color=red],[/color][color=black]5[/color][color=red],[/color][color=black]5[/color][color=red],[/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]Опции[color=red]([/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color][color=black]4[/color][color=red],[/color][color=black]3[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ПовторятьПриПечатиСтроки[color=red]([/color][color=black]4[/color][color=red],[/color][color=black]4[/color][color=red])[/color][color=red];[/color] [color=green]///////проба[/color]
    [color=green]//	Тов=ТекущийЭлемент();                         [/color]
    [color=green]//	Спр.НайтиЭлемент(Тов);[/color]
    Спр[color=red].[/color]ВыборГруппы[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> Спр[color=red].[/color]Выбрать[color=red]([/color][color=black]"Выберите Узел"[/color][color=red],[/color][color=black]""[/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Тов[color=red]=[/color]Спр[color=red].[/color]ТекущийЭлемент[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">		Возврат</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    Гр[color=red]=[/color]Тов[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">	Пока</span> Гр[color=red].[/color]Уровень[color=red]([/color][color=red])[/color][color=red]>[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    Гр[color=red]=[/color]Гр[color=red].[/color]Родитель[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">	КонецЦикла</span>[color=red];[/color]     
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> Изд[color=red].[/color]НайтиПоРеквизиту[color=red]([/color][color=black]"Обозначение"[/color][color=red],[/color]Гр[color=red],[/color][color=black]1[/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Общая_Модель[color=red]=[/color]Изд[color=red].[/color]Номер[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>
    Общая_Модель[color=red]=[/color]Сред[color=red]([/color]Гр[color=red].[/color]Наименование[color=red],[/color][color=black]3[/color][color=red],[/color][color=black]3[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Заголовок"[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Шапка"[/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Шапка2"[/color][color=red])[/color][color=red];[/color]
    МатСорт1[color=red]([/color]Тов[color=red],[/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    Цик[color=red]=[/color][color=black]1[/color][color=red];[/color]
    СпМат[color=red].[/color]Сортировать[color=red]([/color][color=black]0[/color][color=red])[/color][color=red];[/color]
    СМатер[color=red]=[/color][color=black]0[/color][color=red];[/color]
    Ном[color=red]=[/color][color=black]0[/color][color=red];[/color]
    
    Сч[color=red]=[/color][color=black]0[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">	Пока</span> Цик[color=red]<[/color][color=red]=[/color]СпМат[color=red].[/color]РазмерСписка[color=red]([/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span> 
    Ном[color=red]=[/color]Ном[color=red]+[/color][color=black]1[/color][color=red];[/color]
    ТовКод[color=red]=[/color][color=black]0[/color][color=red];[/color]
    СпМат[color=red].[/color]ПолучитьЗначение[color=red]([/color]Цик[color=red],[/color]ТовКод[color=red])[/color][color=red];[/color]
    Матер[color=red]=[/color]СпМат[color=red].[/color]Получить[color=red]([/color]ТовКод[color=red])[/color][color=red];[/color]
    Тов[color=red]=[/color]МатВед[color=red].[/color]Получить[color=red]([/color]ТовКод[color=red])[/color][color=red];[/color]
    Колво1[color=red]=[/color]МатВедКол[color=red].[/color]Получить[color=red]([/color]ТовКод[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> СМатер[color=red]<[/color][color=red]>[/color]Матер <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СМатер[color=red]=[/color]Матер[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">			Если</span> Сч[color=red]>[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">тогда</span> 
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Итого"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">				Если</span> Итог2[color=red]<[/color][color=red]>[/color][color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">тогда</span>
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Итого2"[/color][color=red])[/color][color=red];[/color] 
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">				КонецЕсли</span>[color=red];[/color]	 
    таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Пусто"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">			КонецЕсли</span>[color=red];[/color]
    Итог[color=red]=[/color][color=black]0[/color][color=red];[/color]
    Итог2[color=red]=[/color][color=black]0[/color][color=red];[/color] 
    Сч[color=red]=[/color][color=black]0[/color][color=red];[/color]
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Сек"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    [color=green]//Рассчет модели[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> [color=red]([/color][color=red]([/color]Тов[color=red].[/color]Виды[color=red].[/color]Код[color=red]=[/color][color=black]"3"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/или')">или</span> [color=red]([/color]Тов[color=red].[/color]Виды[color=red].[/color]Код[color=red]=[/color][color=black]"4"[/color][color=red])[/color][color=red])[/color]  <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и</span> [color=red]([/color]Тов[color=red].[/color]ЗаимствованИз[color=red].[/color]Наименование[color=red]<[/color][color=red]>[/color][color=black]""[/color][color=red])[/color] Тогда[color=green]// или (Тов.Виды.Код="4")[/color]
    МодГр[color=red]=[/color]Тов[color=red].[/color]ЗаимствованИз[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">		Пока</span> МодГр[color=red].[/color]Уровень[color=red]([/color][color=red])[/color][color=red]>[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    МодГр[color=red]=[/color]МодГр[color=red].[/color]Родитель[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">		КонецЦикла</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Изд[color=red].[/color]НайтиПоРеквизиту[color=red]([/color][color=black]"Обозначение"[/color][color=red],[/color]МодГр[color=red],[/color][color=black]1[/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Модель[color=red]=[/color]Изд[color=red].[/color]Номер[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">		Иначе</span>
    МодГр[color=red]=[/color]Тов[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">		Пока</span> МодГр[color=red].[/color]Уровень[color=red]([/color][color=red])[/color][color=red]>[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    МодГр[color=red]=[/color]МодГр[color=red].[/color]Родитель[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">		КонецЦикла</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Изд[color=red].[/color]НайтиПоРеквизиту[color=red]([/color][color=black]"Обозначение"[/color][color=red],[/color]МодГр[color=red],[/color][color=black]1[/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Модель[color=red]=[/color]Изд[color=red].[/color]Номер[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">		Иначе</span>
    Модель[color=red]=[/color]Сред[color=red]([/color]МодГр[color=red].[/color]Наименование[color=red],[/color][color=black]3[/color][color=red],[/color][color=black]3[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Модель[color=red]=[/color]Общая_Модель <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Модель[color=red]=[/color][color=black]""[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    
    [color=green]//Рассчет окончен                                   [/color]
    
    Вх[color=red].[/color]ИспользоватьВладельца[color=red]([/color]Тов[color=red])[/color][color=red];[/color]
    Вх[color=red].[/color]ВыбратьЭлементы[color=red]([/color][color=red])[/color][color=red];[/color] 
    Вх[color=red].[/color]ПолучитьЭлемент[color=red]([/color][color=red])[/color][color=red];[/color]
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Данные"[/color][color=red])[/color][color=red];[/color]
    Итог[color=red]=[/color]Итог[color=red]+[/color]Тов[color=red].[/color]НормаРасхода[color=red]*[/color]Колво1[color=red];[/color]         
    Итог2[color=red]=[/color]Итог2[color=red]+[/color]Тов[color=red].[/color]Норма2[color=red]*[/color]Колво1[color=red];[/color]
    Сч[color=red]=[/color]Сч[color=red]+[/color][color=black]1[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Тов[color=red].[/color]Норма2[color=red]<[/color][color=red]>[/color][color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">тогда</span>  
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Данные2"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		Конецесли</span>[color=red];[/color]
    Ед1[color=red]=[/color]Тов[color=red].[/color]ЕдиницыИзмерения[color=red];[/color]
    Ед2[color=red]=[/color]Тов[color=red].[/color]Ед2[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">		Пока</span> Вх[color=red].[/color]ПолучитьЭлемент[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">цикл</span>
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Вх"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">		КонецЦикла</span>[color=red];[/color]	 
    Цик[color=red]=[/color]Цик[color=red]+[/color][color=black]1[/color][color=red];[/color] 
    Таб[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Пусто"[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">	КонецЦикла</span>[color=red];[/color] 
    
    Таб[color=red].[/color]Показать[color=red]([/color][color=red])[/color][color=red];[/color]
    СпМат[color=red].[/color]УдалитьВсе[color=red]([/color][color=red])[/color][color=red];[/color]
    МатВед[color=red].[/color]УдалитьВсе[color=red]([/color][color=red])[/color][color=red];[/color]
    МатВедКол[color=red].[/color]УдалитьВсе[color=red]([/color][color=red])[/color][color=red];[/color]
    Сигнал[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span>  
    [color=green]//*******************************************************************************************************[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> РаботаСТаблицейМФ[color=red]([/color]Режим[color=red])[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> ТекПоз[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> ТекЭлемент[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> ФормаПодбора[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> ВидЗначенияПодбора[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> СправочникПодбора[color=red];[/color]             
    
    ТекПоз [color=red]=[/color] СписокЭлементовМФ[color=red].[/color]ТекущаяСтрока[color=red]([/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ТекПоз[color=red]>[/color][color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span> [color=green]// текущий элемент, спозиционируем на него[/color]
    ТекЭлемент[color=red]=[/color]СписокЭлементовМФ[color=red].[/color]ПолучитьЗначение[color=red]([/color]ТекПоз[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> [color=red]([/color]Режим[color=red]=[/color][color=black]"Добавить"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/или')">или</span> [color=red]([/color]Режим[color=red]=[/color][color=black]"ДобавитьНесколько"[/color][color=red])[/color]  Тогда		[color=green]// добавляем в список один элемент[/color]
    
    Зн [color=red]=[/color] [color=black]""[/color][color=red];[/color]
    
    [color=green]// открываем окно подбора                         [/color]
    ОткрытьПодбор[color=red]([/color][color=black]"Справочник.Материалы"[/color][color=red],[/color][color=black]"ФормаСписка"[/color][color=red],[/color]ФормаПодбора[color=red],[/color][color=red]?[/color][color=red]([/color]Режим[color=red]=[/color][color=black]"ДобавитьНесколько"[/color][color=red],[/color][color=black]1[/color][color=red],[/color][color=black]0[/color][color=red])[/color][color=red],[/color]ТекЭлемент[color=red])[/color][color=red];[/color]
    ФормаПодбора[color=red].[/color]ВыборГруппы[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color]                                      
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">	ИначеЕсли</span> Режим[color=red]=[/color][color=black]"УдалитьВсе"[/color] Тогда	[color=green]// удаляем все элементы из списка[/color]
    СписокЭлементовМФ[color=red].[/color]УдалитьВсе[color=red]([/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">	ИначеЕсли</span> Режим[color=red]=[/color][color=black]"Удалить"[/color] Тогда	[color=green]// удаляем из списка один элемент[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> ТекПоз [color=red]>[/color][color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СписокЭлементовМФ[color=red].[/color]УдалитьЗначение[color=red]([/color]ТекПоз[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">			Если</span> СписокЭлементовМФ[color=red].[/color]РазмерСписка[color=red]([/color][color=red])[/color][color=red]>[/color]ТекПоз  <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СписокЭлементовМФ[color=red].[/color]ТекущаяСтрока[color=red]([/color]ТекПоз[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">			Иначе</span> [color=green]// поставим на последний элемент[/color]
    СписокЭлементовМФ[color=red].[/color]ТекущаяСтрока[color=red]([/color]СписокЭлементовМФ[color=red].[/color]РазмерСписка[color=red]([/color][color=red])[/color][color=red])[/color]<span style='color:red'>;</span
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Посмотри, реквизит Виды назначен для элемента или для группы тоже?

    Попробуй добавить условие
    Код:
    Если Мат.ЭтоГруппа()=1 Тогда
    Возврат;
    КонецЕсли;
    
    
  5. TopicStarter Overlay
    serdel
    Offline

    serdel

    Регистрация:
    29 янв 2010
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Ошибка именно в этом фрагменте!!!
    Код:
    //Рассчет модели
    Если ((Тов.Виды.Код="3") или (Тов.Виды.Код="4")) и (Тов.ЗаимствованИз<>"") Тогда //4 или (Тов.Виды.Код="4")
    МодГр=Тов;
    Пока МодГр.Уровень()>1 Цикл
    МодГр=МодГр.Родитель;
    КонецЦикла; 
    Если Изд.НайтиПоРеквизиту("Обозначение",МодГр,1)=1 Тогда
    Модель=Изд.Номер;
    КонецЕсли;
    Иначе
    МодГр=Тов;
    Пока МодГр.Уровень()>1 Цикл
    МодГр=МодГр.Родитель;
    КонецЦикла;
    Если Изд.НайтиПоРеквизиту("Обозначение",МодГр,1)=1 Тогда
    Модель=Изд.Номер;
    Иначе
    Модель=Сред(МодГр.Наименование,3,3);
    КонецЕсли;
    КонецЕсли;
    
    Если Модель=Общая_Модель Тогда
    Модель="";
    КонецЕсли;
    
    //Рассчет окончен
    
    
    [warn="!!! Внимание !!!"]Пользуйтесь тегами[/warn]
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Код:
    Если Тов.ЭтоГруппа()=1 Тогда
    Возврат;
    КонецЕсли;
    Если ((Тов.Виды.Код="3") или (Тов.Виды.Код="4")) и (Тов.ЗаимствованИз<>"") Тогда //4 или (Тов.Виды.Код="4")
    
    
    
  7. TopicStarter Overlay
    serdel
    Offline

    serdel

    Регистрация:
    29 янв 2010
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Теперь это.....
    Если Тов.ЭтоГруппа()=1 Тогда
    {E:\1C\БАЗА ТЕХОТДЕЛА\МАТВЕДОМОСТЬ\EXTFORMS1\СОРТИРОВКАДЛЯСНАБЖЕНИЯЗА.ERT(200)}: Значение не представляет агрегатный объект (ЭтоГруппа)
  8. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    Выложите всю обработку - это не текст обработки
    прикрепите сюда уже саму обработку
  9. TopicStarter Overlay
    serdel
    Offline

    serdel

    Регистрация:
    29 янв 2010
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1

    Вложения:

  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Говорил же вам... Проверка пустого значения и группы
    Код:
    Если ПустоеЗначение(Тов)=1 Тогда 
    Возврат;
    КонецЕсли;
    Если Тов.ЭтоГруппа()=1 Тогда 
    Возврат;
    КонецЕсли;
    Если ((Тов.Виды.Код="3") или (Тов.Виды.Код="4")) и (Тов.ЗаимствованИз<>"") Тогда
    
    
  11. TopicStarter Overlay
    serdel
    Offline

    serdel

    Регистрация:
    29 янв 2010
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Щас посмотрим...
  12. TopicStarter Overlay
    serdel
    Offline

    serdel

    Регистрация:
    29 янв 2010
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Спасибо огромное разобрался!

Поделиться этой страницей